Contribute
Register

[Guide] Asus ROG G73JH using Clover UEFI

Joined
Aug 31, 2014
Messages
266
Motherboard
Asus T300LA-DH51T
CPU
Intel Core i5 4200U
Graphics
Intel HD Graphics 4400
Mobile Phone
Android
Asus G73JH-X1 Functional clover installs and upgrades tested from 10.9.4 to 10.13.4
(10.9.4 is when i switched to Clover UEFI not the minimum OS supported)

Notes:
  • MAKE SURE YOUR CLOVER BUILD CONTAINS EMULATED NVRAM & APTIOMEMORYFIX
  • Tonymacx86 Clover Legacy mode version may work but it is not supported by this guide.
    No other Tonymacx86 builds will work because they do not use AptioMemoryfix
  • I could only get the installer to boot by going into the bios and selecting the UEFI USB device
  • Custom Fusion Drives supported but not worth it.
  • You can't push button OC but you can still OC with Turbo Mode BIOS Setting
  • I am using APFS on my SSD but this guide does not cover usage
Hardware -
  • Processor:Intel Core i7-720QM - Bios Setting Asus Overclock to Turbo supported
  • Chipset: HM55 - config.plist
  • Battery: Status Indicator - Works ACPIBatteryManager.kext, SSDT-BATT
  • Graphics: AMD Mobilty Radeon 5870M Works Clover config.plist kext patches, SSDT-GFX0
  • Wifi: Atheros 9285(AR5B95) - SSDT-WLAN
  • Ethernet: Atheros 8131 - Works AtherosL1cEthernet.kext
  • Bluetooth: ASUS BT-270(BRCM1043) - Works BRCMNonPatchRAM2.kext
  • Card Reader: Alcor USB - Works OOB
  • Camera: ASUS UVC - Works OOB
  • Audio: Realtek ALC269 - Works G73JH.kext(contains dummy HDA), SSDT-HDEF
  • Keyboard & Trackpad - Synaptics Touchpad: Works VoodooPS2Controller.kext
  • Fn Keys - Works AsusHotKeys.kext
  • Keyboard Backlight - Works SSDT-MISC
Setup -
  • Bios settings
    • Enable UEFI Boot
    • Disable Intel Virtualization
    • Disable VT-D
    • Add New Boot option
      • Name: Clover
      • Disk: Select the drive with Clover and macOS installed
      • Path type "EFI\Boot\Bootx64.efi"
  • Create Clover UEFI USB macOS installer
    • EmuVariableUefi-64AptioMemoryFix driver required
  • Extracted DSDT/SSDT's(Boot Clover press F4 stored in \EFI\Clover\ACPI\Origin\)
  • MaciASL for SSDT's
  • Clover Config.plist - https://github.com/Maromi-/G73JH-OSX
    • SMBIOS serial# is not configured
    • Clover Hotpatch
Kexts - https://github.com/RehabMan?tab=repositories
  • Place files in EFI/CLOVER/kexts/other (remove all numbered folders)
  • FakeSMC
  • VoodooPS2Controller
DSDT/SSDT - https://github.com/Maromi-/G73JH-OSX/tree/master/Hotpatch
  • Download Hotpatch files
  • Open Hotpatch files in MaciASL save each file as filetype aml binary to \EFI\Clover\ACPI\Patched
  • Copy DSDT.aml from \EFI\Clover\ACPI\Origin to patched folder

Post Installation - Use kext installer to install below kexts to /S*/L*/Extensions
  • FakeSMC
  • VoodooPS2Controller
  • G73JH - https://github.com/Maromi-/G73JH-OSX
  • CodecCommander
  • ACPIBatteryManager
  • AsusHotkeys(Fn Keys) Not open source and not really needed
  • AtherosL1cEthernet
  • BRCMNonPatchRAM2
 
Last edited:
Joined
Aug 31, 2014
Messages
266
Motherboard
Asus T300LA-DH51T
CPU
Intel Core i5 4200U
Graphics
Intel HD Graphics 4400
Mobile Phone
Android
Update: Guide will be switching to Clover Hotpatch Guide as soon i get around to creating SSDT-BATT.
Update1:Guide has been converted. If you want to try it you also have to use the config.plist
Update2:Tested Tonymacx86 Clover builds. Clover Legacy mode version may work but it is not supported by this guide.
No other Tonymacx86 builds will work because they do not use AptioMemoryfix or OsxAptioFixDrv
Update3:Testing AptioMemoryFIx without emulated NVRAM.https://www.tonymacx86.com/threads/guide-asus-rog-g73jh-using-clover-uefi.242770/#post-1695198
 
Last edited:
Joined
Aug 31, 2014
Messages
266
Motherboard
Asus T300LA-DH51T
CPU
Intel Core i5 4200U
Graphics
Intel HD Graphics 4400
Mobile Phone
Android
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
We have working NVRAM without emulation!!!
remove emulated nvram with https://www.tonymacx86.com/resources/clover-emulated-nvram-uninstaller.368/
DO NOT USE any Tonymacx86 clover builds
Update Clover with the regular build because it contains AptioMemoryfix use it instead of OsxAptioFixDrv*
Remove any OsxAptioFixDrv* from "/EFI/CLOVER/drivers64UEFI"
reboot
AptioMemoryFix.efi is in my Clover build...
Note that this is already documented in the guide (quite a while ago)...
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Aug 31, 2014
Messages
266
Motherboard
Asus T300LA-DH51T
CPU
Intel Core i5 4200U
Graphics
Intel HD Graphics 4400
Mobile Phone
Android

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Most people are going to try the easy way with the builds hosted here or ughh... sourceforge. I didn't know you had builds, I personally just build it, I would definitely place your builds above the others mentioned.
Yeah, I always build things from source, almost never using prebuilt's by others, even when I don't have any changes planned.
But I recommend my version of Clover from the guide as it has the "Boot without caches (-f)" option and probably a few other differences/fixes.
I'm actively building and testing new AptioMemoryFix.efi changes as they are pushed to github, and will generally include the latest version in my Clover pkg if I happen to push a new build of my Clover fork to bitbucket.
 
Joined
Jun 13, 2012
Messages
55
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i5 8400
Graphics
UHD 630
Hi,
When installing via USB, I'm stuck at "AptioMemoryFix(R9): Starting \.IABootFiles\boot.efi"
 

Attachments

Joined
Aug 31, 2014
Messages
266
Motherboard
Asus T300LA-DH51T
CPU
Intel Core i5 4200U
Graphics
Intel HD Graphics 4400
Mobile Phone
Android
Attention: If you are using an SSD and AFPS. The latest efi driver 10.13.4 apfs.efi seems to be broken for me. I can get it to boot but performance too slow. I rolled back to the previous version works fine again. If you aren't having issues ignore this message.

FYI i am using an intel SSD and also my guide does not cover apfs usage:p

Issue resolved in 10.13.4 security update
 
Last edited:
Top