Contribute
Register

guide asrock z77 pro3 bios 1.90 patched

Joined
Feb 3, 2011
Messages
1,403
Motherboard
ASRock Pro 3-2.10
CPU
i5-3570K
Graphics
HD 4000
guide asrock z77 pro3 bios 1.90

1. patch your bois with pmpatch or http://biosrepo.wordpress.com/2. bois config oc tweaker change cpu ratio to per core other wise sleep wont work,disable internal pll over voltage.
3.advaced north bridge config, primary graphics adapter pci express,shared memory to 32mb if set to 64mb wont boot.
4.storage config ahci and set osx hdd to hot plug disabled other wise it will be shown as external
5.super io config disable serial port.
6.dont change anything else in bois its not needed save and exit.
7.for power management and system defs MacMini6,1 for i5 and i7 6,2 these r for ivy mobo/cpus dont use 13,1 or 13,2 only has 2 p states. asrock z77 pro3 is in the repo pjalm/toleda patches work great with no issues
8.this build is working 100% including sleep havent tested airplay i have no need for it
note if using more than 4gb ram for install use flag maxmem= amount of ram u have minus 2gb example 16 gb=14336

Trouble shooting guide. boot with -v verbose this works with all osx versions

Please remove any hardware thats not needed for install such as extra hdds,pci/pcie cards all of them if u have an incompatible hardware you will get iobluetooth hang can be caused by gfx/fakesmc kext if not loaded.lans such as bcm or killer nics should be disabled in bios for a fresh install.Disable vt-d in bios if your cpu has vt-d use flag dart=0 If u get a kp=kernel panic it because your hardware is incompatible or a bad kext in the efi/efi/kexts/other folder.Boot flags reboot system when you see the bootloader u have 5 secs to act press the spacebar.Now put in each pcie/pci device one at a time and reboot with -v each time to make sure theres no issues.If u get pci config begin then add flag npci=0x2000 or npci=0x3000 for nvida cards. System defs if you choose wrong smbios use SMBIOS=Null flag.Thanks for reading this boring guide. If you have any complaints keep it to yourself.

system freezes

a bad stick of ram or a bad dim port or you have xmp enabled in bios or your using dual channel and need to increase ram voltage,ssd needs firmware update,ssd has trim enabled check your ssd manufacture for details some ssd will freeze if trim enabled,or fakesmc plugins is causing this or a failing psu. bad kexts such as lan will too.
 

Attachments

Last edited:
Joined
Aug 27, 2012
Messages
4
Motherboard
Gigabyte Q9550
CPU
Q9550
Graphics
NV GT9800 + GT210
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Mobile Phone
iOS
Thanks.. did the same and got it working 100%

My setup i7 3770, Z77Pro3 1.90 patched BIOS, 8GB RAM 1600MHZ, 1TB SAMSUNG SATA

I started a clean install with 10.8 ML using Multibeast 5.4.1 (User DSDT / w/o DSDT -ALC892, Disc- 3rd party SATA, Misc - Fake SMC, Network, Lnx2Mac RT81xx, Bootloader - Chimera 2.1.1, Boot options - GE=No, 1080p, Power Mgmt Hibernate mode - Desktop, System definitions - Macmini 6,2)

Upgraded to 10.8.4 using the combo download and encountered various kp. Doing the below solved the problem.

- I installed PJALM patch for ASROCK. This created the DSDT.aml and patched it with the PJALM patch.. http://www.tonymacx86.com/dsdt/100182-pjalms-dsdt-patches.html

- created the ssdt.aml with the SSDT generator .... http://www.tonymacx86.com/ssdt/86906-ssdt-generation-script-ivybridge-pm-49.html

- Next added Toledo patch for HDMI audio over the DSDT.aml created by PJAML ... http://www.tonymacx86.com/hdmi-audio/100492-easy-guide-ml-uefi-hdmi-audio-13.html

System is fully working.. Thanks to Stehor, PJAML and Toledo...
 
Joined
Mar 24, 2011
Messages
1,300
Motherboard
ASUS Z10PE-D8 WS
CPU
2x Intel Xeon E5-2683 v3
Graphics
Sapphire AMD FirePro W9100
Mac
Classic Mac
Mobile Phone
Thanks.. did the same and got it working 100%

My setup i7 3770, Z77Pro3 1.90 patched BIOS, 8GB RAM 1600MHZ, 1TB SAMSUNG SATA

I started a clean install with 10.8 ML using Multibeast 5.4.1 (User DSDT / w/o DSDT -ALC892, Disc- 3rd party SATA, Misc - Fake SMC, Network, Lnx2Mac RT81xx, Bootloader - Chimera 2.1.1, Boot options - GE=No, 1080p, Power Mgmt Hibernate mode - Desktop, System definitions - Macmini 6,2)

Upgraded to 10.8.4 using the combo download and encountered various kp. Doing the below solved the problem.

- I installed PJALM patch for ASROCK. This created the DSDT.aml and patched it with the PJALM patch.. http://www.tonymacx86.com/dsdt/100182-pjalms-dsdt-patches.html

- created the ssdt.aml with the SSDT generator .... http://www.tonymacx86.com/ssdt/86906-ssdt-generation-script-ivybridge-pm-49.html

- Next added Toledo patch for HDMI audio over the DSDT.aml created by PJAML ... http://www.tonymacx86.com/hdmi-audio/100492-easy-guide-ml-uefi-hdmi-audio-13.html

System is fully working.. Thanks to Stehor, PJAML and Toledo...
You really did not need to apply Toledas patch for HDMI audio as I do include his.
 
Joined
Aug 27, 2012
Messages
4
Motherboard
Gigabyte Q9550
CPU
Q9550
Graphics
NV GT9800 + GT210
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Mobile Phone
iOS
Odd. My HDMI install did not give audio till I installed the Toledo patch.

Probably I missed a step somewhere.
 
Joined
Jan 23, 2013
Messages
11
Motherboard
i5 3570k
CPU
4,2
Graphics
GTX460/HD4000
Mac
Mac Pro
Classic Mac
Mobile Phone
Android
1. patch your bois with pmpatch or http://biosrepo.wordpress.com/2. bois config oc tweaker change cpu ratio to per core other wise sleep wont work,disable internal pll over voltage.
3.advaced north bridge config, primary graphics adapter pci express,shared memory to 32mb if set to 64mb wont boot.
4.storage config ahci and set osx hdd to hot plug disabled other wise it will be shown as external
5.super io config disable serial port.
6.dont change anything else in bois its not needed save and exit.
7.for power management and system defs MacMini6,1 for i5 and i7 6,2 these r for ivy mobo/cpus dont use 13,1 or 13,2 only has 2 p states. asrock z77 pro3 is in the repo pjalm/toleda patches work great with no issues
8.this build is working 100% including sleep havent tested airplay i have no need for it

trouble shooting boot with -v verbose this works with all osx versions

please remove any hardware thats not needed for install such as extra hdds,pci/pcie cards all of them if u have an incompatible hardware u will get iobluetooth hang also disable vt-d,ieee 1394,lan, if u get a kp=kernel panic it because u made a bad multibeast choice or hardware is incompatible or a bad kext in the extensions folder. theres no support for vga except on old 8xxx and 9xxx nvida gfx cards. if u get gray screen,black,no signal u have gfx issues. boot flags reboot system when u see the tmx apple u have 5 secs to act press the spacebar. example u have gfx issues chimera defaults are GE=YES PCIRoot=1 npci=0x2000 if not working then use GE=NO or PCIRootUID=0,1,2,3,4,5 if u have nvida 6xx use flag GE=NO now put in each pcie/pci device one at a time and reboot with -v each time to make sure theres no issues. if for some reason u cant disable vt-d in bios and your cpu has it u need this flag dart=0 it will disable vt-d if u get pci config begin then add flag npci=0x3000 or npci=0x2000 or pci=no edit note for gfx dont open plist with chameleon wizard it will break gfx support if using my .plist system defs if using ivy mobo/cpu use MacMini6,1 for i5 for i7 6,2 dont use 13,1 or 13,2 it only has 2 p states then use prgen for ssdt for proper p states make sure its in the extra folder as SSDT.aml if u hang at lnx2mac its gfx issues usally if usb issues use flag USBBusFix=YES


system freezes

a bad stick of ram download memtest86 or a bad dim port,ssd needs firmware update,ssd has trim enabled,or fakesmc plugin is causing this
Hello stehor.


Could you tell me the full process to function correctly my hack?
I have the same board and micro your ... bios asrock z77 pro 3 2.10/i5 3570K.
As I set my bios if I want to use my geforce GTX460?
Nor is whether I have the bios really patchy, but the issue of gfx worries me more.


I've tried too many times to continue without help.


thanks
 
Joined
Feb 3, 2011
Messages
1,403
Motherboard
ASRock Pro 3-2.10
CPU
i5-3570K
Graphics
HD 4000
use pciexpress for hd4000 or gfx card I tested both and use 32mb shared for hd4000. my install method using my MacMini6,2 go into disk utility and choose restore to a external hdd I used a 2nd psu to power the ssd then run multibeast on the restored hdd and put it in your hack build. I prefer this method because a lot of folks have issues with unibeast
 
Joined
Jan 23, 2013
Messages
11
Motherboard
i5 3570k
CPU
4,2
Graphics
GTX460/HD4000
Mac
Mac Pro
Classic Mac
Mobile Phone
Android
Hello Stehor.


I have long been trying to build my hackintosh.
Currently I have GTX460 graphics and dream without DSDT and Kext.
But I can not have audio!
I tried unsuccessfully pjalm and Toleda.
My team is the same as yours and I have the bios patched to 1.90 because I can not update to 2.10.
I'm in 10.9 Mavericks.
That I can be doing wrong?
You can help me.:beachball:
 
Joined
Feb 3, 2011
Messages
1,403
Motherboard
ASRock Pro 3-2.10
CPU
i5-3570K
Graphics
HD 4000
I suspect the reason u r having issues is the ml dvd which isn't a supported install method by this site or me. supported methods clover plus ml on usb stick 2 partions,unibeast+ml,from a real mac disk utility restore to a new hdd then run multibeast and put in hack.this mobo runs sl,ml,mavs with no issues.
 
Top