Contribute
Register

[Guide] Alienware-17-R4-Dual-GPU-MacOS-Catalina-10.15-Hackintosh

Status
Not open for further replies.
Joined
Jul 9, 2016
Messages
46
Motherboard
Alienware 17 R4 / OC
CPU
i7 7700HQ
Graphics
GTX 1060 / Intel 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
Arg. Now I am more confused. USB started working, I didn't change anything, didn't even reboot. Machine went to sleep I guess while I was on my main Mac researching... Walked over and woke it up with the power button and unlocked it. External mouse was working. So I plugged in a USB controller, it worked too and I played a quick game to test graphics performance. All was fine. So I thought the trick was make it sleep, wake it up. I rebooted, and now I can't get USB working again.......
 
Joined
Jul 9, 2016
Messages
46
Motherboard
Alienware 17 R4 / OC
CPU
i7 7700HQ
Graphics
GTX 1060 / Intel 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
I let it sit again and it went to sleep. When I woke it, USB is working again until my next reboot. I don't get it...but I can work with that.

Last remaining issue...can't the internal speakers and microphone be made to work? It pretends with the volume up down, but there is never any audio... What is wrong making that fail?

Validated working:
GTX1060
Camera
Ethernet
Headphones
HDMI
SSD & 1TB platter drive
External USB after machine sleeps from being idle
Internal Microphone
(waiting for WiFi/Bluetooth adapter to arrive...)

Not working:
Internal speakers
USB after boot...needs idle sleep to become active.
 
Last edited:
Joined
Oct 18, 2019
Messages
12
Motherboard
alienware 17 r4
CPU
i7 7700hq
Graphics
gtx 1060
I let it sit again and it went to sleep. When I woke it, USB is working again until my next reboot. I don't get it...but I can work with that.

Last remaining issue...can't the internal speakers and microphone be made to work? It pretends with the volume up down, but there is never any audio... What is wrong making that fail?

Validated working:
GTX1060
Camera
Ethernet
Headphones
HDMI
SSD & 1TB platter drive
External USB after machine sleeps from being idle
(waiting for WiFi/Bluetooth adapter to arrive...)

Not working:
Internal speakers and microphone
USB after boot...needs idle sleep to become active.
update bios version and clean nvram
 
Joined
Jul 9, 2016
Messages
46
Motherboard
Alienware 17 R4 / OC
CPU
i7 7700HQ
Graphics
GTX 1060 / Intel 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
BIOS is at 1.7. You had said yours was at 1.5. Do I need to downgrade? Or do you have a recommended version I should update to? I'm installing windows now as this laptop currently only has macOS on it. Then I'm updating to 1.9....
 
Joined
Jul 9, 2016
Messages
46
Motherboard
Alienware 17 R4 / OC
CPU
i7 7700HQ
Graphics
GTX 1060 / Intel 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
Installed Win10, screwed up my boot management now. Flashed BIOS 1.5. Booted in 10.13, no internal sound. Flashed BIOS 1.9. Booted in 10.13, no internal sound. So 1.5, 1.7, and 1.9 aren't working for internal sound for me. Windows obviously worked for internal sound, so I know speakers work as the Cortana crap greeted me.

Edit: Fixed my boot issue, Windows had modified my EFI partition on my SSD drive and not he 1TB platter HD.
 
Last edited:
Joined
Jul 9, 2016
Messages
46
Motherboard
Alienware 17 R4 / OC
CPU
i7 7700HQ
Graphics
GTX 1060 / Intel 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
OK, everything back to normal now with dual boot. But still no sound on macOS.

BIOS 1.5, 1.7, 1.9 didn't help sound. What can I verify to know if its correct? I am using your OCv6 files from github...
 
Joined
Jul 9, 2016
Messages
46
Motherboard
Alienware 17 R4 / OC
CPU
i7 7700HQ
Graphics
GTX 1060 / Intel 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
And I am now having a serious doubt...even though nvidia web drivers are installed, and the OS clearly can see the gtx1060 from about this mac, system report...I don't think the card is ever being activated... I saw this because a game I played from Steam on macOS was terrible compared to how the identical game was on Windows...in fact I would say its performance was Intel 630 speed... 1080p full graphic options, perfectly smooth and high frame rate in windows. When tried on OSX, it was impossible and very slow. I even tried via HDMI to external 4k monitor at 1080p and it too was slow.

What was this fn-f7 stuff about NVIDIA? fn-f7 does nothing for me in macOS nor in Windows...

Maybe this game just doesn't run well on the Mac...but it feels like I never got the benefit fo the graphics card...
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,379
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
And I am now having a serious doubt...even though nvidia web drivers are installed, and the OS clearly can see the gtx1060 from about this mac, system report...I don't think the card is ever being activated... I saw this because a game I played from Steam on macOS was terrible compared to how the identical game was on Windows...in fact I would say its performance was Intel 630 speed... 1080p full graphic options, perfectly smooth and high frame rate in windows. When tried on OSX, it was impossible and very slow. I even tried via HDMI to external 4k monitor at 1080p and it too was slow.

What was this fn-f7 stuff about NVIDIA? fn-f7 does nothing for me in macOS nor in Windows...

Maybe this game just doesn't run well on the Mac...but it feels like I never got the benefit fo the graphics card...
or maybe dual gpus's do not work on laptop hacks.....
 
Joined
Jul 9, 2016
Messages
46
Motherboard
Alienware 17 R4 / OC
CPU
i7 7700HQ
Graphics
GTX 1060 / Intel 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
That was kind of the key on this guide was that rockjesus indicated dual GPU was working...otherwise, why install the NVIDIA web drivers even at all? I mean dual boot is nice for gaming, but I would rather not have to switch out macOS if not absolutely required.

And I also thought the HDMI is NVIDIA only, so if that is working fine for me both with mirroring, or as separate display, that too makes me think the NVIDA is working... Just wish I knew how to know for certain...
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,379
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
That was kind of the key on this guide was that rockjesus indicated dual GPU was working...otherwise, why install the NVIDIA web drivers even at all? I mean dual boot is nice for gaming, but I would rather not have to switch out macOS if not absolutely required.
as sometimes the NVIDIA is routed to the hdmi port and the only way to have the hdmi working is to install the web drivers
 
Status
Not open for further replies.
Top