Contribute
Register

[Guide] Alienware-17-R4-Dual-GPU-MacOS-Catalina-10.15-Hackintosh

Joined
Oct 18, 2019
Messages
10
Motherboard
alienware 17 r4
CPU
i7 7700hq
Graphics
gtx 1060
4B60C9FDBD5609483647B96771E8D795.jpg


# My hardware

• Alienware 17 R4

• 1080p

• i7-7700HQ

• Intel HD 630 & Nvidia GeForce GT 1060

• 16G RAM

• SM961 Samsung NVME 256

• REALTEK ALC298

• KILLER E2500

• Dell DW1560 (Broadcom BCM94352Z)

• BIOS version 1.5.0

laptop-alienware-17-mlk-pdp-4.jpg


# BIOS Configuration

• SATA MODE AHCI

• SECURE BOOT NO

• BOOT UEFI

bg2.gif


# Overview

I've got dual-gpu working good on 10.13.6,Now just waiting for the webdriver for 10.14.

*In windows OS press FN+F7 to change graphic mode:

1.dual gpu mode:Indisplay connects to hd630,Exdisplay connects to nvidia 1060

2.nvidia gpu only mode:Indisplay & Exdisplay both connects to nvidia 1060

1.png

# What Works

• CPU Power Management

• Battery Support

• Intel HD 630 & Nvidia GeForce GT 1060(when webdriver has installed)

• HDMI out (with hotplug) & Audio out(when webdriver has installed)

• Audio ALC298 (2.1ch with subwoofer)

• Headphone

• Brightness & volume Keys

• Keyboard

• AlienFX keyboard & logo LED lights (follow the settings on windows os but using vmware boot to windows and load the aw1517 usb device could change Alienfx light on macos)

• Trackpad with Gestures

• Webcam

• WiFi and Bluetooth

• Ethernet

• iCloud Services

• Continuity and Hand-off

• USB 3.0 & TYPE-C

• Thunderbolt devices with hotplug before sleep

• Sleep & Wake (only power button could wakeup system)
屏幕快照 2019-12-17 下午9.40.41.png


屏幕快照 2019-12-17 下午9.40.32.png


3.png


# What Doesn't Work

• Keyboard & mouse wakeup sysytem

• Thunderbolt devices with hotplug after wake

• ALIENFX light control on Macos

• Webcam IR function

• Trackpad light (Bios touchpad backlight=auto with no light ,but Bios touchpad backlight=on with light always on)

C5E279FCA8C35923D97FEF044A70F318.gif

# What Needs Improvement

• Backlight auto adjust (ALS0 device)

• HWsensor for more info

• LPCB,SBUS,Thermal subsystem controllers seems not working normally

• Things under "What Doesn't Work"

ED964714AD8FDF12EEFD11CC03059C37.gif

# Install

• If you can't see install partition try to press F3 on clover boot screen
FA15E109498296BE3C0393B08CE450B9.gif

# Post Install

• HIDPI

◦ Run script in Terminal:

sh -c "$(curl -fsSL https://raw.githubusercontent.com/xzhih/one-key-hidpi/master/hidpi.sh)"

• Change ur own productid & vendorid in kext's info.plist

◦ AppleMouseKeyboard.kext

◦ Applesmcmotion.kext (KIOX device)

◦ UVC2FaceTimeHD.kext (cam)

◦ VoodooHDA.kext (nvidia hdmi controller id)

• Nvidia webdriver

◦ Run script in Terminal:

bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh)

• Audio

◦ ALC298: layout-id=11 https://github.com/acidanthera/AppleALC

◦ Headphone/Headset volume ALCplugfix(deprecated):

cd alc_fix

chmod +x install.sh

./install.sh

◦ Headphone/Headset volume fix Combojack(newway):

cd ComboJack

chmod +x install.sh

./install.sh


◦ Install Boom 3D APP to get better audio output

832019F6A28637998F7F191022966F45.gif


# Change log:

•hdmi audio changed to hotpatch from dsdt patch

•add usbports.kext

•cpu pm 800-3800mhz

•Add smcmotionsensor

•Fixed BT issue by droping DMAR table

•change virtualsmc to fakesmc for getting more sensors (Fan & nvidia temp)

•Add intel & nvidia GPU PM

•alcplugfix seems not working on 10.14,changed to verstub(combojack) for headset fix

•smbios=mbp15,1

•New released lilu & whatevergeen etc,No need to hotpatch hdmi audio any more,but still need voodoohda to make hdmi audio work
2019-12-14 145515.gif

WORKING EFI(opencore/clover):https://github.com/RockJesus/Alienware-17-R4-Dual-GPU-MacOS-10.15-14-13-Hackintosh/releases
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
18,519
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
View attachment 440548

# My hardware

• Alienware 17 R4

• 1080p

• i7-7700HQ

• Intel HD 630 & Nvidia GeForce GT 1060

• 16G RAM

• SM961 Samsung NVME 256

• REALTEK ALC298

• KILLER E2500

• Dell DW1560 (Broadcom BCM94352Z)

• BIOS version 1.5.0

View attachment 440549

# BIOS Configuration

• SATA MODE AHCI

• SECURE BOOT NO

• BOOT UEFI

View attachment 440550

# Overview

I've got dual-gpu working good on 10.13.6,Now just waiting for the webdriver for 10.14.

*In windows OS press FN+F7 to change graphic mode:

1.dual gpu mode:Indisplay connects to hd630,Exdisplay connects to nvidia 1060

2.nvidia gpu only mode:Indisplay & Exdisplay both connects to nvidia 1060

View attachment 440551
# What Works

• CPU Power Management

• Battery Support

• Intel HD 630 & Nvidia GeForce GT 1060(when webdriver has installed)

• HDMI out (with hotplug) & Audio out(when webdriver has installed)

• Audio ALC298 (2.1ch with subwoofer)

• Headphone

• Brightness & volume Keys

• Keyboard

• AlienFX keyboard & logo LED lights (follow the settings on windows os but using vmware boot to windows and load the aw1517 usb device could change Alienfx light on macos)

• Trackpad with Gestures

• Webcam

• WiFi and Bluetooth

• Ethernet

• iCloud Services

• Continuity and Hand-off

• USB 3.0 & TYPE-C

• Thunderbolt devices with hotplug before sleep

• Sleep & Wake (only power button could wakeup system)


View attachment 440553

# What Doesn't Work

• Keyboard & mouse wakeup sysytem

• Thunderbolt devices with hotplug after wake

• ALIENFX light control on Macos

• Webcam IR function

• Trackpad light (Bios touchpad backlight=auto with no light ,but Bios touchpad backlight=on with light always on)


# What Needs Improvement

• Backlight auto adjust (ALS0 device)

• HWsensor for more info

• LPCB,SBUS,Thermal subsystem controllers seems not working normally

• Things under "What Doesn't Work"

View attachment 440554
# Install

• If you can't see install partition try to press F3 on clover boot screen

# Post Install

• HIDPI

◦ Run script in Terminal:

sh -c "$(curl -fsSL https://raw.githubusercontent.com/xzhih/one-key-hidpi/master/hidpi.sh)"

• Change ur own productid & vendorid in kext's info.plist

◦ AppleMouseKeyboard.kext

◦ Applesmcmotion.kext (KIOX device)

◦ UVC2FaceTimeHD.kext (cam)

◦ VoodooHDA.kext (nvidia hdmi controller id)

• Nvidia webdriver

◦ Run script in Terminal:

bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh)

• Audio

◦ ALC298: layout-id=11 https://github.com/acidanthera/AppleALC

◦ Headphone/Headset volume ALCplugfix(deprecated):

cd alc_fix

chmod +x install.sh

./install.sh

◦ Headphone/Headset volume fix Combojack(newway):

cd ComboJack

chmod +x install.sh

./install.sh


◦ Install Boom 3D APP to get better audio output

View attachment 440555

# Change log:

•hdmi audio changed to hotpatch from dsdt patch

•add usbports.kext

•cpu pm 800-3800mhz

•Add smcmotionsensor

•Fixed BT issue by droping DMAR table

•change virtualsmc to fakesmc for getting more sensors (Fan & nvidia temp)

•Add intel & nvidia GPU PM

•alcplugfix seems not working on 10.14,changed to verstub(combojack) for headset fix

•smbios=mbp15,1

•New released lilu & whatevergeen etc,No need to hotpatch hdmi audio any more,but still need voodoohda to make hdmi audio work
there are no web drivers for Catalina....
 
Joined
Apr 2, 2020
Messages
6
Motherboard
Alienware 17 R4
CPU
Alienware
Graphics
GeForce GTX 1080p
Could you put a complete tutorial? With a detailed walkthrough?
 
Joined
Apr 2, 2020
Messages
6
Motherboard
Alienware 17 R4
CPU
Alienware
Graphics
GeForce GTX 1080p
I've already read the topics with The guides.The problem is post installation. When I put the files you made available My notebook does not boot properly. My configuration is alienware 17R4 CPU i7, geforce gtx 1080 and Intel 630. I got your files from here and from your blog and I'm not able to use them correctly.
 
Joined
Oct 18, 2019
Messages
10
Motherboard
alienware 17 r4
CPU
i7 7700hq
Graphics
gtx 1060
I've already read the topics with The guides.The problem is post installation. When I put the files you made available My notebook does not boot properly. My configuration is alienware 17R4 CPU i7, geforce gtx 1080 and Intel 630. I got your files from here and from your blog and I'm not able to use them correctly.
try 10.13.6
 
Joined
Apr 2, 2020
Messages
6
Motherboard
Alienware 17 R4
CPU
Alienware
Graphics
GeForce GTX 1080p
After installing this version that you recommend, can I upgrade to catalina?
 
Joined
Oct 18, 2019
Messages
10
Motherboard
alienware 17 r4
CPU
i7 7700hq
Graphics
gtx 1060
no if u r gsync version
 
Joined
Apr 2, 2020
Messages
6
Motherboard
Alienware 17 R4
CPU
Alienware
Graphics
GeForce GTX 1080p
no if u r gsync version
Yes the screen is GSYNC and with that I am not able to activate the intel card and install in the Catalina version. Is there a way to activate this card or will it only work in High Sierra with both cards active?
 
Joined
Oct 18, 2019
Messages
10
Motherboard
alienware 17 r4
CPU
i7 7700hq
Graphics
gtx 1060
Yes the screen is GSYNC and with that I am not able to activate the intel card and install in the Catalina version. Is there a way to activate this card or will it only work in High Sierra with both cards active?
no way that i know
 
Top