Contribute
Register

[Guide] Airport - PCIe Half Mini v2

Status
Not open for further replies.
Joined
Feb 21, 2012
Messages
8
Mac
Classic Mac
Mobile Phone
I was wondering what is the best card for WiFi plus BT on the GA-Z87N-WIFI? I already have a a video card in my PCie slot.
 
Joined
Oct 27, 2012
Messages
140
Motherboard
Lenovo W510 model 4319RU/Intel QM57 Express Chipset (Chipset: Intel ID0044 Southbridge ID3B07)
CPU
Corei7/2.67GHz/M620
Graphics
Chimera 4.1.0, NVIDIA Quadro FX 880M, 1972X1080
Toleda,
Thanks for the great work.

I have the Azurewave AW-CE123H card installed.
I am using the BCM4352 and BCM4352bt kexts.
My WIFI works fine and BT turn on and shows active.
However, it will not connect to any BT devices, as a matter of fact it doesn't even "see" any BT devices.
I have a PC with BT running, my phone with BT on and a BT speaker all within close proximity and it doesn't see any of them.
Also, the phone and PC do not "see" the Mac either.

Did I miss a step or something in the setup?
Attached is what is listed in System Profiler.

EDIT:
Yes, I did miss something.
I downloaded the BT Firmware Updater kext as well and now things work just fine.
 

Attachments

Joined
Aug 13, 2012
Messages
58
Motherboard
Asus Z9PE-D8 WS
CPU
Xeon E5 2680
Graphics
MSI GTX690
Mac
MacBook Pro
Mobile Phone
iOS
I can not get the god damned thing to get an IP address!!! Drives me nuts!
Wifi worked under 10.8.2 - updated to 10.8.5 and no go.
TL-WDN4800, so it's AR9380,
shows up as pci168c, 30

Seems to be working just fine - but always "Self-Assigned IP". Immediately when I switch on wifi, it shows full wifi connecton on the menu, "no ip address" in Network Preferences and then within 10 seconds has the self-assigned IP.
I've deleted the wi-fi, any imaginable plist file, deleted and added Locations, mucked about with the MTU, disabled/enabled ipv6 and finally tried this DSDT patch (one warning, no errors). Still no go :banghead:
 

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
4,555
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
iMac, Mac mini
Mobile Phone
iOS
Toleda,
Thanks for the great work.

I have the Azurewave AW-CE123H card installed.
I am using the BCM4352 and BCM4352bt kexts.
My WIFI works fine and BT turn on and shows active.
However, it will not connect to any BT devices, as a matter of fact it doesn't even "see" any BT devices.
I have a PC with BT running, my phone with BT on and a BT speaker all within close proximity and it doesn't see any of them.
Also, the phone and PC do not "see" the Mac either.

Did I miss a step or something in the setup?
Attached is what is listed in System Profiler.

EDIT:
Yes, I did miss something.
I downloaded the BT Firmware Updater kext as well and now things work just fine.
Are your devices sucessfully pairing and staying connected to this ? I've tried with this several times with no luck.

Bluetooth was visible but wouldn't connect reliably.

Also, did you check waking from sleep using a bluetooth device ?
 
Joined
Dec 20, 2013
Messages
11
Motherboard
gigabyte h87n-wifi rev.2
CPU
intel core i5 4430
Graphics
intel hd4600
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
I was wondering what is the best card for WiFi plus BT on the GA-Z87N-WIFI? I already have a a video card in my PCie slot.
I built my mackintosh based on customac mini, using GA-H87N-WIFI, which is similar to your motherboard. My aim was to build a computer i could actually use everyday, i did not want to spend my time fixing the OS continuously. I am not very good at doing that. So every time i selected a solution that could work OOB.
After using unibeast and multi beast, everything was working ok, except BT, wifi, and IR receiver (i use xbmc all the time). Here is how i solved these problems. First remove the half mini wireless card that came with the motherboard.

For wifi, i used a broadcom module you can get from amazon or from ebay. It is the same vendor (jhe technology). I was convinced by the positive comments from buyers from amazon.com.
The problem is that the card is full size mini pcie card, my only pcie slot was used for a sata pcie controller card, so i had to buy this adapter in order to use the card on the mini-pcie slot of my motherboard (that can accommodate only half mini cards). I did this 2 days ago, and the wifi is working full speed (i have a genuine macbook pro i can compare with). It works OOB, airport extreme, airdrop, location services, everything works.

For BT, i used the DIY apple branded bluetooth module, which i bought on ebay. I did this some 2 months ago, and so far everything working flawlessly. Magic mouse and magic pad wake the computer from sleep. Don't be intimidated by the soldering part, initially i attached the diodes using fine copper wires, and later on had to borrow a soldering iron and learn on youtube how to use it.

For the IR receiver, i used an apple IR module i purchased 4$ from powerbookmedic.com, and it works very well, and is very sensitive.
Of course i had to spend extra 85$ to get everything working, but i think it is a good investment. I have a hackintosh that works even better than my macbook pro 2009 because it is faster. And it comes with the pride you feel from something you built yourself.
 
Joined
Sep 3, 2010
Messages
70
Motherboard
Acer V5-572G
CPU
i5-3337U
Graphics
Intel HD4000
Mac
Classic Mac
Mobile Phone
Notes - Broadcom
  1. 5 GHz - not working (BCM94352)
I made ​​a binary patch for the activation of a range of 5GHz on Broadcom BCM94352HMB.

File Name: AirPortBrcm4360
Find bytes: 01 58 54
Replace bytes: 01 58 58

For terminal:

Code:
sudo perl -pi -e 's|\x01\x58\x54|\x01\x58\x58|g' /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortBrcm4360.kext/Contents/MacOS/AirPortBrcm4360
Code:
sudo touch /System/Library/Extensions/
Wait 30 sec, Restart, Use...


This patch is tested on my Broadcom BCM94352HMB from Lenovo FRU# 03T7135, 20200381.

Before patch:



After patch:





Module AzureWave AW-CE123H need verification.
Test and tell someone about the results...

UPDATE:
Confirmed 5 GHz working: AzureWave AW-CE123H and other BCM94352HMB.
.
 

Attachments

Last edited by a moderator:
Joined
Feb 17, 2012
Messages
21
Motherboard
Hackintosh
CPU
Intel Core i5-4670K
Graphics
ASUS GeForce GTX 760 DC Mini
Mac
Classic Mac
Mobile Phone
iOS
Just tested it and the patch is not working for me, i have the AzureWave AW-CE123H. If this helps you I still have mavericks 10.9.1.

Only differences i see between your screen captures and my system information are:

CoreWLAN: 4.0 (400.45.1)
CoreWLANKit: 3.0 (300.35)
Menu Extra: 9.0 (900.34)
System Information: 9.0 (900.8)
IO80211 Family: 6.0 (600.34)
Diagnostics: 3.0 (300.37)
AirPort utility: 6.3.2 (632.3)
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,458
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I made ​​a binary patch for the activation of a range of 5GHz on Broadcom BCM94352HMB.
@Skvo, outstanding work!
Confirmed 5 GHz working: BCM94352 and AW-CE123H in 10.9, 10.9.1 and 10.9.2
Minor syntax edit to patch.
 
Joined
Sep 3, 2010
Messages
70
Motherboard
Acer V5-572G
CPU
i5-3337U
Graphics
Intel HD4000
Mac
Classic Mac
Mobile Phone
Just tested it and the patch is not working for me, i have the AzureWave AW-CE123H. If this helps you I still have mavericks 10.9.1.
Who patch does not work, show your IOREG after the patch.
 
Joined
Feb 17, 2012
Messages
21
Motherboard
Hackintosh
CPU
Intel Core i5-4670K
Graphics
ASUS GeForce GTX 760 DC Mini
Mac
Classic Mac
Mobile Phone
iOS
I patched the original IO80211Family.kext, but i made a backup just in case as always. Attached is a screen capture of IOReg

EDIT: Now works PERFECT, i patched again the original kext with new patch. Thank you.
 

Attachments

Status
Not open for further replies.
Top