Contribute
Register

[Guide] Aero 15X V8 (High Sierra + Nvidia Graphics, and Mojave)

Joined
Sep 25, 2018
Messages
43
Motherboard
Gigabyte Aero 15X V8
CPU
i7-8750H
Graphics
GTX 1070
Do u guys know how to fix Intel UHD 630 that High Sierra recognized with only 7MB VRAM? I tried other fix but none of them worked. I follow @zacmks guide upon this point and do some modification for the AppleALC.kext driver to work (I use VoohooDHA.kext instead and install it into L/E) High Sierra still recognize UHD with 7MB. Do you know anything upon this problem?

Also I have a question upon screen. Whenever I use the config.plist provided by you @zacmks I only have screen on my HDMI port while the internal display shows nothing but an apple logo with loading line (shown below). I believe that this might be something with SSDT and DSDT file but I'm pretty new to this so that I don't want to mess up anything.

Btw my keyboard, mouse, and trackpad work totally fine. Bluetooth on the other hand doesnt work but that doesnt affect me that much.

P/s: I can live with this but it is kinda finicking because it detects two display lol
No DSDT/SSDT necessary for graphics (other than disabling Nvidia graphics).
Have you configured Whatevergreen + Lilu?
It's basically 2 kexts, plus the config.plist to rename the IGPU and patch the device
If you boot on verbose mode, it could help ("-v" option for args)

Here's a quick, easy guide for it:

Also, having more problem reporting files could help, there's a script to generate them:

I cannot say much without more info, but if you used the config.plist that I provided, there could be something with Lilu/Whatevergreen

This is how it shows to me:
388390
 
Last edited:
Joined
Feb 13, 2019
Messages
7
@zacmks can you send me your whole EFI file? from your EFI bootloader? Thank you

Also are you using High Sierra or Mojave? I guess High Sierra since I saw the NVIDIA logo on your menu bar

and also I'm not able to run the problem diagnostics by black dragon because the prompt shows "cannot connected to the internet. Aborted" although I connects my laptop through ethernet. (I'm still waiting for my wifi card to come)
 
Last edited:
Joined
Sep 25, 2018
Messages
43
Motherboard
Gigabyte Aero 15X V8
CPU
i7-8750H
Graphics
GTX 1070
@zacmks can you send me your whole EFI file? from your EFI bootloader? Thank you

Also are you using High Sierra or Mojave? I guess High Sierra since I saw the NVIDIA logo on your menu bar

and also I'm not able to run the problem diagnostics by black dragon because the prompt shows "cannot connected to the internet. Aborted" although I connects my laptop through ethernet. (I'm still waiting for my wifi card to come)

Clone or download -> Download ZIP

File for High Sierra should be in the 10.13.6 folder, same as:
 
Joined
Sep 25, 2018
Messages
43
Motherboard
Gigabyte Aero 15X V8
CPU
i7-8750H
Graphics
GTX 1070
I've managed to boot with your latest config.plist and EFI setup (10.13.6), but I get the following when I try to install: "Service exited due to signal: Killed: 9 sent by diskarbitrationd"

This is after removing the Transcend NVME drive that came with the system and using just the Samsung 970 Evo. Any ideas what causes this? Is it some security feature I need to disable?
Have you tried using dart=0 with the boot arguments?

JFYI, my setup is with Toshiba NVMe, formatted with 4k sector size. I haven't had this error
 
Joined
Feb 13, 2019
Messages
7
My solution is to go to the app store and update and it works like a charm. Thx for your help anyway
And I have another question. Do you recommend any other wifi card since the one you suggest is pretty expensive?
@zacmks
 
Joined
Feb 13, 2019
Messages
7
try to install the update from apple store. It does the trick for me. Your stick might not have the latest update (i believe it is update 003 for 10.13.6)
 
Joined
Sep 25, 2018
Messages
43
Motherboard
Gigabyte Aero 15X V8
CPU
i7-8750H
Graphics
GTX 1070
My solution is to go to the app store and update and it works like a charm. Thx for your help anyway
And I have another question. Do you recommend any other wifi card since the one you suggest is pretty expensive?
@zacmks
Afaik, what I can see is that the following has the Aero 15x form factor (NGFF/M.2)
BCM4352 - Ex.: Dell DW1560
BCM4350 - Ex.: Dell DW1820A
BCM43602 - Ex.: Dell DW1830

I do use a chinese variant, but I do not recomment much the Bcm94352z (there're reports of ppl having issues even with the brand ones) if you are using Windows. Heard that the Bcm94352hmb is more stable with the OS
 
Joined
Sep 25, 2018
Messages
43
Motherboard
Gigabyte Aero 15X V8
CPU
i7-8750H
Graphics
GTX 1070
I have, this does nothing. I also cannot boot without -no_compat_check. When I do boot with that option, I get a notice that "The version of macOS installed on this drive is newer" for all drives that are not the USB boot drive. I have to change the SMBIOS away from MBP 15,1 to get it to work.

This is if I create the USB drive myself by installing Clover. If I do the Unibeast method for High Sierra, it just merely fails to install, with the same message
Are you using the 17G2208 (or higher) to install? This is a special version for High Sierra with Coffee Lake support
I had issues with the 17G6X version when I tried. If you don't have access to the Coffee Lake versions, you can try with Fake CPUID + NullCPUPowermanagement and it should work.

Agreed, other SMBios would work better with the install, iMac14,2 is the suggested one

Just a note, for my case. Either with my current config.plist (I resintalled once with this), and a standard-for-instalation one did work, so expressing the experience that I had with this laptop, too
 
Joined
Sep 25, 2018
Messages
43
Motherboard
Gigabyte Aero 15X V8
CPU
i7-8750H
Graphics
GTX 1070
@zacmks little off topic but do u use ubuntu? Can you make the keyboard function to work?
I do use Debian (Buster). Volume and sleep does work oob. I haven’t tried to make other keys to work (airplane mode, etc). I suspect that those are ec controlled, but haven’t investigated much yet
 
Top