Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Mar 30, 2021
Messages
60
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
We should not flash the Thunderbolt firmware unless we have a Thunderbolt device that simply won't connect otherwise. More than 90% of Thunderbolt devices will work without flashing the firmware.

As for sound output to the monitor, please check if using an HDMI cable avoids the problem. Use of iMac20,2 is perfectly okay with or without a discrete GPU.
I have tried the HDMI and USB-C to DP cable. macOS is not able to detect both the HDMI and DP audio under the sound output setting. Do you know why? Thank you!
 
Joined
Feb 18, 2018
Messages
790
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Hey,
I'm running Catalina 10.15.7 with OpenCore 0.6.3, and I would like to download the new "macOS Catalina 10.15.7 Supplemental Update". What do I have to prepare in order to do this? Do I have to upgrade to OpenCore 0.6.7?

Also, I've created a backup of the system on my SSD 6 months ago, but now I would like to create a new one since it's old, is there a way to override the old backup with a new one with Carbon Copy Cloner? or is there a better way to do this?

No you don't have to update OC but it wouldn't harm to do so.

As for CCC, it will update only the files it needs to, you don't need to start a new clone.
 
  • Like
Reactions: nss

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,794
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I have tried the HDMI and USB-C to DP cable. macOS is not able to detect both the HDMI and DP audio under the sound output setting. Do you know why? Thank you!
Unfortunately different monitors can react differently. We strongly discourage using the iGPU to drive a display monitor, but I do understand that AMD GPUs are very expensive and very difficult to find. It's best to wait for an AMD GPU to become available.
 
Joined
Mar 30, 2021
Messages
60
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Unfortunately different monitors can react differently. We strongly discourage using the iGPU to drive a display monitor, but I do understand that AMD GPUs are very expensive and very difficult to find. It's best to wait for an AMD GPU to become available.
Thanks again for the reply. I guess I will just use iGPU to drive the display for now since the RX 5700 XT is $1000+. I don't want to encourage those greedy scalpers out there. But, if I have a RX 5700 XT, do I need to change anything in the EFI files? Do I need to change SMBIOS from iMac20,2 to iMac Pro 1,1? What else do I need to change if I upgrade it from iGPU to dGPU?
 
Joined
Jun 1, 2013
Messages
242
Motherboard
Gigabyte Z490 Vision D
CPU
I7-10700K
Graphics
5600XT & 6800 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Works a treat. System Information > Graphics/Displays now only shows the RX580.
That's great. I'll give it a try but will modify it first since my 6800 XT is in slot 12. What were the causes of your system failing at boot with a different SSDT (for instance the one on Dortania website)? was it loading macos then crashed halfway through loading the OS?
 
Joined
Jul 14, 2020
Messages
185
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 6800
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
That's great. I'll give it a try but will modify it first since my 6800 XT is in slot 12. What were the causes of your system failing at boot with a different SSDT (for instance the one on Dortania website)? was it loading macOS then crashed halfway through loading the OS?
Yes, that’s exactly what would happen. macOS would just fail to boot halfway through the loading bar.
 
Last edited:
Joined
Jun 1, 2013
Messages
242
Motherboard
Gigabyte Z490 Vision D
CPU
I7-10700K
Graphics
5600XT & 6800 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
@emistral,

Please try the attached SSDT to disable RX 6800 in Slot 1.
@CaseySJ, I confirmed that once I modified the SSDT for Slot 2, my RX 6800 XT in Slot 2 does not show up in the system report. In IOReg, GFX1 is still showing up but this time class-code value is indeed ff ff ff ff.
I can also confirm that with the GPU in slot 2 now disabled via this working SSDT, my sleep/wake problem is fixed. Prior to disabling it, I could sleep but upon wake up, the system would crash and reboot. This is not the case anymore. Thanks again @Higgie and @CaseySJ.
 
Joined
Jul 14, 2020
Messages
185
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 6800
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ I confirmed that once I modified the SSDT for Slot 2, my RX 6800 XT in Slot 2 does not show up in the system report. In IOReg, GFX1 is still showing up but this time class-code value is indeed ff ff ff ff.
Glad it worked for you mate!

Even better to hear it fixed your Sleep/Wake. Happy to help!
 
Last edited:
Joined
May 10, 2011
Messages
2,584
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
So it’s been roughly 5 months since I’d got my Z490 Aorus Xtreme, and I’m feeling sorta disappointed that I never got the 2 Ethernet ports working properly (been using a USB dongle instead). Yes the built-in WiFi 6 works via itlwm but it occupies port en2 while the Aquantia (non-responsive) uses en0. The Intel 2.5GB also supposedly uses en2 and herein lies my dilemma. I still would like to use a faster cable from time to time but neither port is working even after I’ve put in the F2150000 device-id properties in config.plist. What can I do?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,794
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
So it’s been roughly 5 months since I’d got my Z490 Aorus Xtreme, and I’m feeling sorta disappointed that I never got the 2 Ethernet ports working properly (been using a USB dongle instead). Yes the built-in WiFi 6 works via itlwm but it occupies port en2 while the Aquantia (non-responsive) uses en0. The Intel 2.5GB also supposedly uses en2 and herein lies my dilemma. I still would like to use a faster cable from time to time but neither port is working even after I’ve put in the F2150000 device-id properties in config.plist. What can I do?
Let's take a look at the following:
  • Screenshot of System Information --> Network
  • IOReg file (IORegistryExplorer --> File -- Save As...)
 
Top