Contribute
Register

Fenvi FV T919 (Broadcom BCM94360) working except Apple Watch unlock (Catalina)

Joined
May 3, 2019
Messages
68
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
The strange thing is that it does work for some people. It worked 1x time for me. What I noticed is that 1 out of 20 boots bluetooth devices can not connect and i need to restart one or two times. It just is not 100% stable which might be an due to some usb conflict. As I am quite new no sure how to debug
 
Joined
Jul 12, 2017
Messages
42
Motherboard
Gigabyte GA-H170N-WIFI
CPU
i3-6100
Graphics
RX 560
Mac
  1. MacBook
  2. Mac mini
Classic Mac
  1. Classic
  2. iMac
  3. Performa
  4. Power Mac
  5. PowerBook
  6. SE
  7. SE/30
Mobile Phone
  1. iOS
The strange thing is that it does work for some people. It worked 1x time for me. What I noticed is that 1 out of 20 boots bluetooth devices can not connect and i need to restart one or two times. It just is not 100% stable which might be an due to some usb conflict. As I am quite new no sure how to debug

For me, everything works as long as the watch is connected via bluetooth ("Connected: Yes" in System Information > Bluetooth). Uncheck/check "Use your Apple Watch to unlock apps..." in System Preferences > Security & Privacy, to force the AW to connect. If I leave the computer (and BT disconnects), everything has stopped working when I return to the computer.

On a real Mac, the watch is NOT connected all the time ("Connected: No" in System Information), but can still communicate with the Mac somehow.
 
Joined
May 3, 2019
Messages
68
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I solved this issue by disabling the serial port on BIOS settings (it's hidden under SuperIO settings or something like this). Now the unlock with Apple Watch feature works fine.

Unfortunately the option has been removed on recent bios versions for newer boards like z390. Deleting the serial port does not help so it should be disabled with a ssdt which i have not been able to achieve.

 
Last edited:
Joined
May 3, 2019
Messages
68
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Seems this is 100% related to a bios setting which Gigabyte has removed which allowed to disable the serial port.
There is a beta bios available for multiple Gigabyte motherboards that brings this back. Solved the issue completely for me. More info in the below thread where there is a link to the beta bioses

 
Last edited:
Joined
Sep 28, 2020
Messages
7
Motherboard
Asus
CPU
i9900K
Graphics
5700xt
Mac
  1. iMac
Mobile Phone
  1. iOS
Seems this is 100% related to a bios setting which Gigabyte has removed which allowed to disable the serial port.
There is a beta bios available for multiple Gigabyte motherboards that brings this back. Solved the issue completely for me. More info in the below thread where there is a link to the beta bioses


i have the same problem
i'm using z390 m gaming, fenvi fv t919, i will have a try to flash my bios to a beta version and disable the serial port. i will report here after i tried.

thanks
 
Joined
Aug 12, 2019
Messages
43
Motherboard
Gigabyte X79-UD3
CPU
Xeon E5 1650v2
Graphics
RX570
Mobile Phone
  1. iOS
i have the same problem
i'm using z390 m gaming, fenvi fv t919, i will have a try to flash my bios to a beta version and disable the serial port. i will report here after i tried.

thanks
A friend of mine has the z390-ud and there’s the option for the serial port (it’s under SuperIO) without beta
 
Joined
Sep 28, 2020
Messages
7
Motherboard
Asus
CPU
i9900K
Graphics
5700xt
Mac
  1. iMac
Mobile Phone
  1. iOS
A friend of mine has the z390-ud and there’s the option for the serial port (it’s under SuperIO) without beta
the option is under Peripherals => superIO?

i don't even have Peripherals in my bios, i think i have to use a beta version.

maybe the situation differs in z390-ud :crazy:
 
Joined
Sep 28, 2020
Messages
7
Motherboard
Asus
CPU
i9900K
Graphics
5700xt
Mac
  1. iMac
Mobile Phone
  1. iOS
i have the same problem
i'm using z390 m gaming, fenvi fv t919, i will have a try to flash my bios to a beta version and disable the serial port. i will report here after i tried.

thanks
i fix my apple watch unlock problem by disable serial port in bios
but after i restart my hackintosh, it fails again,
i just uncheck the unlock with apple watch and check the option again, it will come back to work, i'm still working on this

thanks
 
Last edited:
Top