Contribute
Register

E6540 - COMPLETE EFI ATTACHED - CATALINA BETA 3 WORKING EXCEPT USB / INTERNAL 2ND SSD AND HDMI SOUND SYNC

Status
Not open for further replies.
Joined
Jun 12, 2019
Messages
6
Motherboard
Dell Latitude E6540-A26
CPU
i7-4810MQ
Graphics
HD 4600+HD 8790M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have Catalina Beta 3 working on my E6540 but I still have 2 main issues I need to fix and would appreciate some assistance please.

1- Only the mouse USB and a 2GB USB are working but not if I insert an Additional SSD USB or Internal 2nd SSD Drive
2- HDMI works but sound is not synced properly to the Samsung TV

Regarding the USB Do we need to find and replace any address in Kernel and Kext to Patch in the config as we did for 10.14.x?

If I try to install AppleAHCIPort.kext into S/L/E under 10.15.x it will create a Kernel Panic upon boot and I cannot fix it after that.!

I have attached my EFI perhaps it will assist others and someone could also assist with my question.

Thank you
 

Attachments

  • EFI.zip
    16.8 MB · Views: 347

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,199
Motherboard
Lenovo ThinkStation p700
CPU
2 X Xeon E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Not a Desktop - Moved to Laptop Support.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,555
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I have Catalina Beta 3 working on my E6540 but I still have 2 main issues I need to fix and would appreciate some assistance please.

1- Only the mouse USB and a 2GB USB are working but not if I insert an Additional SSD USB or Internal 2nd SSD Drive
2- HDMI works but sound is not synced properly to the Samsung TV

Regarding the USB Do we need to find and replace any address in Kernel and Kext to Patch in the config as we did for 10.14.x?

If I try to install AppleAHCIPort.kext into S/L/E under 10.15.x it will create a Kernel Panic upon boot and I cannot fix it after that.!

I have attached my EFI perhaps it will assist others and someone could also assist with my question.

Thank you
3rd party kexts belong in /L/E
 
Joined
Jun 12, 2019
Messages
6
Motherboard
Dell Latitude E6540-A26
CPU
i7-4810MQ
Graphics
HD 4600+HD 8790M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks but even if I place AppleAHCIPort.kext in /L/E it still doesn't work.

Need to fix USB first for Catalina then I will look into the HDMI Sound Sync issue.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,555
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks but even if I place AppleAHCIPort.kext in /L/E it still doesn't work.

Need to fix USB first for Catalina then I will look into the HDMI Sound Sync issue.
As per rules, please update your hardware profile to allow others to help you easier

please read the faq for proper hardware profile setup:
 
Joined
Dec 13, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have Catalina Beta 3 working on my E6540 but I still have 2 main issues I need to fix and would appreciate some assistance please.

1- Only the mouse USB and a 2GB USB are working but not if I insert an Additional SSD USB or Internal 2nd SSD Drive
2- HDMI works but sound is not synced properly to the Samsung TV

Regarding the USB Do we need to find and replace any address in Kernel and Kext to Patch in the config as we did for 10.14.x?

If I try to install AppleAHCIPort.kext into S/L/E under 10.15.x it will create a Kernel Panic upon boot and I cannot fix it after that.!

I have attached my EFI perhaps it will assist others and someone could also assist with my question.

Thank you
Try this Config.plist i edited the one you posted it should fix your usb Issue even usb 3.0 controller
 

Attachments

  • config.plist
    14.3 KB · Views: 77
Joined
Jun 12, 2019
Messages
6
Motherboard
Dell Latitude E6540-A26
CPU
i7-4810MQ
Graphics
HD 4600+HD 8790M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
As per rules, please update your hardware profile to allow others to help you easier

Sure, I have updated it and also I have attached the Clover dump files here as well as complete darwin dump files.

Try this Config.plist i edited the one you posted it should fix your usb Issue even usb 3.0 controller

Thank you for trying but unfortunately it didn't actually make any difference, the 128GB External SSD USB as well as the Internal one were not recognized.

I hope the files I provided will help to get someone to help me to get fix the issues:
USB
Webcam
HDMI Audio Sync

I am also wondering if there is a possibility to use AMD Radeon HD 8790M + HDMI instead of Intel HD Graphics 4600 ?

Thanks
 

Attachments

  • DarwinDumper.zip
    3.2 MB · Views: 53
  • E6540_origin.zip
    41 KB · Views: 46
Last edited:
Joined
Jun 12, 2019
Messages
6
Motherboard
Dell Latitude E6540-A26
CPU
i7-4810MQ
Graphics
HD 4600+HD 8790M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
-
 
Last edited:
Joined
Dec 13, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Sure, I have updated it and also I have attached the Clover dump files here as well as complete darwin dump files.



Thank you for trying but unfortunately it didn't actually make any difference, the 128GB External SSD USB as well as the Internal one were not recognized.

I hope the files I provided will help to get someone to help me to get fix the issues:
USB
Webcam
HDMI Audio Sync

I am also wondering if there is a possibility to use AMD Radeon HD 8790M + HDMI instead of Intel HD Graphics 4600 ?

Thanks
go to system info and then usb and show me a screen shot like is it seeing the usb controller at all?
like lets try to isolate if its an issue with the ssd or the usb controller.
If it is the ssd it may just be a different kext needed.
 
Joined
Dec 13, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Sure, I have updated it and also I have attached the Clover dump files here as well as complete darwin dump files.



Thank you for trying but unfortunately it didn't actually make any difference, the 128GB External SSD USB as well as the Internal one were not recognized.

I hope the files I provided will help to get someone to help me to get fix the issues:
USB
Webcam
HDMI Audio Sync

I am also wondering if there is a possibility to use AMD Radeon HD 8790M + HDMI instead of Intel HD Graphics 4600 ?

Thanks
also is the ssd usb or nvme there is a difference in how the usb controller sees the devices

https://www.tonymacx86.com/threads/guide-hackrnvmefamily-co-existence-with-ionvmefamily-using-class-code-spoof.210316/https://www.tonymacx86.com/threads/guide-hackrnvmefamily-co-existence-with-ionvmefamily-using-class-code-spoof.210316/

this may be helpful
 
Status
Not open for further replies.
Top