Contribute
Register

Dell OptiPlex 5050 SFF i5-6500 8GB ddr4 500GB

Joined
Nov 15, 2018
Messages
1
Motherboard
Dell OptiPlex 5050
CPU
Core i5
Graphics
Built in
Good morning everyone;
i'm Rosh and new to this forum. I have seen lot of Mac build in custom build and etc. I would like to know if i can run mac on

Dell OptiPlex 5050 SFF i5-6500 8GB ddr4 500GB please let me know which Mac OS would be a stable and safe and how i can install it.

Thank you and looking forward to all of your contributions
 
Joined
Oct 1, 2013
Messages
66
Motherboard
HP ProBook 450 G5
CPU
I5-8250U
Graphics
HD 620
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Were you able to make it work?
 
Joined
Sep 9, 2019
Messages
1
Motherboard
Dell Latitude 5285
CPU
Intel Core i5-7300U Dual Core
Graphics
Intel UHD 620
Yes, Mojave is compatible.
 
Joined
Jul 17, 2013
Messages
3
Motherboard
Optiplex 5050 MFF
CPU
2.9 GHz Intel Core i7
Graphics
Intel HD Graphics 630 1536 MB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
Hi, if you were able to make this work, could you post EFI? I can only get so far before it panics. Can't even reach Mojave installer :(
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,292
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi, if you were able to make this work, could you post EFI? I can only get so far before it panics. Can't even reach Mojave installer :(

As per forum rules, please complete your profile to include CPU, motherboard, and GPU.

You can try my Optiplex 3050 EFI. I think the two systems are similar enough that it should work. Link is below in my signature.
 
Last edited:
Joined
Jul 17, 2013
Messages
3
Motherboard
Optiplex 5050 MFF
CPU
2.9 GHz Intel Core i7
Graphics
Intel HD Graphics 630 1536 MB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
Thank you! thank you! I tried your EFI and it was 99% of the way there. It was trying to use DP vs HDMI so my screen was tinted pink.

I enabled the other framebuffer options you had listed for #1 and that fixed my colors. Thanks again for your EFI! Works great on Optiplex 5050 MFF.

I'll complete my profile now that I have time saved from all the troubleshooting :)
 
Joined
Aug 14, 2012
Messages
57
Motherboard
Dell Optiplex 7040
CPU
i7-6700
Graphics
HD 530
Mac
  1. iMac
Hi @pastrychef, if you maybe able to help me as well. The op's processor is a skylake's one and Im using a skylake processor too but just the i7 6700. The computer that Im using is the Dell optiplex 7040. I have installed mojave. There are just 2 things that I think that didn't installed:

One, is the ethernet card. I just googled which ethernet it uses and based from my search it is using the intel i219 (hope im correct) but I tried copying the kext from the efi-clover-kext-other (folders) but after rebooting it does not work. I also tried using the kextbeast way but it did not work as well. maybe you can help?

Second is the "waking up when I dont touch the computer for long and goes for sleep" I have to force it to shutdown and just turn it on again. What can I do to fix this as well?

Anyway, Happy new year and thanks.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,292
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi @pastrychef, if you maybe able to help me as well. The op's processor is a skylake's one and Im using a skylake processor too but just the i7 6700. The computer that Im using is the Dell optiplex 7040. I have installed mojave. There are just 2 things that I think that didn't installed:

One, is the ethernet card. I just googled which ethernet it uses and based from my search it is using the intel i219 (hope im correct) but I tried copying the kext from the efi-clover-kext-other (folders) but after rebooting it does not work. I also tried using the kextbeast way but it did not work as well. maybe you can help?

Second is the "waking up when I dont touch the computer for long and goes for sleep" I have to force it to shutdown and just turn it on again. What can I do to fix this as well?

Anyway, Happy new year and thanks.

Are you using a video card?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,292
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thank you @pastrychef for your quick reply. No, not using a video card.

Is graphics currently working correctly for you? Are you getting acceleration from IGPU?

Please post your EFI folder.
 
Top