Contribute
Register

<< Solved >> Catalina easy update and sound fix

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,875
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Do you *copy* AppleHDA.kext to /Library/Extensions, or *move* it there? Thanks :)
Use the Kextbeast app. Don't just copy/paste it there.
 
Joined
Nov 8, 2013
Messages
72
Motherboard
Gigabyte GA-Z97X-UD7 TH
CPU
i7-4770K
Graphics
GT 640
Mobile Phone
  1. Android
I have two nearly identical machines. The only difference is that one pulls sound from the NVidia GT640 HDMI port, the other (this one) uses the Intel motherboard sound. Got the sound fix in this thread to work fine on the HDMI machine. On this one, no joy. First tried checking "FixHPET" in config.plist. When that didn't work I went through the rest of the procedure (yes, I used Kextbeast - thanks). Interestingly, it wouldn't let me change permissions/owner/group on /Library/Extensions as root, but they're already root:wheel and 755. Kextcache -i / gave me a bunch of warnings but completed OK. On reboot, it still does not "see" any of the sound devices except a pair of USB headphones - and doesn't play audio through them anyway. The audio out (speakers) doesn't show. Thoughts?

At least it didn't kernel panic this time, like it did the last couple of times I've tried it.

Edit: I used Hackintool to get the newest versions of AppleALC and Lilu and installed them with Kextbeast. Now, I actually get sound through the HDMI cable via the crummy speakers in my otherwise decent 4K monitor. I worked around not being able to use the motherboard's sound-out by running an audio cable from the monitor's headphone jack into the external stereo receiver I use for better sound. This is an acceptable workaround, and I no longer need the motherboard's sound output. However, the USB sound device (headphones/mic) still doesn't work.

Now...how do I enable USB sound (I often use the headphones/mic and a USB webcam for Zoom meetings)??

Thanks all!
 
Last edited:
Joined
Nov 8, 2013
Messages
72
Motherboard
Gigabyte GA-Z97X-UD7 TH
CPU
i7-4770K
Graphics
GT 640
Mobile Phone
  1. Android
I have sound via HDMI to my external stereo receiver. However, the USB sound device (headphones/mic) still doesn't work. I use this for Zoom meetings, etc. It shows up on the list of devices but...no sound output. Any idea as to how to get it enabled?

Thanks!
 
Joined
Apr 23, 2017
Messages
3
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K
Graphics
Sapphire Radeon 570 8 gygs
Mac
  1. iMac
Mobile Phone
  1. iOS
Works for me too. Thanks!!
 
Joined
May 28, 2018
Messages
48
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
I am running a nuc8i5beh, with catalina 10.15.6. I use kext updater to periodically check and copy any updates to the efi partition on my drive. That has not been giving me troubles till recently. When I copied over appleALC 1.50 and rebooted I no longer had sound and it looks like the internal sound was not recognized. I copied back appleALC 1.49 and the sound worked fine. I see that there is now an update to version 1.52 for appleALC, but that also results in no sound. Backing it out and reverting to 1.49 works fine. I was reading through the link to the guide for configuring lilu and plugins, and I think my next step may be to try to update config.plist....wanted to see if that approach makes sense or if there may be something else I am overlooking?
 
Top