Contribute
Register

<< Solved >> Catalina easy update and sound fix

Joined
Mar 6, 2019
Messages
36
Motherboard
Dell Optiplex 7050 SFF
CPU
T6600/Q270
Graphics
Integrated GPU
Mobile Phone
  1. Android

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,931
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Kext with invalid signature (-67062) allowed: <OSKext 0x7fea8fc2fe90 [0x7fff8faf98c0]> { URL = "file:///Library/Extensions/WhateverGreen.kext/", ID = "as.vit9696.WhateverGreen" }

Kext with invalid signature (-67062) allowed: <OSKext 0x7fea8fc0e7d0 [0x7fff8faf98c0]> { URL = "file:///Library/Extensions/Lilu.kext/", ID = "as.vit9696.Lilu" }

Kext with invalid signature (-67062) allowed: <OSKext 0x7fea8fc12700 [0x7fff8faf98c0]> { URL = "file:///Library/Extensions/AppleALC.kext/", ID = "as.vit9696.AppleALC" }

KernelCache ID: 096F86312140429B1A7FE3F53F1B703D

Kext with invalid signature (-67062) allowed: <OSKext 0x7f8a668dd5e0 [0x7fff8faf98c0]> { URL = "file:///Library/Extensions/Lilu.kext/", ID = "as.vit9696.Lilu" }

Kext with invalid signature (-67062) allowed: <OSKext 0x7f8a64507c20 [0x7fff8faf98c0]> { URL = "file:///Library/Extensions/AppleALC.kext/", ID = "as.vit9696.AppleALC" }

Kext with invalid signature (-67062) allowed: <OSKext 0x7f8a66b42de0 [0x7fff8faf98c0]> { URL = "file:///Library/Extensions/WhateverGreen.kext/", ID = "as.vit9696.WhateverGreen" }

ilaydenizs@Denizs-iMac ~ %

View attachment 467132
delete those kexts from /L/E, they are not needed there, as you have them in clover/kexts/other

then go over the link i posted on the other page regarding the audio as that appears to be missing from your config.plist
 
Joined
Mar 6, 2019
Messages
36
Motherboard
Dell Optiplex 7050 SFF
CPU
T6600/Q270
Graphics
Integrated GPU
Mobile Phone
  1. Android
Did you try enabling the FixHPET option in Clover? With that, and the correct layout ID, that might be all you need.

Also, in Hackintool, on the screen that shows all the PCI-e devices, do you see an entry for audio (not an HDMI-connected one)?
Screen Shot 2020-05-05 at 12.18.49 am.png
 
Joined
Aug 13, 2017
Messages
169
Motherboard
Dell Inspiron 3670 DT
CPU
i7-9700K
Graphics
UHD 630 / RX570
Mobile Phone
  1. iOS
Will re-enable FixHPET.

Are you able to share you plist file so I can compare?

Looking at https://github.com/acidanthera/AppleALC/wiki/Installation-and-usage I may need to make small changes in the plist file.
I checked both of mine (both Dell Inspiron 3670 desktops) and one has nothing but FixHPET enabled and it worked. The other had some entries in Devices/Properties to define some audio stuff, but I don't think it is necessary since my other system does not have it and audio is working.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,931
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
sometimes having these enabled can work:

Code:
<key>FixTMR</key>
                <true/>
                <key>FixRTC</key>
                <true/>
                <key>FixIPIC</key>
                <true/>
                <key>FixHPET</key>
                <true/>
 
Joined
Mar 6, 2019
Messages
36
Motherboard
Dell Optiplex 7050 SFF
CPU
T6600/Q270
Graphics
Integrated GPU
Mobile Phone
  1. Android
delete those kexts from /L/E, they are not needed there, as you have them in clover/kexts/other

then go over the link i posted on the other page regarding the audio as that appears to be missing from your config.plist
Thanks...
Removed AppleALC, Lilu and WEG from /L/E folder. They only sit in the relevant EFI/../Other folder..

At this stage, do I need to rebuild the cache?

Only link you have provided is the link to Idiots Guide page. Is that what you were referring to? I check few pages back but can't find any link to audio setup guide. Apologies if I am missing something. It is already after midnight in Sydney.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,931
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks...
Removed AppleALC, Lilu and WEG from /L/E folder. They only sit in the relevant EFI/../Other folder..

At this stage, do I need to rebuild the cache?

Only link you have provided is the link to Idiots Guide page. Is that what you were referring to? I check few pages back but can't find any link to audio setup guide. Apologies if I am missing something. It is already after midnight in Sydney.
yes, the idiot guide, it is very useful and has helped many peeps in getting audio working :)

there is also another readme you can check out:

but the idiot guide is very handy
 
Joined
Mar 6, 2019
Messages
36
Motherboard
Dell Optiplex 7050 SFF
CPU
T6600/Q270
Graphics
Integrated GPU
Mobile Phone
  1. Android
yes, the idiot guide, it is very useful and has helped many peeps in getting audio working :)

there is also another readme you can check out:

but the idiot guide is very handy

thanks... thats the page I am working with...


Note: It is necessary to set value layout-id in Devices-Properties or boot arguments.
-->Testing this with different layout-id=X during boot

HDEF device locations PciRoot, gfxutil may be used: gfxutil -f HDEF
--> nothing done for this

Do not use renaming HDAS to HDEF, B0D3 to HDAU, etc.
--> These are not set in plist.

Properties hda-gfx for digital audio of video cards are injected automatically.
--> NA, since iGPU

Disable Clover's:
FixHDA, AddHDMI and UseIntelHDMI, set Devices → Audio → Inject = NO (Necessarily type string!)
--> Made sure they are all set to FALSE and Inject=NO

Will try the list of layout-ids now...

However, I would expect the AppleHDA to be loaded, regardless of the layout-id?
 
Joined
Aug 13, 2017
Messages
169
Motherboard
Dell Inspiron 3670 DT
CPU
i7-9700K
Graphics
UHD 630 / RX570
Mobile Phone
  1. iOS
However, I would expect the AppleHDA to be loaded, regardless of the layout-id?

I think yes. Did you enable FixHPET? (not ResetHPET...FixHPET under ACPI).
 
Top