Contribute
Register

Can't boot UEFI thumb drives on GA-Z87X-UD7 TH but...

Joined
Jan 7, 2011
Messages
88
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Folks,

Last Monday, I saw recent Clover installation guide on the front page. I was able make UEFI stick with Clover EFI and Mavericks OS X software. I tried to boot UEFI stick but Gigabyte UEFI BIOS can't see and boot it. I can't get it through because it does not display that UEFI boot on the BIOS boot menu. Gave up....

Then I tried to install Clover EFI on Marvericks HD partition. I put a few kexts and config.list, etc to EFI filesystem. I rebooted system and BIOS can see UEFI OS on boot menu. I was able boot Clover EFI without any problem. Then I selected Mavericks icon and successfully booted into OS X system!

I am figuring out why Gigabyte BIOS can't see UEFI OS on USB sticks but can see it on SATA/USB SSD/HDD drives. I think that a bug in that UEFI BIOS cause UEFI-mode USB stick detection failure. I have same problems with other UEFI sticks like live Fedora and Ubuntu, etc.. It can only see and boot UEFI-mode Windows sticks. Only Clover EFI boot menu on my Mavericks HD drive can see them.

Does anyone have any solution with that a possible bug in UEFI BIOS? BIOS upgrade? etc...

Thanks,
Sword7
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,269
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Folks,

Last Monday, I saw recent Clover installation guide on the front page. I was able make UEFI stick with Clover EFI and Mavericks OS X software. I tried to boot UEFI stick but Gigabyte UEFI BIOS can't see and boot it. I can't get it through because it does not display that UEFI boot on the BIOS boot menu. Gave up....

Then I tried to install Clover EFI on Marvericks HD partition. I put a few kexts and config.list, etc to EFI filesystem. I rebooted system and BIOS can see UEFI OS on boot menu. I was able boot Clover EFI without any problem. Then I selected Mavericks icon and successfully booted into OS X system!

I am figuring out why Gigabyte BIOS can't see UEFI OS on USB sticks but can see it on SATA/USB SSD/HDD drives. I think that a bug in that UEFI BIOS cause UEFI-mode USB stick detection failure. I have same problems with other UEFI sticks like live Fedora and Ubuntu, etc.. It can only see and boot UEFI-mode Windows sticks. Only Clover EFI boot menu on my Mavericks HD drive can see them.

Does anyone have any solution with that a possible bug in UEFI BIOS? BIOS upgrade? etc...

Thanks,
Sword7
Check the boot mode in BIOS - UEFI only / Legacy and UEFI / Legacy Only are the usual choices.
Also check what you have enabled / disabled as far as USB choices goes. Look at Storage Boot options and make sure it also says UEFI or Legacy + UEFI.
 
Joined
Jan 7, 2011
Messages
88
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Check the boot mode in BIOS - UEFI only / Legacy and UEFI / Legacy Only are the usual choices.
Also check what you have enabled / disabled as far as USB choices goes. Look at Storage Boot options and make sure it also says UEFI or Legacy + UEFI.

Unfortunately it did not work for me. I set boot mode as Legacy and UEFI. I tried Other OS, Windows 8, and Windows 8 WQHL mode but it resulted the same. I tried secure boot as enabled and disabled but it still resulted the same. It can see UEFI boots on other hard drives and SSD drives but not sticks. With Legacy and UEFI boot mode, it can see legacy sticks only. That stick has EFI filesystem with /efi/boot/bootx64.efi. My other computers can see that stick in UEFI mode but not Gigabyte motherboard. My BIOS version is F2.

Thanks,
Sword7
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,269
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Unfortunately it did not work for me. I set boot mode as Legacy and UEFI. I tried Other OS, Windows 8, and Windows 8 WQHL mode but it resulted the same. I tried secure boot as enabled and disabled but it still resulted the same. It can see UEFI boots on other hard drives and SSD drives but not sticks. With Legacy and UEFI boot mode, it can see legacy sticks only. That stick has EFI filesystem with /efi/boot/bootx64.efi. My other computers can see that stick in UEFI mode but not Gigabyte motherboard. My BIOS version is F2.

Thanks,
Sword7

Look at Storage Boot options further down the screen from the boot options and make sure it also says UEFI or Legacy + UEFI. It is, after all a storage device, yes?
 
Joined
Jan 7, 2011
Messages
88
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Look at Storage Boot options further down the screen from the boot options and make sure it also says UEFI or Legacy + UEFI. It is, after all a storage device, yes?

I checked Storage Boot options. I tried different settings but it still resulted the same. I had opened ticket with Gigabyte technical support at Gigabyte website.

Thanks,
Sword7
 
Joined
Jan 7, 2011
Messages
88
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
[Resolved] Can't boot UEFI thumb drives on GA-Z87X-UD7 TH but...

Hello folks,

I contacted Gigabyte technical support. Well, there is a bug in version F2 cause UEFI boot detection failure through USB ports. I recommend to update BIOS to latest version. I updated to version F3. BIOS can now see UEFI boot on any flash drives through USB ports! I now successfully booted Clover USB (Mavericks OS X Installer) into system through USB flash drive.

Thanks,
Sword7
 
Joined
Sep 19, 2012
Messages
22
Motherboard
B150I-GAMING-PRO-AC
CPU
i5-7400T
Graphics
HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello folks,

I contacted Gigabyte technical support. Well, there is a bug in version F2 cause UEFI boot detection failure through USB ports. I recommend to update BIOS to latest version. I updated to version F3. BIOS can now see UEFI boot on any flash drives through USB ports! I now successfully booted Clover USB (Mavericks OS X Installer) into system through USB flash drive.

Thanks,
Sword7

Why didn't you upgrade to version F4?
 
Joined
Jan 7, 2011
Messages
88
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Why didn't you upgrade to version F4?

Yeah. I had a problem with @BIOS and Q-flash because it can't update F4 image due to out of date error messages. I googled it through Internet and found solution. I had to download FreeDOS image and Win32Disk imager. I installed FreeDOS image into my flash drive and placed F4 image and efiflash.exe into that. I restarted system and booted FreeDOS into system. I was now able flash F4 image successfully.

I restarted system and was able boot Clover boot manager and Mac OS X into system without any problem.

If you have F2 version on GA-Z87X-UD7 TH motherboard, I recommend to update to F4 version because of UEFI boot bugs in F2 and F3 firmwares. For F2 version, BIOS can't see UEFI boot on USB drives. For F3 version, BIOS can see UEFI boot but boot was extremely slow and keyboard is not responsive for first few minutes. For F4 version, both problems had been resolved.

Thanks,
Sword7
 
Joined
Sep 18, 2011
Messages
1
Motherboard
GA-Z87X-UD7-TH
CPU
Intel Core i7-4770K
Graphics
ASUS GTX770-DC2OC-2GD5 DirectCU II OC
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi,

to successfully update BIOS to F4 release you have to either use AppCenter and upgrade @BIOS to the latest release which is B13.1112.1 or use efiflash.exe included in the download of the BIOS file.

By the way there is already F5 out which is supposed to enhance System compatibilty.
 
Top