Contribute
Register

Can't boot UEFI thumb drives on GA-Z87X-UD7 TH but...

Joined
May 11, 2013
Messages
76
Motherboard
GA-Z87X-UD7 TH
CPU
Haswell i7 4770K
Graphics
EVGA GTX 770 4GB SC
Mac
Classic Mac
Mobile Phone
  1. iOS
Where are you getting the f5 bios? as far as gigabytes site is concerned it is at f4 and you cannot use myapp to update, you have to use a DOS with efiflash.
 
Joined
May 11, 2013
Messages
76
Motherboard
GA-Z87X-UD7 TH
CPU
Haswell i7 4770K
Graphics
EVGA GTX 770 4GB SC
Mac
Classic Mac
Mobile Phone
  1. iOS
Folks,

Last Monday, I saw recent Clover installation guide on the front page. I was able make UEFI stick with Clover EFI and Mavericks OS X software. I tried to boot UEFI stick but Gigabyte UEFI BIOS can't see and boot it. I can't get it through because it does not display that UEFI boot on the BIOS boot menu. Gave up....

Then I tried to install Clover EFI on Marvericks HD partition. I put a few kexts and config.list, etc to EFI filesystem. I rebooted system and BIOS can see UEFI OS on boot menu. I was able boot Clover EFI without any problem. Then I selected Mavericks icon and successfully booted into OS X system!

I am figuring out why Gigabyte BIOS can't see UEFI OS on USB sticks but can see it on SATA/USB SSD/HDD drives. I think that a bug in that UEFI BIOS cause UEFI-mode USB stick detection failure. I have same problems with other UEFI sticks like live Fedora and Ubuntu, etc.. It can only see and boot UEFI-mode Windows sticks. Only Clover EFI boot menu on my Mavericks HD drive can see them.

Does anyone have any solution with that a possible bug in UEFI BIOS? BIOS upgrade? etc...

Thanks,
Sword7
Sword7, any chance you have a good tutorial on how to clover this board? I have the same board and video card... I was successful with unibeast and multicast, but clover is a different ballgame.
 
Joined
Jun 28, 2011
Messages
22
Motherboard
GA-Z87X-UD7 TH rev. F5a
CPU
i7 4790K
Graphics
onboard
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Where are you getting the f5 bios? as far as gigabytes site is concerned it is at f4 and you cannot use myapp to update, you have to use a DOS with efiflash.

old thread, but fwiw, on my GA-Z87X-UD7 TH I just updated to the most current bios f5a using only a dos formatted USB stick with the downloaded bios rom copied to it. No issues so far, smooth sailing with 10.12.2. Now on to fixing those nasty USB glitches...
 
Top