Contribute
Register

Black screen for 1 or 2 minutes Big Sur RX5700

Status
Not open for further replies.
Joined
May 31, 2010
Messages
49
Motherboard
Gigabyte Aorus Ultra Z390
CPU
i7 9900K
Graphics
Powercolor Radeon RX5700 XT
My Big Sur starts with a black screen after the Apple logo (monitor is awake). It stays black for a minute or two and then the picture is on.
Everything is fine after that.
Any ideas what I could do to fix it?
Powercolor RX5700 XT
Gigabyte Z390 Aorus Ultra
i7 9900K
Opencore 0.6.3
All kexts up to date
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
I think it's a Whatevergreen issue, I have the same on OC 0.6.3 and latest WEG (1.4.4) on Catalina.
 
Joined
Jul 15, 2020
Messages
35
Motherboard
DELL INSPIRON 7586 2-in-1 OC066
CPU
i7-8565U
Graphics
UHD 620, 4K 3840 x 2160
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
No not yet sorry
 
Joined
Jan 11, 2021
Messages
1
Motherboard
HM76
CPU
i7-8750H
Graphics
GTX 1050 Ti
My Big Sur starts with a black screen after the Apple logo (monitor is awake). It stays black for a minute or two and then the picture is on.
Everything is fine after that.
Any ideas what I could do to fix it?
Powercolor RX5700 XT
Gigabyte Z390 Aorus Ultra
i7 9900K
Opencore 0.6.3
All kexts up to date
I have the same problem, do you found solution?
 
Joined
May 5, 2018
Messages
60
Motherboard
Gigabyte Z390 Aorus Ultra
CPU
i7-8700K
Graphics
Vega 64
Mobile Phone
  1. Android
add -igfxblr to your boot arguments. Worked for me. Whatevergreen was updated with new things and that is one.
 
Joined
Mar 6, 2019
Messages
2
Motherboard
Gigabyte AORUS ULTRA
CPU
i7
Graphics
RX 5700 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Solved for me by adding -igfxblr to boot arguments (on OC 0.6.5) and updating WateverGreen.kext to 1.4.7.

Meanwhile I also updated to MacOS 11.2.1 - not sure if it had any influence on the success (surely it doesn't have any negative effect)


EDIT: I think I spoke too early.... black screen is still there :(
 
Last edited:
Status
Not open for further replies.
Top