Contribute
Register

Audio Sometimes Not Working With VoodooHDA2.9.1?

Status
Not open for further replies.
Joined
Jun 15, 2010
Messages
151
Motherboard
ASUS PRIME B360M-A
CPU
i3-8100
Graphics
RX 580 8gb
Hey guys, I'm wondering if anyone has had an issue with VoodooHDA.kext on Mojave where the menu bar sound icon is sometimes greyed out after booting?
-This only happens maybe 1/5 times so it's inconsistent
-Usually a shut down, reboot, or a hard shut down (holding power button on computer) will cause the sound to work again next time the computer boots.

I searched the forum but the only posts I can find on this issue are very old and not relevant to Mojave.

I wasn't able to get AppleALC working which is why I ended up using VoodooHDA, but I'd be open to trying it again.
My EFI/Clover folder is attached.
Thanks.
 

Attachments

  • CLOVER.zip
    3 MB · Views: 146
Joined
Jun 15, 2010
Messages
151
Motherboard
ASUS PRIME B360M-A
CPU
i3-8100
Graphics
RX 580 8gb
Anybody? (Sent with Echo).
 
Joined
Apr 25, 2019
Messages
22
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050 Ti
Mobile Phone
  1. Android
Hey guys, I'm wondering if anyone has had an issue with VoodooHDA.kext on Mojave where the menu bar sound icon is sometimes greyed out after booting?
-This only happens maybe 1/5 times so it's inconsistent
-Usually a shut down, reboot, or a hard shut down (holding power button on computer) will cause the sound to work again next time the computer boots.

I searched the forum but the only posts I can find on this issue are very old and not relevant to Mojave.

I wasn't able to get AppleALC working which is why I ended up using VoodooHDA, but I'd be open to trying it again.
My EFI/Clover folder is attached.
Thanks.

Same here, trying to use AppleALC, but nothing, so I ended up using VoodooHDA, headphones ALWAYS works, but speakers, works like 4/10 times. I searched in the whole internet, but without find a solution, so, if you can use headphones, it's better than nothing, like AppleALC, I'm sorry I can not help you.
 
Joined
Jun 15, 2010
Messages
151
Motherboard
ASUS PRIME B360M-A
CPU
i3-8100
Graphics
RX 580 8gb
I actually got mine working a couple months ago.

If I remember correctly, all I had to do was remove AppleHDA.kext from System/Library/Extensions (back it up before trying this in case I'm wrong!)
Have you removed AppleALC from both your EFI/Clover folder and Library/Extensions? if either of those kexts are present it creates a conflict and the computer doesn't know which to use on start up. Which explains why it was only working some of the time. Hope this works for you too.
 
Joined
Apr 25, 2019
Messages
22
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050 Ti
Mobile Phone
  1. Android
I actually got mine working a couple months ago.

If I remember correctly, all I had to do was remove AppleHDA.kext from System/Library/Extensions (back it up before trying this in case I'm wrong!)
Have you removed AppleALC from both your EFI/Clover folder and Library/Extensions? if either of those kexts are present it creates a conflict and the computer doesn't know which to use on start up. Which explains why it was only working some of the time. Hope this works for you too.

Delete AppleHDA? But VoodooHDA injects in AppleHDA, without AppleHDA, I think it won't work, I'm gonna try it, but I don't think it will work.
 
Joined
Jun 15, 2010
Messages
151
Motherboard
ASUS PRIME B360M-A
CPU
i3-8100
Graphics
RX 580 8gb
My understanding is the AppleHDA in your Extensions folder is not hackintosh compatible. It injects audio for real macs so as long as you are using Voodoo it doesn't matter. Like I said you can always back it up and replace it if it causes issues. It worked for me.
 
Status
Not open for further replies.
Top