Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Aug 6, 2016
Messages
25
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700K
Mac
MacBook Pro
Thanks so much for the guide! Took me a few tries to get this on my skylake. I'm new to this and initially I thought this meant to remove the ENTIRE config.plist file (which I almost did....):

Skylake/HD 5x0, remove config.plist (if present)
When I realized that this meant "remove these entries from your config.plist", everything made much more sense. Thanks again :)
 
Joined
Aug 6, 2016
Messages
25
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700K
Mac
MacBook Pro
Sadly I'm having a graphics issue now. After running the cloverHDMI script and restarting, I noticed that my system no longer provided my monitor with full resolution HDMI output - previously I was seeing the correct 2560x1440 resolution, but now I only get 1080p. Curiously, before my system did not recognize my monitor model correctly, but now it does (Asus PB277Q).

GA Z170X-UD5
Intel 6700K (skylake) with integrated graphics: Intel HD Graphics 530
2x16GM RAM

Anyway, now that my HDMI audio is working, do you know what may have caused my integrated graphics to no longer support full resolution? Here is the output from when I ran the script the first time - it did not seem to recognize my display. After reboot, the script ran as expected, but my resolution was decreased to 1080p.

Code:
File: audio_cloverHDMI-110.command_v0.22 - BETA
Release Mode
EFI partition is mounted
HDMI audio codec(s)
Intel:    0x80862809
HD530 HDMI audio is not enabled
Install SSDT-HDMI-HD530 HDMI audio ssdt (y/n): y
Download SSDT-HDMI-HD530 ...

WARNING: Improper use of the sudo command could lead to data loss
or the deletion of important system files. Please double-check your
typing when using sudo. Type "man sudo" for more information.

To proceed, enter your password, or type Ctrl-C to abort.

Password:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 44769  100 44769    0     0  49730      0 --:--:-- --:--:-- --:--:-- 49688
Download SSDT-HDEF-HDAS-1.aml ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 44816  100 44816    0     0   114k      0 --:--:-- --:--:-- --:--:--  115k
/Volumes/EFI/EFI/CLOVER/ACPI/patched/SSDT-HDMI-HD530 installed
/Volumes/EFI/EFI/CLOVER/ACPI/patched/SSDT-HDEF-HDAS-1 installed
No display connected to HD530
Error: patch not possible
AMD/Nvidia not found
No system files were changed
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...none found.

[Process completed]
 
Joined
Jun 30, 2012
Messages
82
Motherboard
MSI Krait Gaming 3x
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Code:
Last login: Mon Aug  8 19:40:19 on console
/Users/shhbz/Desktop/audio_cloverHDMI-110_v0.22-2.command ; exit;
Shhbzs-iMac:~ shhbz$ /Users/shhbz/Desktop/audio_cloverHDMI-110_v0.22-2.command ; exit;
Agreement
The audio_cloverHDMI script is for personal use only. Do not distribute
the patch, any or all of the files or the resulting patched AppleHDA.kext
for any reason without permission. The audio_cloverHDMI script is
provided as is and without any kind of warranty.
File: audio_cloverHDMI-110.command_v0.22 - BETA
Release Mode
EFI partition is mounted
HDMI audio codec(s)
Intel:    0x80862809
HD530 HDMI audio is enabled, connector edit may be required
Verify HD530 HDMI audio connector/s (y/n):
osx 10.11.6|MSI gaming 3x krait|F4 bios version|6700k i7| intel HD530
guide used:audio_cloverHDMI-110_v0.22-2.command

please help I am very much new to this and just can't solve this final issue @toleda my patched folder contains SSDT-HDEF-HDAS-1.aml and SSDt-HDMI-530.aml which showed after the scrip was installed and using HDMI port to connect the monitor
 

Attachments

Last edited:
Joined
Jun 30, 2012
Messages
82
Motherboard
MSI Krait Gaming 3x
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
config.plist is damaged, no KextsToPatch, replace.
if you can please share some more light on what exactly I need to do or a thread which I can follow to solve the issue,I have very less knowledge of this and after a week of reading and trying your various thread i came to this solution where hd530 finally got enabled but came up with the next problem and I am unable to find a solution to it so what exactly I need to do to solve this

if you can rectify my config.plist then i can have a look at what exactly I was missing to get it working
 
Last edited:

toleda

Moderator
Joined
May 20, 2010
Messages
24,452
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Jun 30, 2012
Messages
82
Motherboard
MSI Krait Gaming 3x
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
See end of Post
Hi just checked the config plist from linked thread and found that the major change is that there is dsdt.aml and dart=0 in clover rest all are same just the iMessage fix not included as I did to my file so I am confused as i don't use dsdt so what to do apart from dart=0 which is used for bypassing vt-d

i even found Slice-config.plist under EfI partition ,file attached
 

Attachments

Last edited:
Status
Not open for further replies.
Top