Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Jan 10, 2016
Messages
14
Motherboard
Asus H97M-Plus
CPU
Core i36100
Graphics
HD530
Mac
MacBook Air
Mobile Phone
iOS
No patches, no hdmi audio. No files, no idea.
Hey Toleda,
it's been a while since my last post as I've been busy but I wanted to give this another try to see if I can get working HDMI audio.
As said before I don't have a discrete GPU, still coverHDMI seems to be looking for one. But from what's in the guide I understand that it should be working with only the integrated GPU (iGPU), is that correct?

If so, then let me start over:
I followed you guide and removed all arbitrary entries from the config.plist.
Do you mind having a look at my report files to see if I'm good to go and run your cloverHDMI script?

thanks a lot
Laurens
 

Attachments

toleda

Moderator
Joined
May 20, 2010
Messages
24,453
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I tried running cloverHDMI
Ignore error, script ran on 8/1/16:
HDMI audio edited /Volumes/EFI/EFI/CLOVER/config.plist installed
Attached config.plist has a last opened date of 7/3/16, not the config.plist edited.
Installed config.plist is in a different EFI partition than the EFI partition booting.
 
Joined
Jan 10, 2016
Messages
14
Motherboard
Asus H97M-Plus
CPU
Core i36100
Graphics
HD530
Mac
MacBook Air
Mobile Phone
iOS
Ignore error, script ran on 8/1/16:
HDMI audio edited /Volumes/EFI/EFI/CLOVER/config.plist installed
Attached config.plist has a last opened date of 7/3/16, not the config.plist edited.
Installed config.plist is in a different EFI partition than the EFI partition booting.
You are correct. Config.plist uploaded is the one that was installed before running cloverHDMI script.

The new files attached in this post are from after running cloverHDMI.
Note that I had to remove 10.11.4-SKL-1912000-Port_0x6-DP2HDM patch since it gives me a kernel panic at startup. So I did run the script, restarted and got a kernel panic, then booted into windows and removed said patch from config.plist and finally booted back into OS X and gathered all the report files.
 

Attachments

Last edited:
Joined
Jan 10, 2016
Messages
14
Motherboard
Asus H97M-Plus
CPU
Core i36100
Graphics
HD530
Mac
MacBook Air
Mobile Phone
iOS
No HDMI audio without the patch. Clean install.
Two questions:
1) What exactly do you mean by 'clean install'?
2) Any idea why cloverHDMI is looking for a discrete GPU even though there is none installed? Is this connected to the missing patch?

Thanks for your help
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,453
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Two questions
Clean install is a new install on an empty partition.
When the script reports no discreet graphics, it has finished with Intel graphics; ignore. I fixed a different problem and broke the no discrete graphics verification.
 
Joined
Aug 3, 2016
Messages
8
Motherboard
Gigabyte Z170-HD3P
CPU
Intel i5 6600
Graphics
Sapphire Radeon HD 7770 Vapor-X
Mac
MacBook Pro
Mobile Phone
iOS
Joined
Jan 10, 2016
Messages
14
Motherboard
Asus H97M-Plus
CPU
Core i36100
Graphics
HD530
Mac
MacBook Air
Mobile Phone
iOS
Clean install is a new install on an empty partition.
When the script reports no discreet graphics, it has finished with Intel graphics; ignore. I fixed a different problem and broke the no discrete graphics verification.
Okay thanks for the reply. I won't be able to make a clean install soon but I might get around to it in September. I will try it again once its done. Thanks again for taking the time and looking at my problem!
 
Status
Not open for further replies.
Top