Contribute
Register

Asus TP500LA with macOS High Sierra

Status
Not open for further replies.
Joined
Feb 23, 2017
Messages
274
Motherboard
MSI H97 GAMING 3
CPU
i5-4690
Graphics
HD 4600 & GTX 650 Ti
Mobile Phone
  1. iOS
For sleep/wake i needed to disable my touchscreen using USBInjectAll.kext and a custom SSDT, Audio i use AppleALC.kext \ Lilu.kext and the appropriate layout id in DSDT, to disable the Nvidia card you need to do that in your DSDT which you can extract with Clover at the boot screen and press F4 which will dump the native files into EFI\CLOVER\ACPI\origin. The boot screen glitch can be lessened \ removed by using IntelGraphicsFixup.kext.
Most of these issues have guides available on this site.
https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/
https://www.tonymacx86.com/threads/guide-disabling-discrete-graphics-in-dual-gpu-laptops.163772/
https://github.com/vit9696
https://sourceforge.net/projects/intelgraphicsfixup/

Hey savage001, I fixed lots of issues lately, thanks to RehabMan. Right now I have backlight full brightness on every boot (turns out my NVRAM is not working, custom variable couldn't stayed over a boot), Fn+F4/F5 keys not changing brightness (I need a function discovery for this one), and Sleep/Wake. Since we have similar h/w maybe your solution can be my solution too for Sleep/Wake. Can you share your custom SSDT file that is used by USBInjectAll.kext? If it doesn't work, at least I modify it. Btw, I checked and we have same USB port config as in 2 USB2 on the left side and 1 USB3 on the right side. This could work.

And btw, how did you find out that touch screen is the main issue of Sleep/Wake?

Other minor issues are a lag right after the boot, Screen glitch which I can live with that (I wish there is a way to make it work with UEFI only so it starts at full resolution like real macs instead of fatty {due to the broken aspect ratio} apple logo first, then a glitch and full res clean image) and long boot up and shut down, restart times. I have Kingston HyperX Savage 240 SSD Drive, and in windows everything is really fast. I'll check this after I solve all issues.

And a final question How long does your juice last? With Power Management I got 3 hours, after disabling Nvidia I earn another hour. Now I fixed broadwell issue on power management (idle CPU freq stuck at 1300 MHz), now it's 800 MHz and I'll see how much will that effect the usage.

Cheers!

You can try following my guide here: https://www.tonymacx86.com/threads/guide-macos-on-the-asus-tp500la-broadwell-edition.212252/

It's not quite up to date, but that's because this site is extremely slow for me when logged in to my account.

For the Nvidia GPU, you can follow Rehabmans guide to disable it. His method works, I tried it on my brothers TP550LA, which is slightly different to mine (older cpu and nvidia gpu).
Hey haimann951, it would be really great if we see you more. Since we have quite similar h/w, that would help me a lot. For instance, if you really get everything working by just doing the things you wrote onto your guide, I wonder if you have any issues like Sleep/Wake (Did you disable the touchscreen too?), brightness and such that the majority have.

Cheers!
 
Joined
Aug 2, 2013
Messages
37
Motherboard
ITX-HM77
CPU
i3-3320M
Graphics
HD4000
Mobile Phone
  1. iOS
Hi,

I have successfully installed macOS High Sierra on my ASUS TP500LA.

Everything is working except the battery percentage (its stuck unless you uncheck show percentage and reactivate it again)
using the 10.12 configuration.

Thats it for now.

Work with me. ASUS TP300LA but don't work with AR946x, don't see my wifi.
 
Joined
Feb 23, 2017
Messages
274
Motherboard
MSI H97 GAMING 3
CPU
i5-4690
Graphics
HD 4600 & GTX 650 Ti
Mobile Phone
  1. iOS
Do you guys use the new file system?
 
Joined
Aug 24, 2017
Messages
14
Motherboard
Haswell-MB
CPU
i7 4700HQ
Graphics
NVIDIA GTX 765M
I can confirm the ACPIBatteryManager issue on a Ausus g750jw with battery DSDT patch.

Battery Condition says "Replace Soon"
Icon has to be toggled after boot and sleep, but does not track adapter state.
HighSierra install USB will not boot internal drive while ACPIBatteryManager.kext is installed on system. System hangs with ACPI enumeration error refering to BAT0 and ECO, until restart, although i have not tried booting it with safe mode.

This is all the debugging i have done so far. But, for anyone else having this issue ill will submit problem reporting files later today if i cant resolve it.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I can confirm the ACPIBatteryManager issue on a Ausus g750jw with battery DSDT patch.

Battery Condition says "Replace Soon"
Icon has to be toggled after boot and sleep, but does not track adapter state.
HighSierra install USB will not boot internal drive while ACPIBatteryManager.kext is installed on system. System hangs with ACPI enumeration error refering to BAT0 and ECO, until restart, although i have not tried booting it with safe mode.

This is all the debugging i have done so far. But, for anyone else having this issue ill will submit problem reporting files later today if i cant resolve it.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Aug 24, 2017
Messages
14
Motherboard
Haswell-MB
CPU
i7 4700HQ
Graphics
NVIDIA GTX 765M
RehabMan,

Firstly, let me take this time to thank you for all your hard work! I don't think we as a community truly understand the gratitude that is owed to you.

Attached are problem reporting files, modified smbios in plist to upload.

Thanks again. I should probably go focus on client issues.

On a side note; this device also has a AR9485 not supported and never used, always ethernet. But on HS, the BT module is natively supported.
 

Attachments

  • problem reporting.zip
    3 MB · Views: 66
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
RehabMan,

Firstly, let me take this time to thank you for all your hard work! I don't think we as a community truly understand the gratitude that is owed to you.

Attached are problem reporting files, modified smbios in plist to upload.

Thanks again. I should probably go focus on client issues.

On a side note; this device also has a AR9485 not supported and never used, always ethernet. But on HS, the BT module is natively supported.

Your ioreg shows APFS.
Your config.plist has the TRIM patch.
Looks likely to be a bad combination for a lot of hardware.
Disable the TRIM patch.

Note:
- FIX_ACST_4000000 is a bad idea (remove)
- looks like you have renames in DSDT that you didn't apply to SSDTs (big mistake). Renames must be balanced across all DSDT+SSDTs that reference the symbol
 
Joined
Aug 24, 2017
Messages
14
Motherboard
Haswell-MB
CPU
i7 4700HQ
Graphics
NVIDIA GTX 765M
Correct.
Removed.
Removed.
Yes, PCI slot(for sanity's sake), IGPU(oem disabled), and GFX1
I think you're referring to SSDT-7? Oddly enough I haven't seen any issues with that setup on Sierra. I uploaded changed SSDT Currently booted with this in patched, and drop oem.

Booted 5 seconds faster with these changes. But no change to battery status.
 

Attachments

  • SSDT-7.aml
    23.9 KB · Views: 116
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Correct.
Removed.
Removed.
Yes, PCI slot(for sanity's sake), IGPU(oem disabled), and GFX1
I think you're referring to SSDT-7? Oddly enough I haven't seen any issues with that setup on Sierra. I uploaded changed SSDT Currently booted with this in patched, and drop oem.

Booted 5 seconds faster with these changes. But no change to battery status.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Aug 24, 2017
Messages
14
Motherboard
Haswell-MB
CPU
i7 4700HQ
Graphics
NVIDIA GTX 765M
It works.

After second reboot battery icon is persistent, ac adapter state/battery drain is recognized (20 second delay), battery condition replace soon, lol as if...

I'd say this is solved for me. Thanks RehabMan! Do you think it was fix_ACST or the SSDT renaming? I uploaded problem reporting files, in case you wanted to see what worked.
 

Attachments

  • problem reporting 2.zip
    3 MB · Views: 50
Status
Not open for further replies.
Top