Contribute
Register

Apple Bluetooth Module Wireless Keyboard Problem

Joined
Jul 19, 2012
Messages
5
Motherboard
MacBook Pro
CPU
Intel i3
Graphics
HD3000
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
I am running a CustoMac 2011 with a GA-H61-USB3 motherboard and an i3 processor. Originally I was using a belkin mini bluetooth adaptor to connect my Apple Wireless Keyboard and Magic Mouse. The keyboard connection worked well, but there was very bad mouse lag and both were prone to dropping out. The connection distances are well below 10m and there are no other bluetooth devices working nearby. I have tried to solve the problem with an Apple Bluetooth Module from a 2006 MacBook. I have stepped down the voltage from 5v to 3.3v and connected it to a USB header on the motherboard. Now the Magic Mouse works flawlessly with no connection drops and no mouse lag - the problem is that the keyboard does not detect at all.


I have found the solution to this problem. http://prasys.info/2011/04/fixing-csr-bluetooth-in-osx/
 
Joined
Feb 1, 2012
Messages
76
Motherboard
GA-Z77X-UP5 TH [F11]
CPU
i7-2600 3.4Ghz (no HD3000)
Graphics
NVIDIA GeForce GTX 650
Mac
MacBook
Classic Mac
128K, 512K, Apple, Classic, iBook, iMac, LC, Plus, Portable, Power Mac, PowerBook, Quadra
Mobile Phone
iOS
I am running a CustoMac 2011 with a GA-H61-USB3 motherboard and an i3 processor. Originally I was using a belkin mini bluetooth adaptor to connect my Apple Wireless Keyboard and Magic Mouse. The keyboard connection worked well, but there was very bad mouse lag and both were prone to dropping out. The connection distances are well below 10m and there are no other bluetooth devices working nearby. I have tried to solve the problem with an Apple Bluetooth Module from a 2006 MacBook. I have stepped down the voltage from 5v to 3.3v and connected it to a USB header on the motherboard. Now the Magic Mouse works flawlessly with no connection drops and no mouse lag - the problem is that the keyboard does not detect at all.


I have found the solution to this problem. http://prasys.info/2011/04/fixing-csr-bluetooth-in-osx/
Thanks for that info, very much appreciated. I am still trying to digest it to make soem no-name bluetooth dongle work. Right it gives me terrible lag on my magic mouse.
Any complementary tutorial would be welcome.

Also, I am a bit wary of using that kext coming from who-knows-where, and is it current (ML)?

(BTW, I suggest you edit your post title and prefix it with "[SOLVED] - ")
 
Top