Contribute
Register

(99% perfect) Sierra 10.12.6 on Thinkpad x1 carbon 5th-gen with dual-boot unchanged Win7

Joined
Jul 12, 2017
Messages
12
Motherboard
Thinkpad X1 Carbon 6th Gen + Clover UEFI
CPU
i7-8650U
Graphics
Intel UHD 620 Graphics
Mobile Phone
  1. iOS
1. change a high-quality HDMI cable ... (don't laugh, do introduce difference)
2. Found thinkpad x1c using eDP rather than LVDS, change HDMI patch
3. carefully follow the wonderful HDMI audio guide
now it seems ok..

Which HDMI patch are you referring to?
 
Joined
Oct 19, 2017
Messages
31
Motherboard
Thinkpad x1 carbon 5th gen
CPU
intel i7-7600U
Graphics
intel HD620 1920*1280
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Which HDMI patch are you referring to?

this is the patch i chose.
based on RehabMan's HDMI patch, adding eDP support, so far so good..
upload_2018-6-20_12-52-48.png
 
Joined
Sep 13, 2012
Messages
5
Motherboard
Thinkpad x1 Carbon 4th gen
CPU
i7-6600U
Graphics
Intel HD Graphics 520
Hi @chaihaixin,

I followed your steps on my Lenovo X1 Carbon 4th and OSX 10.13.4 and the results are pretty good so far! Everything seems to be working as per your guide other than wifi

I purchased a wifi replacement card however osx only detects BT. The card is also not recognized in windows 10 either, only bluetooth works.
This is the wifi card I purchased: Broadcom BCM94352Z DW1560 802.11AC 867Mbps Bluetooth 4.0 WIFI Card f Hackintosh (https://www.ebay.ca/itm/Broadcom-BC...tooth-4-0-WIFI-Card-f-Hackintosh/263584111500)

@chaihaixin do you know what might be causing the issue?
@RehabMan can you please help?
 

Attachments

  • debug_19357.zip
    2.3 MB · Views: 55
Joined
Oct 19, 2017
Messages
31
Motherboard
Thinkpad x1 carbon 5th gen
CPU
intel i7-7600U
Graphics
intel HD620 1920*1280
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Sorry no idea. If it can't work in Windows, less hope it will work in Mac. What you mean "not recognized" in windows? an unknown device in device manager or nothing new at all? Are the antenna correctly connected?
 
Joined
Sep 13, 2012
Messages
5
Motherboard
Thinkpad x1 Carbon 4th gen
CPU
i7-6600U
Graphics
Intel HD Graphics 520
Thanks chaihaixin. I checked with the ebay seller and he confirmed the card is not compatible with my thinkpad x1 carbon 4th gen.

I appreciate the support
 
Joined
Sep 13, 2012
Messages
5
Motherboard
Thinkpad x1 Carbon 4th gen
CPU
i7-6600U
Graphics
Intel HD Graphics 520
Sorry no idea. If it can't work in Windows, less hope it will work in Mac. What you mean "not recognized" in windows? an unknown device in device manager or nothing new at all? Are the antenna correctly connected?

Only bluetooth was detected as new device under device manager.

Can you please provide more details about your wifi card? did you get it from ebay?
any link will be greatly appreciated!

thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,155
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi @chaihaixin,

I followed your steps on my Lenovo X1 Carbon 4th and OSX 10.13.4 and the results are pretty good so far! Everything seems to be working as per your guide other than wifi

I purchased a wifi replacement card however osx only detects BT. The card is also not recognized in windows 10 either, only bluetooth works.
This is the wifi card I purchased: Broadcom BCM94352Z DW1560 802.11AC 867Mbps Bluetooth 4.0 WIFI Card f Hackintosh (https://www.ebay.ca/itm/Broadcom-BC...tooth-4-0-WIFI-Card-f-Hackintosh/263584111500)

@chaihaixin do you know what might be causing the issue?
@RehabMan can you please help?

No Broadcom WiFi on the PCIe bus:
Code:
0:100  0:000  === [ GetDevices ] ========================================
0:100  0:000  PCI (00|00:00.00) : 8086 1904 class=060000
0:100  0:000  PCI (00|00:02.00) : 8086 1916 class=030000
0:100  0:000   - GFX: Model=Intel HD Graphics 520 (Intel)
0:100  0:000  PCI (00|00:08.00) : 8086 1911 class=088000
0:100  0:000  PCI (00|00:13.00) : 8086 9D35 class=000000
0:100  0:000  PCI (00|00:14.00) : 8086 9D2F class=0C0330
0:100  0:000  PCI (00|00:14.02) : 8086 9D31 class=118000
0:100  0:000  PCI (00|00:16.00) : 8086 9D3A class=078000
0:100  0:000  PCI (00|00:17.00) : 8086 9D03 class=010601
0:100  0:000  PCI (00|00:1C.00) : 8086 9D10 class=060400
0:100  0:000  PCI (00|02:00.00) : 10EC 525A class=FF0000
0:100  0:000  PCI (00|00:1C.02) : 8086 9D12 class=060400
0:100  0:000  PCI (00|00:1F.00) : 8086 9D48 class=060100
0:100  0:000  PCI (00|00:1F.02) : 8086 9D21 class=058000
0:100  0:000  PCI (00|00:1F.03) : 8086 9D70 class=040300
0:100  0:000  PCI (00|00:1F.04) : 8086 9D23 class=0C0500
0:100  0:000  PCI (00|00:1F.06) : 8086 156F class=020000

Your WiFi hardware is either defective, installed incorrectly, disabled in BIOS, or rejected by BIOS.
 
Joined
Sep 19, 2019
Messages
1
Hello. I successfully installed Mac OS Mojave, but I get kernel panic after boot system (debug.log attached).

160:623 0:045 Intel HD Graphics 620 [8086:5916] :: PciRoot(0x0)\Pci(0x2,0x0)
160:669 0:045 ig-platform-id = 0x12345678
....
163:640 0:069 Custom boot screen not used because entry has unset use graphics
163:686 0:046 Closing log

Configuration:
Intel i5-7200U
Intel HD Graphics 620
 

Attachments

  • debug.log.zip
    9.7 KB · Views: 87
  • CLOVER.zip
    2.2 MB · Views: 80
Last edited:
Top