Contribute
Register

4530s USB 3.0 Half Working.

Joined
Apr 20, 2011
Messages
102
Motherboard
Hackintosh
CPU
I5 2300
Graphics
GTX 460 MSI 1GB
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. 512K
Mobile Phone
  1. Android
  2. iOS
Hi Guys,

My 4530s Hack (2430M, HD3000, 8GB & 750HDD) finally works great bar the wifi but thats cos i bought a dead card... Anyway I just want some advice on the USB 3.

Basically it will charge an iPad which can't be charged from a USB 2.0 but it wont read anything no matter what it is. It just gives me an error in iTunes but if i plug it in and then go to system report it can see that the iPad is plugged in, if I open Sys report and then plug it in i will charge but won't be seen. Also it only says a speed of 480 mb/s i.e USB 2.0 Speed. I'm running 8.3 and always have. And windows works fine!

Any help would be great as obviously I'd love to take advantage of the speed
 

Attachments

  • SysRepAfterPluggedIn.png
    SysRepAfterPluggedIn.png
    148.8 KB · Views: 214
  • iTunesError.jpg
    iTunesError.jpg
    126.5 KB · Views: 133
  • PluggedInAfter.png
    PluggedInAfter.png
    69.5 KB · Views: 172
Joined
Oct 22, 2012
Messages
3,476
Motherboard
HP Elitebook 8470p
CPU
Intel Core i5 3320M
Graphics
Intel HD 4000, 1600x900
Mobile Phone
  1. iOS
Install Probook Installer with the latest USB3.0 kext to solve this problem.
 
Joined
Sep 19, 2012
Messages
711
Motherboard
hackintosh
CPU
i3
Graphics
intel
Umm, kinda thought it would be assumed that was the first thing i tried...

we can assume you didn't.

have you tried a usb3 hub.

iphones/ipads use usb2. how are you going to get the extra speed on the usb3. did i miss something?

afaik its been a longtime issue using ios devices on the probook usb3 port. its ok for mouse/kb and usb3 storage.

unless the developer of the genericusb3 kext finds a way to get it working, or someone else, its usb2 direct or via hub.
 
Joined
Apr 20, 2011
Messages
102
Motherboard
Hackintosh
CPU
I5 2300
Graphics
GTX 460 MSI 1GB
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. 512K
Mobile Phone
  1. Android
  2. iOS
If you read what I had asked it was how to get full speed USB 3. Hence I added a pic showing the 480mb/s on ssusb.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi Guys,

My 4530s Hack (2430M, HD3000, 8GB & 750HDD) finally works great bar the wifi but thats cos i bought a dead card... Anyway I just want some advice on the USB 3.

Basically it will charge an iPad which can't be charged from a USB 2.0 but it wont read anything no matter what it is. It just gives me an error in iTunes but if i plug it in and then go to system report it can see that the iPad is plugged in, if I open Sys report and then plug it in i will charge but won't be seen. Also it only says a speed of 480 mb/s i.e USB 2.0 Speed. I'm running 8.3 and always have. And windows works fine!

Any help would be great as obviously I'd love to take advantage of the speed

What version of GenericUSBXHCI.kext are you running? Where did you get it from?
 
Joined
Oct 22, 2012
Messages
3,476
Motherboard
HP Elitebook 8470p
CPU
Intel Core i5 3320M
Graphics
Intel HD 4000, 1600x900
Mobile Phone
  1. iOS
Your system is using PXHCD instead of the latest GenericUSBXHCI kext (you can look at his screenshot). Try removing PXHCD.kext in S/L/E and install the latest kext. iPhone work with my USB 3.0 port.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Your system is using PXHCD instead of the latest GenericUSBXHCI kext (you can look at his screenshot). Try removing PXHCD.kext in S/L/E and install the latest kext. iPhone work with my USB 3.0 port.

Yeah... I didn't look at it that closely and since he said he already installed the latest, I trusted what he said...

@sean2e

You might consider running the latest ProBook Installer v6.1b11 to refresh your system. There are a lot of advances in this version of the Installer including automatic DSDT/SSDT generation, and updated kexts. Maybe you haven't been keeping up on the developments, but v6.1b11 is pretty solid. Be sure to read the guide and changelog so you understand what's going on.
 
Joined
Apr 20, 2011
Messages
102
Motherboard
Hackintosh
CPU
I5 2300
Graphics
GTX 460 MSI 1GB
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. 512K
Mobile Phone
  1. Android
  2. iOS
Yeah... I didn't look at it that closely and since he said he already installed the latest, I trusted what he said...

@sean2e

You might consider running the latest ProBook Installer v6.1b11 to refresh your system. There are a lot of advances in this version of the Installer including automatic DSDT/SSDT generation, and updated kexts. Maybe you haven't been keeping up on the developments, but v6.1b11 is pretty solid. Be sure to read the guide and changelog so you understand what's going on.

First I'm female... Felt the need to change my pic as if a male makes a n00b mistake it gets hostile but anyways I got it (new installer) and the first thing i noticed was it didn't have my old sys def, Im sure from memory it only tells the laptop its a 13"/15" ect... I haven't gone to 10.8.4 yet for obvious reasons.

Heres what I'm going to run and you guys tell me if it sounds right.

*10.8.3
*DSDTGen = 4X30s
*sys def = i3/i5 Sandy Bridge (i have a 2440m I believe )
*quiet fan
*9285 patch
*SSDT Gen
*Chi 2.0.1
*All optional HW/Spec fixes
*misc osx fix
*sleep image restore
*Every extra Tools
 
Joined
Apr 20, 2011
Messages
102
Motherboard
Hackintosh
CPU
I5 2300
Graphics
GTX 460 MSI 1GB
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. 512K
Mobile Phone
  1. Android
  2. iOS
Yeah... I didn't look at it that closely and since he said he already installed the latest, I trusted what he said...

@sean2e

You might consider running the latest ProBook Installer v6.1b11 to refresh your system. There are a lot of advances in this version of the Installer including automatic DSDT/SSDT generation, and updated kexts. Maybe you haven't been keeping up on the developments, but v6.1b11 is pretty solid. Be sure to read the guide and changelog so you understand what's going on.

Just went ahead with it and bam...it worked.

Thanks guys xo
 
Top