Contribute
Register

11.0.1 to 11.2.1 update

Joined
Apr 2, 2011
Messages
46
Motherboard
Gigabyte Aorus Ultra Z390
CPU
i7-8700K
Graphics
Gigabyte RX 5700 XT Gaming OC 8GB
When I am running the auto update check it is coming back saying that there are no updates available to my current 11.0.1. With no direct access to combo updates is there a work around to force the update without needing to download the 11.2.1 full install from the app store?
 
Joined
Apr 2, 2011
Messages
46
Motherboard
Gigabyte Aorus Ultra Z390
CPU
i7-8700K
Graphics
Gigabyte RX 5700 XT Gaming OC 8GB
I eventually got the update to show up by changing the config.plist setting for csr-active-config. The update runs and does the reboot where it then takes about 10 min to complete. Upon completion the OS is still at 11.0.1 and the update shows as available. In other words, it went through the entire update process but did not upgrade the OS. Any help appreciated.

Running OC 0.66 with all the latest kexts. Can post EFI if needed
 
Last edited:
Joined
Oct 10, 2015
Messages
792
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
You may need to select a correct partition manually on the boot menu.
 
Joined
Oct 10, 2015
Messages
792
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Which boot menu? I don't have any issues booting to 11.0.1. It's just the update to 11.2.1 that is failing
Clover or OpenCore menu
 
Joined
Jul 31, 2012
Messages
217
Motherboard
gaz77xud3h
CPU
i5
Graphics
gtx650
Mac
  1. iMac
Mobile Phone
  1. iOS
all those who are on OpenCore 6.5 and above, to update Big Sur, boot into recovery and select reinstall macOS Big Sur it will take about 30-40mins and 3 reboots . when it finally boots to desktop , u have updates installed and all your apps and preferences remain unchanged
 
Joined
Apr 2, 2011
Messages
46
Motherboard
Gigabyte Aorus Ultra Z390
CPU
i7-8700K
Graphics
Gigabyte RX 5700 XT Gaming OC 8GB
I eventually went the route of a full install from USB. Everything else I tried did not update from 11.0.1 to 11.2.1. It would look like it downloaded the update, do the install, reboot, continue the install and then show the GUI. Every time the system would report 11.0.1 and the 11.2.1 update available
 
Joined
Oct 26, 2013
Messages
1,049
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Every time the system would report 11.0.1 and the 11.2.1 update available
Common case for me, all my unsupported hacks (AMD/Celeron/Pentium) had this issue (randomly not every time) from 11.1 up, no matter what kind of boot loader are using.

The best way is create a simplest config.plist and use SMBIOS MacPro7,1 which does not need any Lilu + its plugins at all, only use FakeSMC (Rehabman version) + lan kext for update/upgrade, it always work for me after update/upgrade failed.

1, press shift + winkey + . to reveal hidden folder, /com.apple.installer must be deleted from /System/Volumes/Preboot/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, after update/upgrade is failed, otherwise no way to update/upgrade.

2, use mini config.plist for update/upgrade.
 
Joined
Apr 2, 2011
Messages
46
Motherboard
Gigabyte Aorus Ultra Z390
CPU
i7-8700K
Graphics
Gigabyte RX 5700 XT Gaming OC 8GB
Common case for me, all my unsupported hacks (AMD/Celeron/Pentium) had this issue (randomly not every time) from 11.1 up, no matter what kind of boot loader are using.

The best way is create a simplest config.plist and use SMBIOS MacPro7,1 which does not need any Lilu + its plugins at all, only use FakeSMC (Rehabman version) + lan kext for update/upgrade, it always work for me after update/upgrade failed.

1, press shift + winkey + . to reveal hidden folder, /com.apple.installer must be deleted from /System/Volumes/Preboot/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, after update/upgrade is failed, otherwise no way to update/upgrade.

2, use mini config.plist for update/upgrade.
Definitely will keep note of this for future use. The thing is that if you look at my specs this is a very commonly used MB from Gigabyte to hack. Lots of guides on how to make this work and almost vanilla. I have never had any issue updating prior with essentially the same config.plist file in place.
 
Joined
Oct 26, 2013
Messages
1,049
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
The thing is that if you look at my specs this is a very commonly used MB from Gigabyte to hack. Lots of guides on how to make this work and almost vanilla.

Issue just started from Big Sur 11.1, should no relevant to unsupported or vanilla system.

For troubleshooting, config / patches / kexts and ssdt files, less and simply are the best.
 
Top