Contribute
Register

10.13.6 USB3 X99-UD4

Joined
Aug 22, 2011
Messages
232
Motherboard
Gigabyte X99 UD4 -F.23c
CPU
i7-5820K OC @4.5 GHz
Graphics
GTX 960
Mobile Phone
iOS
I was wondering if anyone got all their USBs working correctly and who wants to share their config and or SSDT?

Thanks
Put this in your EFI/Clover/Kexts/Other folder and remove all kexts related to USB port limits , such as the USBInjectAll.kext and X99 injector kexts. Also, remove the clover port limit patch. This will enable all your USB 2 and 3 ports.

How's your power management with the 5820K? Are you getting good geekbench scores?
 

Attachments

Joined
Nov 1, 2018
Messages
204
Motherboard
Asus Rampage VI Extreme
CPU
i9-7980XE
Graphics
GTX 1080 TI
Mac
Mac Pro
Classic Mac
iMac
Mobile Phone
Android, iOS
Joined
Jul 23, 2015
Messages
94
Motherboard
x99-UD4
CPU
5820K
Graphics
280x
Mac
MacBook Pro
Put this in your EFI/Clover/Kexts/Other folder and remove all kexts related to USB port limits , such as the USBInjectAll.kext and X99 injector kexts. Also, remove the clover port limit patch. This will enable all your USB 2 and 3 ports.

How's your power management with the 5820K? Are you getting good geekbench scores?
Hey, thanks for getting back... Power management was perfect with 10.14 but when I updated to 10.14.1 it won't go to sleep on its own anymore. It goes to sleep when I do it manually and awakes too but not on its own

I am not overclocking or anything... What would be a good geekbenchscore you reckon?

Cheers
 
Joined
Aug 22, 2011
Messages
232
Motherboard
Gigabyte X99 UD4 -F.23c
CPU
i7-5820K OC @4.5 GHz
Graphics
GTX 960
Mobile Phone
iOS
Hey, thanks for getting back... Power management was perfect with 10.14 but when I updated to 10.14.1 it won't go to sleep on its own anymore. It goes to sleep when I do it manually and awakes too but not on its own

I am not overclocking or anything... What would be a good geekbenchscore you reckon?

Cheers
I haven't updated to 10.14.x yet, so I'm not sure about a good GB score for our hardware. Off the top of my head, I'd put it somewhere around 23-25000. To help you with power management, what you can do is download the EFI folder from this link - https://github.com/KGP/X99-EFI-Folder-Distributions/blob/master/EFI-X99-10.14.1-Release-iMacPro1,1-311018.zip - and treat it as a starting point. This is the same wizard I consulted with, to settle my problems with power management.

I also forgot to mention that, for the USB enabler kext to work, you have to be using the iMacPro1,1 system definition, or you will have to edit the config.plist inside it, to match your setup. The guide for it is here: https://www.tonymacx86.com/threads/xhc-usb-kext-creation-guideline.242999/

Let me know how it goes.
 
Joined
Jan 9, 2014
Messages
49
Motherboard
Gigabyte X99-UD4
CPU
i7-5820K
Graphics
RX 580
Put this in your EFI/Clover/Kexts/Other folder and remove all kexts related to USB port limits , such as the USBInjectAll.kext and X99 injector kexts. Also, remove the clover port limit patch. This will enable all your USB 2 and 3 ports.

How's your power management with the 5820K? Are you getting good geekbench scores?
Hello @jasperlevi, I've tried to download your file, but it looks empty? I would be glad to have a look at it. Thanks.
 
Joined
Aug 22, 2011
Messages
232
Motherboard
Gigabyte X99 UD4 -F.23c
CPU
i7-5820K OC @4.5 GHz
Graphics
GTX 960
Mobile Phone
iOS
Hello @jasperlevi, I've tried to download your file, but it looks empty? I would be glad to have a look at it. Thanks.
Hi @IsidoreIsou, I am attaching different versions of the kext to enable proper USB on your machine. You can use the one that matches your system definition. I am using iMac14,2 because I get best overclocking and Geekbench scores etc., also since I am still using the NVidia GTX 960. You can try the iMacPro1,1 SMBIOS. The files are very small, so they might show up as 0KB in size.

Same instructions as before: Put this in your EFI/Clover/Kexts/Other folder and remove all kexts related to USB port limits, such as the USBInjectAll.kext and X99 injector kexts. Also, remove the clover port limit patch. This will enable all your USB 2 and 3 ports.

Let me know how it goes...
 

Attachments

Joined
Jan 9, 2014
Messages
49
Motherboard
Gigabyte X99-UD4
CPU
i7-5820K
Graphics
RX 580
Hi @IsidoreIsou, I am attaching different versions of the kext to enable proper USB on your machine. You can use the one that matches your system definition. I am using iMac14,2 because I get best overclocking and Geekbench scores etc., also since I am still using the NVidia GTX 960. You can try the iMacPro1,1 SMBIOS. The files are very small, so they might show up as 0KB in size.

Same instructions as before: Put this in your EFI/Clover/Kexts/Other folder and remove all kexts related to USB port limits, such as the USBInjectAll.kext and X99 injector kexts. Also, remove the clover port limit patch. This will enable all your USB 2 and 3 ports.

Let me know how it goes...
WOH Thanks so much! I am trying to do my own SSDT but slowly learning.. I will try all that and get back to you!
For the moment I'm using MacPro SMBIOS.
Would you mind sharing your OC and score with iMac14,2?
And, do you have EHCI / XHCI hand off enable on your bios?

Thanks!
 
Last edited:
Joined
Aug 22, 2011
Messages
232
Motherboard
Gigabyte X99 UD4 -F.23c
CPU
i7-5820K OC @4.5 GHz
Graphics
GTX 960
Mobile Phone
iOS
WOH Thanks so much! I am trying to do my own SSDT but slowly learning.. I will try all that and get back to you!
For the moment I'm using MacPro SMBIOS.
Would you mind sharing your OC and score with iMac14,2?
And, do you have EHCI / XHCI hand off enable on your bios?

Thanks!
@IsidoreIsou, I'm glad to be of help! So, I'm currently overclocked to 4.5 GHz on all cores, with my Base Clock running at 125 MHz (so everything is 1.25x). Attaching my OC profile, which you can simply load in your BIOS, and get all my (BIOS) settings in one shot. EHCI and XHCI handoff are enabled in the settings.

I'm on firmware revision F24c for the GA X99 UD4, so I guess it'll help for you to also be on the same revision.

As for OC scores, I get around 26756 for multicore and 5057 single-core in geekbench 4, and around 1275 cb and ~100 fps in Cinebench 15. I think those are pretty good, and I don't get the same numbers with any other sysdef, which I think is primarily because I'm using an NVidia GTX 960, an old and unsupported video card for Macs.
 

Attachments

Joined
Jan 9, 2014
Messages
49
Motherboard
Gigabyte X99-UD4
CPU
i7-5820K
Graphics
RX 580
@IsidoreIsou, I'm glad to be of help! So, I'm currently overclocked to 4.5 GHz on all cores, with my Base Clock running at 125 MHz (so everything is 1.25x). Attaching my OC profile, which you can simply load in your BIOS, and get all my (BIOS) settings in one shot. EHCI and XHCI handoff are enabled in the settings.

I'm on firmware revision F24c for the GA X99 UD4, so I guess it'll help for you to also be on the same revision.

As for OC scores, I get around 26756 for multicore and 5057 single-core in geekbench 4, and around 1275 cb and ~100 fps in Cinebench 15. I think those are pretty good, and I don't get the same numbers with any other sysdef, which I think is primarily because I'm using an NVidia GTX 960, an old and unsupported video card for Macs.
That's impressive numbers. I'm looking forward to OC my machine more precisely, thanks for the profile! For the moment I'm @4Ghz auto in Bios, but if I apply XMP profile with this auto OC no post, no boot. So I have to do it manually I guess.

Lastly, can you confirm that EHCI and XHCI handoff enabled is not messing with sleep (or anything else) in your config?
 
Top