Recent content by themightyquinn

  1. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    It's worth a shot. They're basically the same machine besides display size, so I'd guess it'd go off without too many issues.
  2. themightyquinn

    [Guide] Disabling discrete graphics in dual-GPU laptops

    Picking up trying to disable my DGPU on Broadwell E550 again. All _OFF are located in DSDT, as well as the the _INI for the DGPU seems to be at \_SB.PCIO.PEG.VID._INI Device (VID) { Name (_ADR, 0x00) // _ADR: Address Method (ISOP, 0...
  3. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    Should still be solid depending upon what version of MacOS you're using. It's a Haswell guide, but if you look at the stuff I hijacked the thread with that should get you up and running fairly well on Broadwell. Never got my DGPU disabled or the WiFi fixed. So if someone figures that out I'm...
  4. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    I've redone UIAC based off a direct copy and paste with the correct connector IDs inserted. I'd previously attempted to install, but it didn't work at that time and I didn't have time to troubleshoot so I uninstalled and went back to the imperfect but some backlight control setup. I redid it...
  5. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    Well, after a good bit of messing around, I've got a pretty workable setup going with my Broadwell E550. A couple of things didn't quite work OOB, most (all?) related to the Broadwell vs Haswell. 1. Need the 10.12 Stolen Size Framebuffer patch. As far as I can tell there's no way of...
  6. themightyquinn

    Failing Macbook Pro - Late 2011

    The extension was only until 12/31/2016 or 4 years from date of purchase, so he's boned if he missed out. My mid-2010 MBP had a similar issue and thankfully got repaired under warranty (although power circuit problems got it once, and I soldered in a new resistor, and 6 or so months later...
  7. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    I chmod'd everything, no dice. Then I rm -r the Projects folder and redid it. Only time I entered password was when the script required sudo. Same problem. Then I just ran "mkdir build" to see if it make a difference and reran the make commands and everything processed fine. So I'm not sure...
  8. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    This was after it failed the first time, I wasn't just throwing them in randomly.
  9. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    I'm pretty I just did a straight copy and paste, but that does seem like a strong possibility, it felt like a permissions problem, so I threw a sudo on the make command, I'll check permissions. Ok, I'll give it a look and give that a shot if I can't get it sorted. Thanks!
  10. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    Yeah, I've got the Broadwell at least running, although not particularly well, but I know it's outside of the scope of this guide. I'll give it a shot. Any chance you have a list of the patches that need to be installed manually?
  11. themightyquinn

    [Guide] Lenovo ThinkPad E550 (Haswell) using Clover UEFI (10.11)

    Hi, First of all thanks for the guide. I've got a Broadwell E550 (i7-5500u), and did a copy paste of all the commands into terminal, works fine until I get to the make section and I get an error from maciasl: Error 6092 - Could not open file "build/SSDT-XOSI.pre" (Preprocessor Output) -...
  12. themightyquinn

    [solved] Inspiron 5548 - no boot with graphics patches

    Thanks. I figured it might just be camera problem. I was hoping since it shows up as an UVC camera that it would work, but it's also some fancy 3D Intel webcam so that complicates things I'm sure. Just got my bcm94352z and installed your wifi and bluetooth kexts for it and it's up and...
  13. themightyquinn

    [solved] Inspiron 5548 - no boot with graphics patches

    Thanks for the pointer. I think I've done what I can. It shows up in IOreg (was XHC@14>SSP4, but changed after XHCIMux) EHCx renamed to EH0x FakePCIID_XHCIMux installed USBInjectAll.kext installed Windows 8 OSI patch installed Still getting the same situation, green light on, but black...
  14. themightyquinn

    [solved] Inspiron 5548 - no boot with graphics patches

    Thanks! I'd previously run the HDMI Audio patcher script and thought that that should have gotten it. I had to match up layout-ids (HDAU/HDEF) and add 4 of the patches (the script only applied one). Yes. Intel(R) RealSense(TM) 3D Camera (Front F200): Product ID: 0x0a66 Vendor ID: 0x8086...
  15. themightyquinn

    [solved] Inspiron 5548 - no boot with graphics patches

    Indeed I did, thank you very much. Turns out I missed patching (or re-patching) some bits in SSDT-6. Have almost everything working now, my current issues HDMI Audio is patched and shows up in System Profiler but when plugged in doesn't show up as an output option. And my webcam doesn't...
Top