Contribute
Register

Working Kext for Killer E2200

Joined
Jul 29, 2012
Messages
5
Mac
Classic Mac
Mobile Phone
Is this only for wired or does wireless work as well? After installing this I can only see just regular ethernet but no wifi.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Sep 29, 2012
Messages
3
Motherboard
PC
CPU
3770K
Graphics
EVGA GTX780 ACX
Mac
Classic Mac
Mobile Phone
Well then I'll have a try with 10.9.1, since there's nothing installed on my hackintosh.
Thx. :)
I am on 10.9.1 now and everything works, thx for this great piece of work! :)
 
Joined
Mar 12, 2011
Messages
10
Motherboard
x58 LGA1366
CPU
i7 980X
Graphics
GTX 570 OC
Mac
Classic Mac
Mobile Phone
Android
Hey robodex

I have a GIGABYTE G1.Assassin motherboard in my hackintosh. The lan on that motherboard is Killer E2100. What I am wondering is if you know if your driver for E2200 will work for it even though your chip is newer. Are there any differences that would not allow the driver to work? and would it be possible to build a driver for E2100 like you did with yours?

Thanks,
Videl.
 
Joined
Oct 26, 2012
Messages
8
Motherboard
Asus Hero VIII Z170
CPU
intel i7-6700k SkyLake 4GHz
Graphics
Gigabyte Nvidia G1 Gaming 1070GTX 8Gb
Mac
iMac
Mobile Phone
iOS
The reason this cheap and dirty hack works is because the e2200 is just a regular atheros 8162 with a udp offload chip bolted to the side of it. If the e2205 is the same, say an 8182 (or something) with the udp offload asic next to it, then yes, I could make this same mod for the e2205, as long as the host chip is supported by the alx driver. Unfortunately, I don't have an e2205 to test against. If someone could get me the dev ids I would be happy to try.
I have an MSI Z87i AC Gaming with aforementioned Killer 2205 - What you want me to run/do etc to get all the possible info to see if it can be handled like the 2200's?


Update:

Well it seems the Killer on my MSI is actually a 2200. Both OSX and Windows agree.

I do get this in my log (and obviously no eth0)

Code:
06/03/2014 02:33:39.000 kernel[0]: Refusing new kext com.insanelymac.ALXEthernet, v1.0.2: a prelinked copy with a different executable UUID is already present.
The HW ID matches what is in the plist in the kext you provided.

I get 0xE0911969

Vendor: 1969
Sub Vendor: 1462
Device: E091
Sub Device: 7887

Unknown:


Name: ethernet
Type: Ethernet
Driver Installed: No
MSI: No
Bus: PCI
Slot: PCI Slot 1835010
Vendor ID: 0x1969
Device ID: 0xe091
Subsystem Vendor ID: 0x1462
Subsystem ID: 0x7887
Revision ID: 0x0013
Link Width: x1
Link Speed: 2.5 GT/s

is any of this helpful?


Further Update:

Got it up and running. Spent a while making absolutely sure there were no kext caches or dependencies lying around. Cleaned ALXEthernet from my system. cleaned up all my caches, perms etc and once rebooted manually added the debug version to s/l/e and inside the other network kext.

Now I have my Killer E2200 running sweet - going to hammer a few linux distro's via t*****t and see if its stable.

Thanks for your work in making this version

:thumbup:
 
Last edited by a moderator:
Joined
Oct 27, 2013
Messages
11
Motherboard
x99 Hackintosh
CPU
i7 5820k OC 4.5ghz
Graphics
Sapphire r9 290 Tri x oc 4gb
Mac
Mac Pro
Classic Mac
Mobile Phone
iOS
Hey i can't seem to get this to work in 10.9.2. do you have any idea what it maybe?
Thanks for all your hard work friend
 
Joined
Jun 2, 2011
Messages
232
Motherboard
ASUS UX305CA-FB055T Chipset: Intel Skylake-U
CPU
Intel Core m7 6Y75
Graphics
Intel HD Graphics 515 : 3200x1800
mine doesnt work. I have a msi g45 z77a gaming. Im using a wireless usb
 
Joined
Oct 27, 2013
Messages
11
Motherboard
x99 Hackintosh
CPU
i7 5820k OC 4.5ghz
Graphics
Sapphire r9 290 Tri x oc 4gb
Mac
Mac Pro
Classic Mac
Mobile Phone
iOS
I am doing the same with a usb wifi card. i couldn't get it to work on my G45 z77a or my z87 g65. But thanks for writing the kext my friend.
 
Joined
Apr 1, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
Gamester,

Thank you so much for this. YOU ARE AWESOME! I spent the last several days trying to get it to work, then I found this thread and bam! Got it working in 10.9.2. Again thank you so much. Much appreciated.
 
Joined
Jun 22, 2011
Messages
32
Motherboard
ASRock X99 Extreme4
CPU
Xeon E5 2630-V3 @2.5GHz
Graphics
2 x Gigabyte R9 280X OC
Mac
MacBook, MacBook Pro, Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
Hey robodex

I have a GIGABYTE G1.Assassin motherboard in my hackintosh. The lan on that motherboard is Killer E2100. What I am wondering is if you know if your driver for E2200 will work for it even though your chip is newer. Are there any differences that would not allow the driver to work? and would it be possible to build a driver for E2100 like you did with yours?

Thanks,
Videl.

Hey Videl,
I have G1.Assassin F3 mobo too, it immediate appear as "Ethernet" in the [System Preferences \ Network] after install using KextBeast. (I already have RealtekRTL81xx.kext installed, not so sure it help or not, At first the [Ethernet Cards] section in the [System Report] show only n/a, but once installed it showing "AppleRTL8169Ethernet.kext" and not "ALXEthernet.kext"), anyway...it just work !

** UPDATE: I just try remove RealtekRTL81xx.kext, the Ethernet still work fine and showing as AppleRTL8169Ethernet.kext.


Many thanks Gamester !!!
 
Top