Trixxiee's build: Gene VIII + i7-6700K + GTX1070 + Samsung 960 Evo NVMe

Not open for further replies.
Apr 19, 2017
Asus Maximus VIII Gene
GTX 1070
  1. MacBook Air
Mobile Phone
  1. iOS
Trixxiee's Phanteks mATX build:
Asus Maximus Gene VIII + i7-6700K + GTX1070 + Samsung 960 EVO NVMe





Benq BL2101PT 32" 4K Monitor


Intel i7-6700K Skylake Processor

Noctua NH-D15S Processor cooler

EVGA GeForce GTX 1070 FTW ACX 3.0 Graphics Card

G.Skill Trident Z DDR4-3200 DIMM CL14 Dual Memory Kit

Samsung 960 EVO M.2 2280 NVMe PCIe 3.0 SSD

2x Samsung 850 EVO SATA III 2.5" SSD

2x Seagate BarraCuda 2TB ST2000DM006 64MB HDD

Seasonic X850 Modular 80+ Gold Power Supply

ABWB 802.11AC WI-FI/Bluetooth 4.0 PCI-PCI-E BCM943602CS Combo Card [New Version]

Gelid GC-Extreeme Thermal Compound

Apple Magic Keyboard

Phanteks Enthoo Evolv mATX Tempered Glass Case

Already Owned

Apple Magic Mouse


BIOS Setup

The Gene VIII arrived with old version of BIOS. Having read Stork’s and pastrychef’s threads I decided to do a flashback with an USB stick and upgrade the BIOS to version 2202. It turned out to be a disaster – delivered manual contains a mistake in regard to the flashback port. When I followed the manual and used the recommended flashback port the blue light started flashing and froze after approximately 5 seconds. Afterwards I got Q-code “00” meaning my BIOS did not ever POST. I tried CMOS clear, which turned everything off, tried removing battery for an hour… nothing worked. Then I tried the flashback using different ports, which seemed to do something, but ended in the same exact situation after it finishes. 00. In the end I decided to buy 2 new BIOS chips for Gene VIII and do the flashback once again but with the port that seemed to do something, meaning blue light started flashing, then flashing faster and disappearing. The new chip arrived and after the installation I found that it has BIOS 3401 installed. I risked and tried doing flashback using the port that I marked in green. It worked! So even downgrade was possible.

Screen Shot 2017-05-20 at 21.20.06.png

After successful update or to be more precise - a downgrade, I used BIOS settings taken over from Stork’s golden build:

Extreme Tweeker
AI Overclocker Tuner > X.M.P.
Extreme Tweeking > Enable
Advanced Items
System Agent (SA) Configuration > VT-d > Disable
PCH Configuration > IOAPIC 24-119 > Disabled
USB Configuration > Legacy USB Support > Auto
USB Configuration > XHCI Hand Off > Enabled
APM Configuration > Power on by PCI - E/PCI > Disabled
Boot Menu
Fast Boot > Disabled
Boot Logo Display > Disabled
Secure Boot > OS Type > Other OS
Boot Option 1 > UEFI installer USB thumb drive
Exit > Save Changes

Making the UniBeast USB Thumb Drive with Sierra 10.12.5

Use the tonymacx86 guide UniBeast: Install OS X Sierra on Any Supported Intel-based PC. Since I wanted to use Samsung 960 NVMe I had to modify config.plist:
  • Insert the UniBeast USB installer thumb drive to a working USB 2 Back Panel Port;
  • Open the Terminal and run the following:
    diskutil list
  • Note the UniBeast USB drive's EFI partition's "diskXs1" designation - could be something like "disk0s1";
  • Use EFI Mounter Version 3 to mount the UniBeast USB drive's EFI partition;
  • Navigate to EFI > EFI > CLOVER folder;
  • Open another tab in your Finder window and navigate to Download/patch-nvme-master/ folder
  • Copy only the KextsToPatch patches in the NVMe_patches_10_12_5.plist, starting with:
                <string>IONVMeFamily IONameMatch</string>


                <string>IONVMeFamily Pike R. Alpha Patch#17</string>

into the USB Installer Thumb Drive's config.plist, appending it to end of this file's KextsToPatch patches:

                <string>change 15 port limit to 26 in XHCI kext (100-Series-10.12)</string>
                <string>IONVMeFamily IONameMatch</string>

Installation Notes
  • I installed the Sierra on a fresh system following the guide:
  • Insert the UniBeast USB Thumb Drive in the USB port in the bottom USB port at the bottom of the stack with the PS/2 port at the top (see Rear Port graphic above);
  • Boot into the Sierra Installer with the UniBeast Installer USB thumb drive to begin the installation.
  • Skip logging to the iCloud at this step.
  • Drag&drop MultiBeast from the thumb drive to your Applications folder, unzip them, run MultiBeast and selection the following:
Screen Shot 2017-05-20 at 23.41.55.png

  • Click on the Install button in the MultiBeast window bottom right hand corner and wait for MultiBeast to finish.
  • Important. MultiBeast v9.1.0's FakeSMC Plugins' FakeSMC_GPUSensors.kext has not been updated to support Pascal graphics cards. To prevent Kernel Panics and Reboot
    • Open the installation drive's /Library/Extensions/ folder;
    • Find and trash the FakeSMC_GPUSensors.kext;
    • Delete the Trash.
  • If you have a current Nvidia graphics card, install the newest driver: 378.05.05.15f01 but not reboot the system when the installator asks.
  • Drag & drop the Rehabman's Codec file from the thumb drive onto your Desktop and un-zip the file. Drag the CodecCommand.kext from the Release folder to the Desktop. Drag the zip & the two folders to the Trash.
  • Drag & drop the KextBeast on your Desktop, unzip it and run it; choose to put the kexts in the /Library/Extensions/ folder (/L/E/).
  • Now install your processor's SSDT.aml:
    • Download the SSDT for your processor from ammulder's Guide and rename it SSDT.aml; I chose the SSDT for my i7-6700K. Note: ammulder's SSDTs are for non overclocking speeds; for overclocking, you'll need to create a SSDT for your processor using PikeRalpha's script located here.
    • Use EFI Mounter Version 3 to mount the UniBeast USB drive's EFI partition;
    • Navigate to EFI > EFI > CLOVER > ACPI > patched folder
    • Drag&drop the SSDT.aml from the thumb drive ino the ...ACPI > patched folder.
  • Create your spoofing SSDT using Rehabman's [Guide] HackrNVMeFamily co-existence with IONVMeFamily using class-code spoof:
    • Determine the ACPI path of your NVMe device. (Before Sierra installation I installed Windows 10 on one of my Samsung 850 Evo SSD drive.)
    • Create SSDT-NVMe-Pcc.aml: You should use RehabMan's version of MaciASL. Make sure you have MaciASL->Preferences->iASL set to ACPI 6.1.
    • After running MaciASL, close the default window (which has your DSDT), then choose File->New to create an empty document. Paste the code:
      // Inject bogus class-code for NVMe SSD to prevent IONVMeFamily.kext from loading
      DefinitionBlock("", "SSDT", 2, "hack", "NVMe-Pcc", 0)
          External(_SB.PCI0.RP13.PXSX, DeviceObj)
          Method(_SB.PCI0.RP13.PXSX._DSM, 4)
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
      and edit as appropriate for your ACPI path, then use File->Save As, "SSDT-NVMe-Pcc.aml", format: ACPI Machine Language Binary. Save to a location you can find, such as your desktop.
    • Now you can copy the SSDT-NVMe-Pcc.aml file such that Clover can load it. If you're preparing your USB, you'll place it on the EFI for USB, otherwise it will be on the EFI for your boot drive. In any case, it goes to EFI/Clover/ACPI/patched/SSDT-NVMe-Pcc.aml.
  • Create RehabMan's HackrNVMeFamily*.kext with the spoofed class-code
    • Open terminal and run following:
      mkdir ~/Projects
      cd Projects
      git clone patch-nvme.git
      cd patch-nvme.git

      cd ~/Projects/patch-nvme.git
      ./ --spoof

      cd ~/Projects/patch-nvme.git
      sudo cp -R HackrNVMeFamily-10_12_5.kext /Library/Extensions

      You can rebuild cache to verify cache can be built without error:
      sudo kextcache -i /
  • Now click on the Restart button in the Nvidia Web Driver window or reboot the computer if you didn't install the Nvidia drivers.Reboot into the BIOS. Change BOOT > Boot Options Priorities > Select your installation disk to either the: UEFI (Samsung 960 Evo...) NVMe M.2 drive or UEFI setting for the Sierra drive. EXIT to save the BIOS update and reboot.
  • To fix the audio, run MultiBeast once more, selecting the following:
    Drivers > Audio > Realtek ALC1150
    Drivers > Audio > 100/200 Series Audio
    Build > Install
    Reboot after installation is complete

  • Sierra broke wake-up from long (4+hours) sleep. @pastrychief discovered a "fix"; see his Build Description and Post #63 in his Build Description thread for more details. So, in the Terminal, execute the following command:
    sudo pmset -a autopoweroff 0

What works
  • Booting from NVMe drive
Screen Shot 2017-05-19 at 23.50.43.png

  • iMessage
  • Handoff, continuity
  • Audio through green port
  • Sleep and wake up (after wakeup Q-code on your Gene VIII will change from A0 -> 40, what's supposed to be normal)
  • WLAN and Bluetooth, though I observed that at the beginning aluminium Phanteks case interfered with Bluetooth signal and my Magic Mouse, Magic Keyboard and Bose SoundTouch were loosing connection. Playing around with antennas fixed the problem :)
What doesn't work
  • [*]iMessage, although no idea why. I can log in and see my contacts but I can theoretically send only text messages not iMessages. I tried to log out from the iCloud and log in again but it didn't fix the problem.


Special thanks go to @Stork @pastrychef and @RehabMan as I mostly followed their builds/configurations, thus some parts of this thread were just copied.

22.05.2017. iMessage Fixed; see Post #8
Last edited:
LOL! I thought parts of the installation were a familiar read.

Welcome to the GENE Club! :thumbup:
Re: The BIOS version. I share your pain. I'm glad I learned my lesson on MyHero with updating the BIOS before understanding the ramifications. So, I kept the BIOS at 2202 for Gene.

The good news is that MultiBeast v9.1.0 now has a Bootloader configuration that installs the EmuVariableUefi-64.efi and RC Scripts so as to preserve NVRAM between boots.
Exactly, that's why I bought one spare BIOS chip... just in case :lol: I will also play with settings on this hack so the current setup is:
1. 960 Evo: Sierra
2. 850 Evo: CCC bootable copy of 960
3. 950 Evo: Windows for some particular software - I'm a geneticist and unfortunately some molecular modelling softwares run only under Win7
4. 2xTB hard drive in Raid 1 for all the data
Has anyone notified Asus about the mixup of the Bios flashback ports in the diagram ? Don't know how they could make a mistake like that and not at least add a note card in the motherboard manual that corrects it.
Update #1, 22.05.2017 iMessage Fixed
  • Make sure that your primary network is set as en0. A lot of the time, this is a major issue and is often overlooked. If you use WiFi as your primary network, it has to be en0. Open System Profiler, click Ethernet or Wifi, depending on how you receive your internet, and make sure the network is listed as en0. If not, delete NetworkInterfaces.plist and Preferences.plist in /Library/Preferences/SystemConfiguration. In many cases, this is unnecessary.
  • Download Clover Configurator and run the program.
  • Mount the EFI partition and open the config.plist
  • Go to the SMBIOS tab and click the magic wand icon.
  • Select you Mac definition. In my case it was iMac 14,2.
  • Click both 'shake' button few times.
  • Go to
  • If the error shown above appears, than you are good to go! If not, make another serial by repeating the above step.
  • Add 5 hexadecimal digits and letters to the end of the Board Serial Number. The five characters must be HEX, such as ABCDEF1234567890.
  • Open Terminal and type uuidgen, then press enter. Copy the value that was outputted and past the value into the SmUUID section.
  • Save the config.plist
  • If you ever attempted to log into iMessage previously, do the following steps in terminal before rebooting:
     cd ~/Library/Caches/
    rm -R*
    rm -R*
    cd ~/Library/Preferences/
    rm -R ~/Library/Messages/
Credits: P1LGRIM;
Last edited:
Nice Trixxie, may you do all this things in a video? Should be excellent for dummies like me!
I have the same hardware config than you.
Nice Trixxie, may you do all this things in a video? Should be excellent for dummies like me!
I have the same hardware config than you.

Hi! I could do it but now my beauty is in a box and taken by a relocatinon company as I am changing the country :) It will be back in 2 months :)
Not open for further replies.