Contribute
Register

TP-LINK Archer T8E 175 (AC1750) showing no networks on El Capitan

Joined
Oct 13, 2011
Messages
13
Motherboard
GIGABYTE GA-Z170X-Designare
CPU
INTEL Core i7-6700K 4.00GHz 1151 BOX
Graphics
NVIDIA GeForce GTX 750 Ti 2047 MB
Mac
MacBook Pro
Mobile Phone
iOS
I have installed TP-LINK Archer T8E 175 (AC1750) with Broadcom BCM4360 chip which should work without installing any kexts on OS X El Capitan.

The card is recognized as "Third-Party Wireless Card" in system profiler.

Software Versions:
CoreWLAN: 11.0 (1101.20)
CoreWLANKit: 11.0 (1101.20)
Menu Extra: 11.0 (1110.33)
System Information: 11.0 (1100.1)
IO80211 Family: 11.1 (1110.26)
Diagnostics: 5.1 (510.88)
AirPort Utility: 6.3.6 (636.5)
Interfaces:
en1:
Card Type: Third-Party Wireless Card
MAC Address: c4:e9:84:78:62:ff
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported
Status: Off


It seams as card is working (there is WiFi icon in system menu) and I can turn WiFi on and off. But No networks are shown. I have couple of networks available and other devices connect to them without any problems.

Does anyone have this card working on El Capitan?
 
Joined
Dec 23, 2012
Messages
54
Motherboard
0
CPU
0
Graphics
0
Mac
Classic Mac
Mobile Phone
Hi, I am interested in purchasing this card for my build. Did you ever get yours working properly?
 
Joined
Oct 13, 2011
Messages
13
Motherboard
GIGABYTE GA-Z170X-Designare
CPU
INTEL Core i7-6700K 4.00GHz 1151 BOX
Graphics
NVIDIA GeForce GTX 750 Ti 2047 MB
Mac
MacBook Pro
Mobile Phone
iOS
I think that card should work without any configuration.
After many attempts to make it work i have installed Windows 7 on another drive and tried the card. I experienced the same issues, available networks would be listed for a few seconds every 5 to 10 minutes and in that period I would click to join a network but never with success. Same things was happening on OS X.
So I called the support and we established that my card was defective. I have shipped my card back to the seller. I am waiting for a new one.
 
Top