Contribute
Register

[Success] Radeon RX 6800 XT - Big Sur

Joined
May 29, 2012
Messages
623
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
My m1 max MBP already runs circles around my hack, even my 6900XT in some cases when the gpu operations are choked down by lagging intel and bus performance (where the SoC design shines since it doesnt have to wait on memory or cpu for literally anything)

But I bet you can't play Doom Eternal on it!

The best thing about my Hack is having the optionality. At this point, I'm willing to trade off dwindling benchmarks for the ability to swap out components, add storage and dual boot. I know eventually I will be going to AppleSi, but I'm hoping that's not for another 5 years. At that point, I will probably have the Mac for real work and my rig for play.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,807
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
But I bet you can't play Doom Eternal on it!

The best thing about my Hack is having the optionality. At this point, I'm willing to trade off dwindling benchmarks for the ability to swap out components, add storage and dual boot. I know eventually I will be going to AppleSi, but I'm hoping that's not for another 5 years. At that point, I will probably have the Mac for real work and my rig for play.

I bet it will work for those who have Xbox Cloud.

 
Joined
Apr 4, 2014
Messages
89
Motherboard
GA-Z390-DESIGNARE
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks all contributors!

By using page 105
It really worked to flash the BIOS of a Nov 2021 edition of XFX RX 6900 XT MERC 319 Limited Black, per instruction.

After rebooting with agdpikera in boot arguments and recent WhateverGreen kext in OpenCore 0.75 the Monterey 12.0.1 is working with hardware acceleration.
The geekbench 5 score for openCl is around 30% lower than in windows, but i dont game in MACOS so thats OK.
The max Hz in 4k is only 108 Hz, versus 144 Hz in windows. (more annoying for me i really wanted the full 144HZ in MacOS....
But a great improvement compared to before the BIOS flash when i could not get acceleration to work at all.

Which VBIOS did you use?
 
Joined
Jul 20, 2014
Messages
882
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Is RX 6600 (non XT) is compatible with Monterey 12.1 ?
Or do I need to spoof it with "Device-id" 0x73E3 ? How?
I Kinda boot Monterey, but the screen turns black at the end of the booting sequence
OC 074
Whatevergreen enable and agpdmode=pikera boot arg

Any advice ?
Thanks
 
Last edited:
Joined
May 29, 2012
Messages
623
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Which VBIOS did you use?

Hi @Ponkass

Just following your recent posts, it looks like you have the Ultimate 6900XT XTXH card. You don’t need to flash the VBIOS anymore to get this card running.

A spoof method has been developed. You need to update to the latest versions of OC and WEG, then place an SSDT in your ACPI folder, then make an entry in you Device Properties.

It may take a bit of customization.

Can you post an IOReg output after doing a search for “GFX0”

Depending on the output I can let you know if you need to tweak the entries.
 
Joined
Apr 4, 2014
Messages
89
Motherboard
GA-Z390-DESIGNARE
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi @Ponkass

Just following your recent posts, it looks like you have the Ultimate 6900XT XTXH card. You don’t need to flash the VBIOS anymore to get this card running.

A spoof method has been developed. You need to update to the latest versions of OC and WEG, then place an SSDT in your ACPI folder, then make an entry in you Device Properties.

It may take a bit of customization.

Can you post an IOReg output after doing a search for “GFX0”

Depending on the output I can let you know if you need to tweak the entries.

Thanks for your reply. I already found the SSDT and it's working now :thumbup:
 
Joined
Mar 18, 2017
Messages
1,042
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Is RX 6600 (non XT) is compatible with Monterey 12.1 ?
Or do I need to spoof it with "Device-id" 0x73E3 ? How?
I Kinda boot Monterey, but the screen turns black at the end of the booting sequence
OC 074
Whatevergreen enable and agpdmode=pikera boot arg

Any advice ?
Thanks

Support will be added on Monterey 12.1 :

AMDRadeonX6000.kext

AMD Navi 23 GPU

Device id ( same for RX 6000 and RX 6600 XT) 0x73FF1002

Seems to be natively supported :


Capture d’écran 2021-12-04 à 17.37.24.png
 
Joined
Jul 20, 2014
Messages
882
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Support will be added on Monterey 12.1 :

AMDRadeonX6000.kext

AMD Navi 23 GPU

Device id ( same for RX 6000 and RX 6600 XT) 0x73FF1002

Seems to be natively supported :


View attachment 536251
Thanks
I'm booting Monterey 12.1b but ends with black Screen
I tried
WEG & agpdmode=pikera ➧ Black Screen
agpdmode=pikera ➧ Black Screen
WEG ➧ Black Screen
none ➧ Black Screen
 
Joined
Mar 18, 2017
Messages
1,042
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Thanks
I'm booting Monterey 12.1b but ends with black Screen
I tried
WEG & agpdmode=pikera ➧ Black Screen
agpdmode=pikera ➧ Black Screen
WEG ➧ Black Screen
none ➧ Black Screen
And if you disable Whatevergreen.kext ?
 
Joined
Jul 20, 2014
Messages
882
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
And if you disable Whatevergreen.kext ?
Same ➧ black Screen
I'll try again and report

I want to point out that I boot a Vanilla Monterey Drive not Usb installer
 
Top