Contribute
Register

[SUCCESS] jbarnette's Build - ASUS TUF Z390 M Gaming + i9-9900K + Sapphire RX Vega 64 8GB + 32GB RAM + MacOS 10.14.3 w/ USB3 working!

Status
Not open for further replies.
Joined
Jan 6, 2018
Messages
82
Motherboard
ASUS ROG Strix Z370-G WIFI
CPU
i7-8700
Graphics
Vega 56
Thanks for your info - can you tell me what case you used- it is slick looking.
 
Joined
Aug 21, 2012
Messages
6
Motherboard
Gigabyte Z390M gaming
CPU
I9-9900K
Graphics
RX 570
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Hi guys, I have a 9900K and this MB - Gigabyte Z390 M gaming + Radeon 570. I can't get it to overcome the second part of installation - I downloaded the EFI folder from here and set up BIOS as instructed. But when the screen finally boots and shows the installation - 13m remaining, it reboots and it never gets out of this loop. Any clues? Many thanks...
 
Joined
Feb 28, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@mhoudek I'm still learning myself but here are a few tips I did learn along the way.
  1. Fill out the specs of your hardware. The senior members on here are going to point that out right away and some are cool about and others may just ignore your post altogether.
  2. I know this is silly but if you haven't done so make sure all your hardware is fully seated properly. I had a problem with my card and it was because it wasn't seated properly.
  3. Take screenshots of what's going on and also provide a copy of your EFI folder and config.plist. I had a problem with a kext that I thought was WhateverGreen.kext and it turned to be WhateverGreen.kext.textClipping.

I know I probably didn't answer anything, but at least you have the tools now to set yourself up so someone else with more knowledge doesn't have to ask you the basic questions. You'll be prepared to provide them what they need to help you. I hope that helps.
 
Joined
Aug 21, 2012
Messages
6
Motherboard
Gigabyte Z390M gaming
CPU
I9-9900K
Graphics
RX 570
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Thanks. All my HW is fully seated and was running MS Windows without an issue.
I named the HW here - same MB, same CPU, just different GPU. I downloaded the EFI folder from here and before that I of course tried standard Unibeast method which didn't work - couldn't allocate resources (iGPU problem). Thx
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,939
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks. All my HW is fully seated and was running MS Windows without an issue.
I named the HW here - same MB, same CPU, just different GPU. I downloaded the EFI folder from here and before that I of course tried standard Unibeast method which didn't work - couldn't allocate resources (iGPU problem). Thx
You need to have your hardware profile filled out as per rules (the ones you agreed to when signing up here)
 
Joined
Feb 28, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@SFSquire here is the link to the mod that the OP made to his case, and the case name. BTW it's on the OP's 1st thread towards the bottom.

 
Joined
Jan 6, 2018
Messages
82
Motherboard
ASUS ROG Strix Z370-G WIFI
CPU
i7-8700
Graphics
Vega 56
The result is gorgeous but heck - that is a "whole-lot" of work. Thanks for the info and kudos on a beautiful case.

@SFSquire here is the link to the mod that the OP made to his case, and the case name. BTW it's on the OP's 1st thread towards the bottom.

 
Joined
Mar 28, 2019
Messages
1
Motherboard
Gigabyte Z390 UD
CPU
i9 9900K
Graphics
Vega 64
Hello! I have a very similar build. Motherboard is Gigabyte Z390 UD but rest is basically the same. i9 9900K, Gigabyte RX VEGA 64, 32GB G.Skill RAM, Corsair SATA SSD 500GB and Samsung 970 M.2 SSD. I still have some serious issue with random freeze. After booting to the Desktop, it sometimes works for half an hour and sometimes just freezes in couple of minutes. I have tried different .efi memory fixes one at a time but with no luck so far. Does anyone have an idea what could it be? I probably should link some config or debug files to the post, but I'm not really sure what files would point to the issue.
 
Joined
Feb 28, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@chalixon, I'm just as new to this as you however, I will try to do my best to help and or point you in the right direction with the little I do know.

I have a question about your Samsung 970. Can you tell me what is the exact model of that drive, and is that where you have the OS on?
 
Joined
Feb 28, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@joanareis here is my Thunderbolt install.

Installing GC-Titan Ridge

I installed the Titan Ridge in the last slot (PCIEX4). I removed my NVMe SSD, and installed Windows on a spare SSD that I had. The rest are the steps I used to get it running;
  • Booted into Windows, (let it do it's updates)
  • Grab the Gigabyte GC - Titan Ridge drivers and install them
  • Check Device Driver to make sure it's installed. (I can't remember where exactly, but it's nestled in there and it doesn't stand out)
  • Then run the GC - Titan Ridge application, to test if it is working (I used this USB-C hub)
  • Reboot and see if you have a Thunderbolt option now in the BIOS (It's under Peripherals)
  • Reboot into Mojave and install the following two files into EFI->CLOVER->ACPI->PATCHED reboot (Please see below)
  • Check About This Mac and System Report, then go to PCI (Should look like Image below) Screen Shot 2019-04-26 at 12.47.41.png
  • Open IORegistryExplorer and it should look like the image below
402059


None of this could have been possible without @CaseySJ. His initial AML I used was the RP21, he redid it for me as it was found in RP05 as you can see above. So, thank you so much Casey, for all the work you do. I hope this helps anyone with our mobo, that wants to use the GC-Titan Ridge.

-Semper Fi
 

Attachments

  • Proof of Thunderbolt in RP06@1C.png
    Proof of Thunderbolt in RP06@1C.png
    84.3 KB · Views: 93
  • SSDT-DTPG.aml
    100 bytes · Views: 91
  • SSDT-Z390-RP05-SLOT4-TB3HP.aml
    6.2 KB · Views: 100
Status
Not open for further replies.
Top