Contribute
Register

[Success] i5 4460 - GA-Z97M-D3H - HD4600 - 8gb RAM - RX570

Joined
Oct 8, 2014
Messages
11
Motherboard
GA-Z97M-D3H
CPU
i5-4460
Graphics
RX570 / HD 4600
Mac
iMac, MacBook, MacBook Pro
Mobile Phone
iOS
Nyrem First Hack: Core i5-4460 - GA-Z97M-D3H - HD 4600 - RX570 - mATX

CA-141-BX_75899_350.jpg
Components

Bitfenix Prodigy M

Intel Core i5 4460 3.2ghz -
Amazon US

Gigabyte GA-Z97M-D3H - Amazon US

Sapphire Nitro+ RX570

Crucial Ballistix Sport XT 8GB (2x4GB) DDR3 1600 C9 RAM - Amazon US

Kingston SSDNow V300 120GB SSD SATA3 - Amazon US

Seagate 1TB HDD SATA3

CoolerMaster Hyper TX3 Evo Cpu Cooler

CoolerMaster G550M PSU

TP-Link PCI Express Adapter(TL-WDN4800)

DeLock PCI FireWire 400 1394a 3+1 (product: 89179)


Running MAC OS 10.9.5
https://itunes.apple.com/ca/app/os-x-mavericks/id675248567?mt=12


2020 - High Sierra / Manjaro 19 / Windows 10


Already Owned

Philips Brilliance 248C LED Display HDMI/VGA

Saitek Eclipse II usb Keyboard

Razer Naga USB Mouse

PreSonus FireStation (mLAN Firewire audio interface)



Comments

In 2006 I got my first Macbook. It's working until today, although sitting on my desk with a couple of fans blowing air around it while trying to play a video probably doesn't really count as working. It's survived 2 cups of coffee and a lot of road use so I guess I can't blame it for quitting. As a musician I really needed a new Mac for home recording, but as a musician I'm also on a tight budget. Enter Hackintosh.

Picked these parts with the help of the Buyer's Guide and a little luck. I will probably upgrade and add parts later on this year, but for now, it's a success

Summary

Spent some time tinkering the first day I got the parts built but I guess I was too tired because there was no way I could get it to work. HD4600 would just not cooperate. In retrospect I probably just skipped some step and was too eager to get it working fast.

Just redid the BIOS and reinstalled Mavericks 10.9.5, followed the tonymacx86 installation guide and looked at daemontus and mga1981 build descriptions. :thumbup: (H97M-D3H i7) and with the updated MultiBeast it worked on the first go. You can follow their settings; except you skip some parts because of the 6.5 MultiBeast.

MultiBeast 6.5

Quick Start > DSDT Free

Driver > Audio > Realtek 892

Driver > Audio > 9 series support

Driver > Disk > 3rd party SATA

Driver > Disk > Trim patch

Driver > Graphics > 9 series support

Driver > Misc > FakeSMC + Plugins + HW Monitor

The main difference from the first couple of tries was I did take out all but 4gb RAM, the HDD and the PCI and PCIe cards on the successful installation! I know its mentioned in the guide...... :banghead:

Mac OS 10.9.5 runs smooth, Intel HD4600, app store, iCloud, audio (from mini jacks) all work. No iMessage yet! Using HDMI out for display.

Updates:



    • Got a chance to test the FireWire PCI - works out of the box!
    • Also know that PreSonus Firestation mLAN drivers do not work with Mavericks now. Going to have to look for another interface :/
    • Feb 2015 update: iMessage started working, without me changing anything. Apple must have changed something on their servers.


Thanks so much for all the information on these forums and the site! I'll keep you updated on the rest of this work-in-progress but for now Im a very happy guy!

Nyrem
 
Last edited:
Joined
Oct 8, 2014
Messages
11
Motherboard
GA-Z97M-D3H
CPU
i5-4460
Graphics
RX570 / HD 4600
Mac
iMac, MacBook, MacBook Pro
Mobile Phone
iOS
Planning to update to Yosemite this weekend, maybe El Capitan even. Depends if I feel like switching to Clover too ;) I'll post an update when it's done.
 
Joined
Oct 8, 2014
Messages
11
Motherboard
GA-Z97M-D3H
CPU
i5-4460
Graphics
RX570 / HD 4600
Mac
iMac, MacBook, MacBook Pro
Mobile Phone
iOS
Long time since I've updated! Now successfully upgraded to Sierra and Clover 4428.
Didn't dare to break the original Mavericks install so installed Sierra on a fresh SSD. Only took 2 tries and did not fiddle with Clover Configurator yet (i.e.: New Serial number....). After installing Sierra I restored from Time Machine and all files are back in place.

edit 1: The reason it took 2 times was first time; fiddling with Clover Config to get my old serial and hardware ID back.. That broke the install so I started over and figured I'd just keep this as a 'new' mac. Makes sense after the years...

Happy to report; I didn't use any additional kexts and the FW card works.

Edit 2: Still running the same hardware but using a Focusrite external Audio Interface. Works out of box.

Problem 1: iMessage will receive, but will not send. Will update when I manage to fix it with the fix that works for me.
 
Last edited:
Joined
Oct 8, 2014
Messages
11
Motherboard
GA-Z97M-D3H
CPU
i5-4460
Graphics
RX570 / HD 4600
Mac
iMac, MacBook, MacBook Pro
Mobile Phone
iOS
Following the direct update instructions I'm now on High Sierra, first attempt I got stuck on the initial reboot ( black screen/ mouse pointer; it wouldn't shut down/reboot ) but second attempt worked flawlessly. APFS included. No additional kexts loaded, apart from the ones in the first post.
Everything still works, haven't bothered doing any 'audio fix' for the ALC 8xx because I only use the external interface from focusrite.

Thanks again for the great resources and information @tonymacx86 @Stork and everyone else who chipped in!
 
Joined
May 5, 2010
Messages
83
Motherboard
GA-Z390M Gaming
CPU
i5-9600K
Graphics
RX 570
Mac
iMac
Mobile Phone
iOS
Are you going to try Mojave in the next few weeks? I was always going to "upgrade soon" to High Sierra. Well kinda missed that... Hoping I can get one more OS update out of this MoBo.
 
Joined
Oct 8, 2014
Messages
11
Motherboard
GA-Z97M-D3H
CPU
i5-4460
Graphics
RX570 / HD 4600
Mac
iMac, MacBook, MacBook Pro
Mobile Phone
iOS
Are you going to try Mojave in the next few weeks? I was always going to "upgrade soon" to High Sierra. Well kinda missed that... Hoping I can get one more OS update out of this MoBo.
Downloaded and thinking about it (just want to make sure I have enough time on my hands). I'll definitely post an update when I do. Also looking into some gfx card options for games/photos/movies as I'm getting into those a bit more.
 
Joined
Oct 8, 2014
Messages
11
Motherboard
GA-Z97M-D3H
CPU
i5-4460
Graphics
RX570 / HD 4600
Mac
iMac, MacBook, MacBook Pro
Mobile Phone
iOS
6 years old and still going strong! Now triple booting High Sierra, Manjaro and Windows 10.
Latest update was adding a Sapphire nitro+ RX 570, easy installation, although because this Bitfenix case is quite small one of the fans was hitting the firewire card. A little piece of folded paper in-between the cards solved it.
 
Last edited:
Top