Contribute
Register

Success High Sierra 10.13.4 With Nvidia 1050ti H270 g3

Joined
Apr 23, 2016
Messages
6
Motherboard
Gigabyte H270 Gaming 3
CPU
core i5-7500
Graphics
GTX 1050 ti
Mac
  1. iMac
Mobile Phone
Part 1 : Update Via mac Store

I just simple update High Sierra from Mac App Store (from 10.13.1 to 10.13.4 ), its work like imagine . but after install USB 3.00 ports is not support , for fixed that I use that kexts patch :

USB 3.00 fixed :

Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>

after patch its works like imagine .

Nvidia drivers :

Nvidia drivers update automatically .. it can be manually read this guides https://www.tonymacx86.com/threads/...s-high-sierra-10-13-4-387-10-10-10-30.249039/

For Lag issue with 387.10.10.10.30.103 Fixed :


1. https://www.tonymacx86.com/threads/nvidia-update-simple-way-to-install-nvidia-web-drivers.244987/

OR

2. You need to download Nvidiagraphicsfixup and lilu kexts (latest)
https://github.com/lvs1974/NvidiaGraphicsFixup/releases
https://github.com/vit9696/Lilu/releases

mount your EFI then GO > CLOVER > kexts > others folder and paste it here .

Reboot your system ..

For sound I use MultiBeast and chose voodooHDA
..

If No Audio Devices with AppleHDA Realtek Audio read this guide : https://www.tonymacx86.com/threads/no-audio-devices-applehda-realtek-audio.234729/


Now everything is work fine.:headbang::headbang::headbang::headbang::headbang::headbang::headbang::headbang:


Part 2 : via UniBest 8.2

Currently there are two issues with USB sticks for macOS 10.13.4 created with UniBeast 8.2.
Until we release UniBeast 8.3 you need to run the following two Terminal commands after running UniBeast and before ejecting any volume:

Code:
rm -f /Volumes/Install\ macOS\ High\ Sierra/.IAPhysicalMedia

Code:
rm -rf /Volumes/ESP/EFI/CLOVER/kexts/Other/USBInjectAll.kext


UniBeast 8.3 is now available for download at tonymacx86.com/downloads. If this utility has helped you, please consider a contribution to support further UniBeast development. Thanks in advance, and enjoy!

Now you are ready for Setup
 
Last edited:
  • Like
Reactions: ksy
Joined
Jan 10, 2015
Messages
2
Motherboard
Mavericks 10.9.5
CPU
I7 4770
Graphics
NVIDIA GEFORCE GTX 650
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Joined
Apr 23, 2016
Messages
6
Motherboard
Gigabyte H270 Gaming 3
CPU
core i5-7500
Graphics
GTX 1050 ti
Mac
  1. iMac
Mobile Phone
Joined
Sep 24, 2013
Messages
120
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
Vega
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. eMac
  2. iMac
  3. Power Mac
Mobile Phone
  1. iOS
Hello mate,

I see you've done it successfully, do not find the way to PM you requesting some advice or help about it.
I'd really appreciate If you can spend some minutes with my problem... can't find help about, and I see you have got same graphic card I want to buy.

https://www.tonymacx86.com/threads/...-graphics-gigabyte-geforce-1050ti-4gb.248786/

Thank you and sorry If spam you with this,

davidminyano, I've tried to post a long reply on this thread,
https://www.tonymacx86.com/threads/...-graphics-gigabyte-geforce-1050ti-4gb.248786/
but unlike any other post I've made each time after I've logged out my reply has disappeared. Unless that is some setting for your account, it's strange. Just trying to help. I could post here, I suppose.
 
Last edited:
Joined
Sep 24, 2013
Messages
120
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
Vega
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. eMac
  2. iMac
  3. Power Mac
Mobile Phone
  1. iOS
Hello mate,

I see you've done it successfully, do not find the way to PM you requesting some advice or help about it.
I'd really appreciate If you can spend some minutes with my problem... can't find help about, and I see you have got same graphic card I want to buy.

https://www.tonymacx86.com/threads/...-graphics-gigabyte-geforce-1050ti-4gb.248786/

Thank you and sorry If spam you with this,

This upgrade is very possible. My rig is proof of it.

Do not install over your Mavericks installation on the Kingston drive and do not install over whatever flash drive you have as the installer for Mavericks. Buy a new drive (SSD or HDD) or reuse your HDD -- but for any drive you'll have to erase and reformat the drive completely. Buy a new 8-16GB USB flash drive.

Install Apple's macOS installer using UniBeast 8.3.1:
https://www.tonymacx86.com/resources/unibeast-8-3-1.381/
Here on UniBeast and later with MultiBeast always choose UEFI only when asked to choose and when choosing your system definition (SMBIOS) choose iMac 14,2.

To install macOS installer on the flash drive and macOS 10.13.4 on your disk follow tonymacx86's installation method:
https://www.tonymacx86.com/threads/...ierra-on-any-supported-intel-based-pc.235474/

After you make your USB flash drive installer, restart, and then
Go into your BIOS (hitting "Delete" while starting up) and use these settings:

Start by loading optimized defaults. Use the profile for your RAM, if you need it. No OC on your processor. Fast Boot (DISabled); Execute Disable Bit (Enabled); Intel Virtualization (Enabled); Secure Boot (DISabled); Boot Mode Selection (I suggest UEFI and Legacy, but can try UEFI Only); Storage Boot (Legacy Only); Init Display First (IGFX); XHCI Mode (Smart Auto /or Auto); Internal Graphics (Enabled) and Memory Size (128M); Intel Rapid Start (DISabled); Legacy USB (Enabled); XHCI Hand-Off (Enabled); EHCI Hand Off (DISabled).

In Bios, choose SAVE and Exit Setup, which reboots. Shutdown.

Disconnect all SSD's and HDD's except the one you're installing to and pull out your graphics card, your GTX 650 or the new one before installing. To install: Start up the computer and at Clover menu (if going there is not automatic, start up again and start hitting F12 to open the system bootloader, choose the UEFI version of your new USB flash drive installer and there choose Install macOS.

NOTE: because SSD's will automatically covert to APFS and HDD's stay HFS+ when you install High Sierra on them, read in the installation guide by tonymacx86 about this:
(https://www.tonymacx86.com/threads/...ierra-on-any-supported-intel-based-pc.235474/),
There are ways to handle that to stay in HFS+

I'll write more later. In mean time if you're not doing this soon, download Clover Configurator to your Mavericks installation. You can use it to mount your EFI folder on this partition and on your flashdrive installers. Careful what you do, just look unless you have experience. The all-essential Clover config.plist (A COPY PLEASE NOT THE ORIGINAL) can be dragged to the CC icon in your dock and opened that way into the configuration fields.

Read these posts of mine to find some similarities to what you're doing:

https://www.tonymacx86.com/threads/macos-10-13-3-supplemental-update.246266/page-27#post-1702833

https://www.tonymacx86.com/threads/...hout-success-help-please.247957/#post-1705800

Let me know if this sounds like the right direction...
 
Last edited:
Joined
Apr 23, 2016
Messages
6
Motherboard
Gigabyte H270 Gaming 3
CPU
core i5-7500
Graphics
GTX 1050 ti
Mac
  1. iMac
Mobile Phone
Hello mate,

I see you've done it successfully, do not find the way to PM you requesting some advice or help about it.
I'd really appreciate If you can spend some minutes with my problem... can't find help about, and I see you have got same graphic card I want to buy.

https://www.tonymacx86.com/threads/...-graphics-gigabyte-geforce-1050ti-4gb.248786/

Thank you and sorry If spam you with this,


hello , this post will helps you for fresh installation >>

1. if you already mac user back up everything by time machine
2. then download high sierra from mac store .
3. create bootable usb via unibeast 8.3 , don't select anything from alternative graphic platform .and also don't need to change anything in config.plist
4.restart your pc .
5. make sure your bios setup is fine .
6. after finish setup process, you need multibeast for install some drive .. like sound (depends on your motherboard , if you don't know which one is supported plz search on google about your motherboard ) , system definition (most important part for graphic support , its depends on which processor you used ) , in cloverbootloder chose uefi boot mode + Emulated NvRAM ( its also Important for graphic card ) I attached my muiltbeast setup..
7. now install web drive (don't restart )
8. mount your EFI by any mounter software , you can find on google . and open config.plist by clover configuration . and on Acpi , untick everything without fix shut down .
8. restart your pc and enjoy .
Note : sometime some kexts is not work properly , for that you need to customize your config.plist .. like USB 3.00 port not working ,no sound

I hope if you follow this process no problem will be face .. thank you
 

Attachments

  • Screen Shot 2018-01-16 at 11.45.28 AM.png
    Screen Shot 2018-01-16 at 11.45.28 AM.png
    279.7 KB · Views: 595
Last edited:
Top