Contribute
Register

[Success] ECS 945GCT-M

Joined
Nov 4, 2011
Messages
65
Motherboard
ASUS P8H61-M LE/CSM
CPU
i2500K
Graphics
Intel HD Graphics 3000
Mac
Classic Mac
Mobile Phone
Much to my surprise I got a PM from another user with this rickety old board that wants to get it up and running. This won't be an extensive guide cause quite honestly- there's just not much to it especially if you already had Leo or SL running on it before (which means you've already tweaked the bios)-- Assuming you've done that- here was my vague remembrance of what was done..

Note: I am not using the on board video- rather an old GF 6600 which I had pretty much zero confidence would come up and work (I was wrong). The proc used here is a Intel E2200 (not a true core 2- but gets the job done).

1. Make unibeast usb stick and follow tony's directions throughout the Lion install.
2. Install mbeast (I used 4.0.3 which has since been upgraded)-- I used the options for easybeast, latest voodoo for sound, - I did not touch network stuff at this time as it was already working after first boot. Video resolution was stuck at 1024x768. I did not install anything for vid nor a custom dsdt as I couldn't find one.
3. After boot- Vid came up in full 1080 and tested qe/ci w/ chess and widgets ripple. Still no sound, and now network was gone.
4. Ran MB again and chose the realtek nic drivers, and went back to voodoo 0.2.2.
5. Rebooted again w/ sound, 1080 res, and nic working.

I haven't messed with sleep, but I've read it can be achieved with some jumper settings on the motherboard. I don't care about that as this machine runs 24/7 w/ only monitor and hd sleep enabled. Thank you UB!
 
Joined
Nov 22, 2011
Messages
1
Mac
Classic Mac
Mobile Phone
Success! used multibeast for sound with the latest voodoo, nic used the realtec drivers. The video will only work in 32bit mode with the graphicsenabled=on, its ok though i had a old 7300SE that worked great in 64-bit with graphics enabled. Thanks alot. It is a old rickety board but over all it does its job and does it well. Its great just to play around with and see what the OS can do. Thanks again.

Thomas
 
Joined
Nov 4, 2011
Messages
65
Motherboard
ASUS P8H61-M LE/CSM
CPU
i2500K
Graphics
Intel HD Graphics 3000
Mac
Classic Mac
Mobile Phone
Glad to hear of your success. One thing to watch out for- let me know if you see intermittent internet drops. It hasn't happened that often but a couple of times when using google chrome the internet connection (and possibly overall network/lan) just drops for a minute or two. Then it comes back fine w/o rebooting or anything.. It hasn't happened nearly enough to be considered a major problem but it's a little concerning. If anyone else knows anything about this from other builds please chime in. Maybe it's realtek related, maybe it's just Lion.
 

pct

Joined
Nov 8, 2010
Messages
89
Motherboard
Gigabyte H67MA-UD2H-B3
CPU
i3-2105
Graphics
GT710
NoThomass said:
Success! used multibeast for sound with the latest voodoo, nic used the realtec drivers. The video will only work in 32bit mode with the graphicsenabled=on, its ok though i had a old 7300SE that worked great in 64-bit with graphics enabled. Thanks alot. It is a old rickety board but over all it does its job and does it well. Its great just to play around with and see what the OS can do. Thanks again.

Thomas

Thomas

I am trying to update to 10.7.2 with a 6600GT and I am getting a Kernel Panic on video driver. (see there
viewtopic.php?f=15&t=40963)

Can you confirm your setup was working with no GraphicsEnable=Yes (or any other strings), boot in 32 only ?
What happens if booting in 64 bits ? Which version of Lion you are using ?
Which SMBIOS file are your using?
Are you in VGA or DVI ?

Thanks
 
Joined
Dec 5, 2010
Messages
15
Motherboard
GA-B75M-D3V
CPU
i3
Graphics
built-in
Mac
Classic Mac
Mobile Phone
I have V.3 of this board. Following haggle's advice, I installed with unibeast, then ran multi beast. Installed the Realtek driver (not the lnx2mac Realtek driver, but the 3rd option) to get ethernet, and the latest Voodoo worked for me for sound.

However, I was stuck at 1024x768, and no sleep. To get these working, I used the attached dsdt (courtesy of MaLd0n at insanelyMac - he built this for my SL installation on this board). Then, I deleted the following from /Extra/org.chameleon.Boot.plist:
Code:
<key>Kernel Flags</key>
	<string>npci=0x2000 darkwake=0</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
and added:
Code:
<key>Kernel Flags</key>
	<string>arch=i386</string>
Looks like everything works now: graphics, sound, ethernet, sleep, even iCloud!
 

Attachments

  • dsdt.aml
    16.9 KB · Views: 222
Joined
Dec 5, 2010
Messages
15
Motherboard
GA-B75M-D3V
CPU
i3
Graphics
built-in
Mac
Classic Mac
Mobile Phone
Anybody try 10.7.3 yet?
 
Joined
Aug 25, 2011
Messages
14
Motherboard
Gigabyte Z68
CPU
i5-2500K
Graphics
HD 3000
scram69 said:
Anybody try 10.7.3 yet?

10.7.4 works ok..Having an issue with USB waking up from sleep though, if anyone has any idea on how to fix that.
 
Joined
Dec 5, 2010
Messages
15
Motherboard
GA-B75M-D3V
CPU
i3
Graphics
built-in
Mac
Classic Mac
Mobile Phone
I'm currently running 10.7.5 successfully. The combination of dsdt and org.chameleon.boot.plist edits I posted earlier still works for graphics and sleep. The only other issue I ran into was waking from sleep - the display would not wake.

The solution was setting BIOS passwords - user and admin. Now sleep works.

Note: putting darkwake=0 back into the kernel flags will just prevent the dsdt from loading.
 
Top