Contribute
Register

[Success] Asus P8P67 Deluxe + i7 2600K Running Mount Lion

Status
Not open for further replies.
Joined
Jan 26, 2011
Messages
84
Motherboard
Dell XPS 15 9550
CPU
6th Generation Intel® Core™ i7-6700HQ Quad Core
Graphics
NVIDIA® GeForce® GTX 960M with 2GB GDDR5
[Success] Asus P8P67 Deluxe + i7 2600K Running 10.8 ML

After several hours, I finally got my Asus P8P67 Deluxe up and running with Mountain Lion OS. I followed TooSixy's P8Z68 guide (http://www.tonymacx86.com/mountain-...10-8-installation-asus-p8z68-deluxe-gen3.html).

The most difficult thing for me was with the graphic card - Asus GTX 460. The installation screen simply would not show. I had to make the following changes to the installation USB:

0. get an old 8800GT and stick it in the main graphics slot (near the CPU)

2. update the Extra/org.chameleon.Boot.plist to turn the GraphicsEnabler off

<key>GraphicsEnabler</key>
<string>No</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>npci=0x3000 darkwake=0</string>

3. place iMac12,2 profile in the Extra/smbios.plist

<key>SMfamily</key>
<string>iMac</string>
<key>SMproductname</key>
<string>iMac12,2</string>
<key>SMboardproduct</key>
<string>Mac-942B59F58194171B</string>
<key>SMserial</key>
<string>C02FT7U2DHJP</string>
<key>SMbiosversion</key>
<string>MultiBeast.tonymacx86.com</string>

Then, I was able to see the ML installation screen. Follow through the guide. I used the DSDT.aml for modified 2302 ROM and hnak's AppleIntelE100e Ethernet from the MultiBeast. Overclocking worked! Running 4.8Ghz. Sound is also working!! See the GeekBench 17,151.
 

Attachments

  • Screen Shot 2012-07-29 at 11.14.49 AM.jpg
    Screen Shot 2012-07-29 at 11.14.49 AM.jpg
    146.1 KB · Views: 595
Joined
Jan 1, 2012
Messages
27
Motherboard
P8P67 Deluxe
CPU
i7-2600k
Graphics
Gigabyte Xtreme 980TI
Mac
Classic Mac
Mobile Phone
I had no success as of yet. I can install alright, but whatever I do, the system kernel panics immediately on first reboot. I'm running the deluxe version with stock 2302 and a Radeon HD 5870 and a 2600k, do I need to do something special because of that? I was using the DSDT from the main page and was following Threesixtys guide.

Where can I get that patched BIOS in case that helps?

edit: Okay, I found bios4asus.blogspot.com by now. :)

I reinstalled with fresh bios but with threesixty's p8z67 DSDT and followed Threesixty's instructions to the point (well, without the whole Radeon 6000 thing). I do not get Kernel Panics anymore but the machine won't boot either. :(
With normal boot I get endless spinning, this is how it looks like in verbose mode:



When waiting for a really long time, it changes to: "disk0s2: no such device"

The only way to get to the desktop now is to reinstall over the old installation, then I get to boot, but only once. Unfortunately, I have no idea what could be the cause of this. :/
 
Joined
Jan 26, 2011
Messages
84
Motherboard
Dell XPS 15 9550
CPU
6th Generation Intel® Core™ i7-6700HQ Quad Core
Graphics
NVIDIA® GeForce® GTX 960M with 2GB GDDR5
try to take out other disks and keep one disk. if that does not work, move it to different sata connection.
 
Joined
Jan 17, 2011
Messages
1
Motherboard
Mountain Lion
CPU
i7 2600K
Graphics
ATI RADEON 5870
Mac
Classic Mac
Mobile Phone
  1. Android
Thanks for your support,
I've got nearly the same conficuration except the graphic card which is an ATI 5870.
What DSDT did you use because the one posted by Toosixy is for P8Z68?
Can you post your personnal DSDT?
Thank you.
 
Status
Not open for further replies.
Top