Contribute
Register

SOLVED : Simple and quick solution for ALC892 Issue / With GA-Z170M and 10.11.4

Status
Not open for further replies.
Joined
May 4, 2016
Messages
54
Motherboard
Gigabyte Z490m Gaming X
CPU
i9-10850K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello Everybody ;)

Before to start please excuse me for my english. I'm french ^^
I'm a new owner of hackintosh since few days only. It was not easy to reach to my goal and I would thank @tonymacx86 and @Stork for their help !!! :)

After have lost a lot of hours with a lot of solution no working for me... I was never able to get native audio working !
And I finally found this one ! Hope it can help you to have Audio with ACL892 !

My config is : GA-Z170M-D3H / i6700k with El Capitan 10.11.4

I try few solutions but no one was working for me (or maybe does I miss something)

  1. - Multibeast 8.2.2 solution : NOT WORKING !
  2. - Adding AppleHDA.kext / HDAEnabler892.kext with KextBeast or Kext Wizard : NOT WORKING !
  3. - Using Audio_CloverALC-110_V1.command : NOT WORKING ! Have errors below in terminal
File: audio_cloverALC-110.command_v1.0r10
Release Mode
Password:
Print: Entry, ":CFBundleShortVersionString", Does Not Exist
Error occurred, AppleHDA.kext/Contents/Info.plist/BundleShortVersionString not found
No system files were changed
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.​

Finally I found this really simple solution : Just install VoodooHDA 2.8.8 pkg file.
https://sourceforge.net/projects/voodoohda/

Install the original pkg file ! For me the Voodoo inside Multibeast was not working.
After have installed the pkg, reboot and go to Pref Panel > Audio > Output and you will see the Audio :)
Digital-Out HDMI is working / Line-Out (Rear) is working / Headphones (Front) is working / Don't test for microphone.

LAST (IMPORTANT) TIPS :

When you plug your headphones on front or rear jack you will probably heard a noisy scratch sound !

  • Go to Pref Panel > VoodooHDA
  • Select the 2nd option (see caption) to have the line settings. The first option concern the HDMI Audio.
  • Select the "Line Out" and just move Input gain to 0 and the bad noise will be removed :)
  • Do the same with "Headphones" and do the same if you use Front jack.
Capture d’écran 2016-05-09 à 02.35.26.png

Hope this one will be clear for you and will close your issues with ACL892 Audio / 10.11.4 !!!

Good luck ;)

EDIT : Sometimes when I reboot the Input Gain slider go back to default value... Have to check that !

EDIT 2 : THE PB ABOVE IS SOLVED ! AUDIO FULLY WORKING.

I will show you the fix for the problem with VoodooHDA Pref Panel, where when you change the settings it's not saved when you reboot ! There is two reasons !

- First one : Check the VoodooHdaLoader.app is enabled to launch on startup !
Go to System Pref > Users & Groups : Click on Login items. If the VoodooHdaLoader.app doesn't appear click on the "+" below and go to your Applications folder to add it. (You can check Hide)

- Second one : You need to modify the Info.plist located inside our VoodooHdaLoader.app to force it to have a "0" value for settings.

Launch Terminal :
  • Type 'sudo -s' and your password
  • Type 'cd /System/Library/Extensions/VoodooHDA.kext/Contents'
  • Now type 'ls' to check if the Info.plist is right here
  • If ok type 'nano sudo Info.plist'
  • Scroll down until you see the <key>PCM</key>
  • Modify the four value PCM, Rec, iGain & iMix to '0'
  • Save and restart !

Now the problem must have been fixed :)
 
Last edited:

toleda

Moderator
Joined
May 19, 2010
Messages
22,928
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I try few solutions but no one was working for me (or maybe does I miss something)
  1. - Multibeast 8.2.2 solution : NOT WORKING !
  2. - Adding AppleHDA.kext / HDAEnabler892.kext with KextBeast or Kext Wizard : NOT WORKING !
  3. - Using Audio_CloverALC-110_V1.command : NOT WORKING
Missed several things.
1. See Quick MultiBeast Setup for Skylake Systems 10.11.4+
2. Not supported, never work
3. AppleHDA.kext is not native, script terminates.
 
Joined
May 4, 2016
Messages
54
Motherboard
Gigabyte Z490m Gaming X
CPU
i9-10850K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Missed several things.
1. See Quick MultiBeast Setup for Skylake Systems 10.11.4+
2. Not supported, never work
3. AppleHDA.kext is not native, script terminates.

1. Never work for me ! I tried several times.
2. Ok. I see that ^^
3. Have the same problem.

That's why I used this solution with the VoodooHDA pkg.
But I was asking myself if I will not bought a USB Audio Dongle :) More simple solution, Ahah
 
Joined
May 8, 2016
Messages
5
Motherboard
Gigabyte
CPU
Intel i5
Graphics
GeForce GTX 950
Thank you so much for your post. I have been looking for a solution for a whole day and found your post. It just works!
 
Joined
May 8, 2016
Messages
5
Motherboard
Gigabyte
CPU
Intel i5
Graphics
GeForce GTX 950
Really happy it works for you ! Do you have the same problem when rebooting ? Having the slider "input gain" go back to default value ?
I have the same problem after reboot. I would like to know how can I fix it. Thank you for your help ;)
 
Joined
Sep 5, 2015
Messages
3
Motherboard
Asus Z97-A
CPU
Intel Core i7 4790k 4.0GHz
Graphics
MSI GTX 980 4G
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I junst wanted to say a big thank you ! It worked marvellously on my system (Z97-A, i7 4790k, GTX980, 16GB of DDR3)
Et en plus t'es français, encore mieux ;)
Merci !
 
Joined
May 8, 2016
Messages
5
Motherboard
Gigabyte
CPU
Intel i5
Graphics
GeForce GTX 950
Scroll to the top, at the end of my first post ! I post last night a "how to" to fix the problem :)
Let me know if it's working for U too.
It works perfectly! Thank you again!
 
Joined
May 4, 2016
Messages
54
Motherboard
Gigabyte Z490m Gaming X
CPU
i9-10850K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Really happy it works for you guys.

I junst wanted to say a big thank you ! It worked marvellously on my system (Z97-A, i7 4790k, GTX980, 16GB of DDR3)
Et en plus t'es français, encore mieux ;)
Merci !

Ahah ca se voit tant que ça à mon anglais approximatif ? ^^ lol
 
Status
Not open for further replies.
Top