Contribute
Register

[Solved] Reboot on shutdown (sometimes) and slow shutdown/reboot

Joined
Nov 13, 2012
Messages
35
Motherboard
Asrock Z390 Phantom Gaming 6
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I just built a new hack with 10.13.6. Most things are working but shutdown and restart has issues.

1. When I shutdown or restart it always takes very long (around 10s) after the kernel halted before the computer shuts off or restarts. Just a black screen with fans going up until the process continues.

2. Sometimes the computer reboots after this long period even if shutdown was selected. This only happens sometimes and is somehow connected to the amount of attached usb devices. When I detach my usb sound card it usually does not do it. The slow restart/reboot problem (1.) is always there. Even without any USB attached.

3. Sometimes even some bios settings get changed. Maybe some corruption is taking place?

The problem from (1) does not exist when I replace AptioMemoryFix by OsxAptioFixDrv. However, my Nvidia web driver does not load with the latter one because the nvram appears to be empty then. The other aptio fix drivers do not allow me to boot.

I messed around with bios settings a lot but nothing really had any effect. Wake on LAN is off.

Attached is:
  • ioregexplorer 2.1 dump
  • clover directory (including dsdt dump)
  • some terminal commando outputs
 

Attachments

Joined
Nov 13, 2012
Messages
35
Motherboard
Asrock Z390 Phantom Gaming 6
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Top