Contribute
Register

[solved] Keyboard stops working randomly at High Sierra

Status
Not open for further replies.
Joined
May 4, 2017
Messages
130
Motherboard
Lenovo Flex 2 15inch
CPU
i7-4510U
Graphics
HD 4400 + GT 840M, 1920x1080
Mobile Phone
  1. iOS
Hi

@RehabMan, I've installed latest version of VoodooPS2Controller as per you mention in the How-to install section of its github page.
Let me add some details to this problem. Some unusual kind of stop working also happened.

First, in a case, it stopped working but wherever (text fields) I clicked letter 'e' started typing like : "eeeeeeeeeeee.." without any end.

Second, I think the reason of not working isn't a full dead. I think the reason that keyboard keys not working is that some keys like shift and alt and ctrl automatically start to pushing (same as eeee...) and then it prevents other keys to be entered and worked so in practical I think keyboard is completely dead whereas it isn't.


Update: It happened again so I opened virtual keyboard for testing. It showed No key pushed down. So my above logic isn't correct (virtual keyboard worked fine)
 

Attachments

  • Archive.zip
    17.8 MB · Views: 137
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi

@RehabMan, I've installed latest version of VoodooPS2Controller as per you mention in the How-to install section of its github page.
Let me add some details to this problem. Some unusual kind of stop working also happened.

First, in a case, it stopped working but wherever (text fields) I clicked letter 'e' started typing like : "eeeeeeeeeeee.." without any end.

Second, I think the reason of not working isn't a full dead. I think the reason that keyboard keys not working is that some keys like shift and alt and ctrl automatically start to pushing (same as eeee...) and then it prevents other keys to be entered and worked so in practical I think keyboard is completely dead whereas it isn't.


Update: It happened again so I opened virtual keyboard for testing. It showed No key pushed down. So my above logic isn't correct (virtual keyboard worked fine)

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
May 4, 2017
Messages
130
Motherboard
Lenovo Flex 2 15inch
CPU
i7-4510U
Graphics
HD 4400 + GT 840M, 1920x1080
Mobile Phone
  1. iOS
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Sorry. I had attached it to another topic by mistake. Now it attached to the first post.

note1: You mentioned there to use clover menu to make a copy of EFI folder and compressing but I have used your terminal command "diskutil mount EFI" and then compressed it manually. Is ok?

note2: Size is huge though I eliminated Themes folder. The main part of this huge size is because of APPLE folder a child of EFI folder. It's a bran-new folder (and I guess it's related to APFS)
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Sorry. I had attached it to another topic by mistake. Now it attached to the first post.

note1: You mentioned there to use clover menu to make a copy of EFI folder and compressing but I have used your terminal command "diskutil mount EFI" and then compressed it manually. Is ok?

note2: Size is huge though I eliminated Themes folder. The main part of this huge size is because of APPLE folder a child of EFI folder. It's a bran-new folder (and I guess it's related to APFS)

EFI not requested. Please provide only EFI/Clover as per FAQ, "Problem Reporting" (it is quite clear).
 
Joined
May 4, 2017
Messages
130
Motherboard
Lenovo Flex 2 15inch
CPU
i7-4510U
Graphics
HD 4400 + GT 840M, 1920x1080
Mobile Phone
  1. iOS
EFI not requested. Please provide only EFI/Clover as per FAQ, "Problem Reporting" (it is quite clear).

Sorry.
Attached Report.zip including Clover.zip+Terminal output#1+Terminal output#2+RehabMan.zip
 

Attachments

  • Report.zip
    1.9 MB · Views: 100
Joined
May 4, 2017
Messages
130
Motherboard
Lenovo Flex 2 15inch
CPU
i7-4510U
Graphics
HD 4400 + GT 840M, 1920x1080
Mobile Phone
  1. iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thank you.

Regarding kext installing nothing is new to me. I've installed Hackintosh more than 7 times and I really know how to install kexts.

Possible to give me more details on the flag that indicates incorrectness?

Your kextcache output indicates FakeSMC.kext is not installed.
All kexts you need must be installed to the system volume.
 
Joined
May 4, 2017
Messages
130
Motherboard
Lenovo Flex 2 15inch
CPU
i7-4510U
Graphics
HD 4400 + GT 840M, 1920x1080
Mobile Phone
  1. iOS
Your kextcache output indicates FakeSMC.kext is not installed.
All kexts you need must be installed to the system volume.

FakeSMC installed and the problem completely disappeared.

Thanks
 
Joined
Jan 21, 2020
Messages
2
Motherboard
Dell 1464 Rev.00
CPU
i3-330M/HM55
Graphics
HD need model # > See Rules! , 1366x768
Mobile Phone
  1. iOS
Hi @norwayRainyday can you help me with the same problem as you.
my keyboard started typing continuously when i typed a character (e.g e became jjjjjjjjjjjj....).
Fakesmc loaded successfully and i don't know anymore about what causing this problem.
 

Attachments

  • CLOVER.zip
    2.3 MB · Views: 40
Status
Not open for further replies.
Top