Contribute
Register

[solved] DELL 5458 | ALC255 Don't active with condeccommander

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank you for quick response
I did all steps but nothing works. I think problem comes from CodecCommander itself because the audio works fine except of headset. :(

btw, "after run the commander for create o cache again." means I rebuild kext cache by "sudo kextcache -i /" right?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Oct 11, 2017
Messages
22
Motherboard
Dell Insprion 3459 (Clover)
CPU
I5-6200U
Graphics
Intel Graphics HD 520
Mobile Phone
iOS

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
My bad. This is my debug files.
This configuration looks ok (audio working), although you might consider using an AppleHDA injector (dummyHDA) instead of patched AppleHDA.kext (your config.plist already has the patches for it).
 
Joined
Oct 11, 2017
Messages
22
Motherboard
Dell Insprion 3459 (Clover)
CPU
I5-6200U
Graphics
Intel Graphics HD 520
Mobile Phone
iOS
This configuration looks ok (audio working), although you might consider using an AppleHDA injector (dummyHDA) instead of patched AppleHDA.kext (your config.plist already has the patches for it).
Ok, it's "sudo kextcache -i /". Run this commander after inicialization of OS X, "hda-verb 0x19 SET_PIN_WIDGET_CONTROL 0x25". You need of hda-verb script, do on download https://bitbucket.org/RehabMan/os-x-eapd-codec-commander/downloads/, after extract, input the hda-verb on /usr/bin. This go enable headset. If this resolved, you create a script that run on login with that command.
Following @eltoncerqueira instruction, after run this commander "hda-verb 0x19 SET_PIN_WIDGET_CONTROL 0x25", headset works like a charm. Is there any way to make SSDT for patching CodecCommander.kext with that params 0x19 and 0x25?
I really don't know how these things work? :(
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Following @eltoncerqueira instruction, after run this commander "hda-verb 0x19 SET_PIN_WIDGET_CONTROL 0x25", headset works like a charm. Is there any way to make SSDT for patching CodecCommander.kext with that params 0x19 and 0x25?
I really don't know how these things work? :(
CodeCommander already sends 0x19 SET_PIN_WIDGET_CONTROL 0x25 for ALC255 at startup and after wake from sleep.
Look in the Info.plist and you'll see.
 
Joined
Oct 11, 2017
Messages
22
Motherboard
Dell Insprion 3459 (Clover)
CPU
I5-6200U
Graphics
Intel Graphics HD 520
Mobile Phone
iOS
CodeCommander already sends 0x19 SET_PIN_WIDGET_CONTROL 0x25 for ALC255 at startup and after wake from sleep.
Look in the Info.plist and you'll see.
Oh, I got it. Then I try install debug CodecCommander and check kernel_log. I see the commander has run but it still doesn't work before I run "0x19 SET_PIN_WIDGET_CONTROL 0x25" manually. Do you have any idea why it been interrupted? :(
 

Attachments

Joined
Jan 20, 2017
Messages
83
Motherboard
Dell Vostro 3546(clover)
CPU
Intel core i3-4005u;Dell 09XY3N;INTEL LYNX POINT-LP(MAINSTREAM)
Graphics
Intel integrated 4400 graphics only,1366*768
Mobile Phone
Android
@chiendo97 Instead of using Patched applehda try Applealc dynamic patching with layout 17 (may try 13) for alc255 ,and use alcplugfix (search) to remove headphone noise.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Oh, I got it. Then I try install debug CodecCommander and check kernel_log. I see the commander has run but it still doesn't work before I run "0x19 SET_PIN_WIDGET_CONTROL 0x25" manually. Do you have any idea why it been interrupted? :(
It may be something wrong in your patched AppleHDA.
Try using aDummyHDA.kext as generated from Mirone's HDA patcher.
 
Joined
Oct 11, 2017
Messages
22
Motherboard
Dell Insprion 3459 (Clover)
CPU
I5-6200U
Graphics
Intel Graphics HD 520
Mobile Phone
iOS
@chiendo97 Instead of using Patched applehda try Applealc dynamic patching with layout 17 (may try 13) for alc255 ,and use alcplugfix (search) to remove headphone noise.
Thank you, I appreciate your suggestion, I may try it in some days.

It may be something wrong in your patched AppleHDA.
Try using aDummyHDA.kext as generated from Mirone's HDA patcher.
Thank you so much. After re-install vanilla AppleHDA.kext to S/L/E and aDummyHDA.kext to /L/E, my audio and my headset works like a charm again. You can mark it as solved.
 
Top