Contribute
Register

[Solved] Bose USB Audio Problem

Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
After updating to the latest security fix I started experiencing a problem with my Bose USB Audio.

Every time I restart, I get a warning that my computer was restarted because it had a problem. It seems that my Bose Audio cause a Kernel Panic on shutdown or restart. The Bose Audio works properly when OSX is running.

This behavior happens whether the Bose system is connected or not.


Anonymous UUID: 9FD637B0-384F-5D5A-ADA5-F68B53D14C97

Sat Jan 20 10:08:07 2018

*** Panic Report ***
panic(cpu 0 caller 0xffffff801726627c): "Bose USB Audio[0x100000396]::terminate(kIOServiceSynchronous) timeout\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4570.31.3/iokit/Kernel/IOService.cpp:2289
Backtrace (CPU 0), Frame : Return Address
0xffffff8212b23960 : 0xffffff8016c505f6
0xffffff8212b239b0 : 0xffffff8016d7d604
0xffffff8212b239f0 : 0xffffff8016d6f0f9
0xffffff8212b23a70 : 0xffffff8016c02120
0xffffff8212b23a90 : 0xffffff8016c5002c
0xffffff8212b23bc0 : 0xffffff8016c4fdac
0xffffff8212b23c20 : 0xffffff801726627c
0xffffff8212b23c70 : 0xffffff8017269d27
0xffffff8212b23cf0 : 0xffffff7f978d3808
0xffffff8212b23d10 : 0xffffff7f98766f2b
0xffffff8212b23d50 : 0xffffff7f98766908
0xffffff8212b23db0 : 0xffffff7f9875bd8b
0xffffff8212b23df0 : 0xffffff7f9875ea8d
0xffffff8212b23e40 : 0xffffff8017276d85
0xffffff8212b23eb0 : 0xffffff8017276b2a
0xffffff8212b23ed0 : 0xffffff8016c89e74
0xffffff8212b23f40 : 0xffffff8016c89965
0xffffff8212b23fa0 : 0xffffff8016c014f7
Kernel Extensions in backtrace:
com.apple.iokit.IOUSBFamily(900.4.1)[FD04D3BC-D376-36FD-924C-DD5DF51B0509]@0xffffff7f97896000->0xffffff7f97930fff
dependency: com.apple.iokit.IOPCIFamily(2.9)[C08F7FC1-78A4-3A1B-BFE2-C07080CF2048]@0xffffff7f974a7000
dependency: com.apple.iokit.IOUSBHostFamily(1.2)[8398A8CC-6560-38E5-B061-C4EEB6B2E1D9]@0xffffff7f97816000
dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[E768F6C8-F7ED-3AA5-AB26-03284841965E]@0xffffff7f9780e000
com.apple.driver.AppleUSBLegacyHub(900.4.1)[6D278A06-950F-35C6-B3E4-445F4BBD7DB9]@0xffffff7f98759000->0xffffff7f98771fff
dependency: com.apple.iokit.IOUSBFamily(900.4.1)[FD04D3BC-D376-36FD-924C-DD5DF51B0509]@0xffffff7f97896000

BSD process name corresponding to current thread: kernel_task
Boot args: -v dart=0 darkwake=0 lilubetaall igfxbeta

Mac OS version:
17C205

Kernel version:
Darwin Kernel Version 17.3.0: Thu Nov 9 18:09:22 PST 2017; root:xnu-4570.31.3~1/RELEASE_X86_64
Kernel UUID: 87641697-A3DD-30C4-B010-E65ECE57550B
Kernel slide: 0x0000000016800000
Kernel text base: 0xffffff8016a00000
__HIB text base: 0xffffff8016900000
System model name: iMac18,3 (Mac-BE088AF8C5EB4FA2)
 
Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
The problem was with NVRAM. I was loading the emu variable driver and the associated nvram fie had reference to a KP with the Bose audio. I deleted the nvram file and removed the emu variable driver. Seems to be working normally now.
 
Top