Contribute
Register

Shutdown and Bluetooth problems on HP Envy x360

Joined
Jan 21, 2022
Messages
3
Motherboard
HP 8483 70.31
CPU
Intel Core i7 8550U
Graphics
Intel UHD Graphics 620
I have an HP Envy x360 15-cn0013nr with almost everything working with Monterey, with the following specs:
CPU: Intel Core i7 8550U (Kaby Lake R)
GPU: Intel UHD Graphics 620
Motherboard: HP 8483 (Insyde F.27)
OpenCore v0.7.7
Memory: 16 GB (though I don't think this is relevant)
Ports: 2 USB (3.0), 1 USB Type-C, SD, HDMI.

I followed the Dortania OpenCore guide a couple of days ago and successfully installed macOS 10.12 Catalina (as the guide said it was the most compatible). Everything was working perfectly except for shutdown: it would get stuck on the logs screen with the last message showing something like "shutting the system down" (can't remember the exact message, and it's not in the logs). After following the OpenCore Post-Install guide for Fixing Power Management, Fixing Sleep, and USB-Mapping, as well as enabling Apple Secure Boot (not sure if relevant), I was able to get it past the logs screen and it just turns blank, but it still doesn't completely shut down; the CPU fan is still working, and power button and keyboard backlight are lit. It's worth mentioning that it doesn't restart, it just sits there doing nothing. Restart is actually working as it should.
Additionally, putting it to Sleep doesn't do anything beyond turning off the screen. Moving the mouse or clicking the keyboard turns it back on immediately (though I'm not sure if that's normal macOS behavior - this is my first hackintosh).

Lastly, Bluetooth was working, until I updated to Monterey through the System Preferences (already had OpenCore and everything up-to-date) and everything else worked perfectly. The previous issue with shutdown persisted, and additionally the Bluetooth broke. WiFi worked again by updating the AirportItlwm kext. (However, Bluetooth isn't that important to me. The shutdown issue is more relevant.)

As a side question why wasn't I able to enable Secure Boot in the BIOS settings even after enabling Apple Secure Boot?

I want to fix the shutdown problem at least to switch everything from DEBUG to RELEASE mode (hoping it would boot faster, or at least look better).
Any help is appreciated. I have attached my latest EFI folder. Thank you.
 
Last edited:
Joined
Mar 24, 2022
Messages
4
Motherboard
hp envy x360 convertible 15-bp194cl
CPU
i8550u
Graphics
intel graphic 620
Mobile Phone
  1. iOS
I have the same spec for you ,case the same but now my laptop working all function except Bluetooth
solution for sleep mode and shutdown is to install macOS on ssd make dual boot with windows
if you need my refi text me
 
Joined
Jan 21, 2022
Messages
3
Motherboard
HP 8483 70.31
CPU
Intel Core i7 8550U
Graphics
Intel UHD Graphics 620
I did install macOS on an SSD (it used to be internal but I took it out and put it in the SATA adapter case thing). I did so because I don't use it so often, and I didn't want my first experiment with Hackintoshing to touch my main system at all. Windows is installed on the internal SSD. I don't really understand how dual booting with Windows will fix the problem, but I'd appreciate it if you can send your EFI so I can at least compare.
 
Joined
Mar 24, 2022
Messages
4
Motherboard
hp envy x360 convertible 15-bp194cl
CPU
i8550u
Graphics
intel graphic 620
Mobile Phone
  1. iOS
ok best solution for sleep and shut down after many test working fine in ssd main
 

Attachments

  • EFI.zip
    31.3 MB · Views: 10
Joined
Jan 21, 2022
Messages
3
Motherboard
HP 8483 70.31
CPU
Intel Core i7 8550U
Graphics
Intel UHD Graphics 620
Thank you for your help. This fixed the sleep issue indeed, but shutdown is still broken for me. I guess I'll just have to live with force shutting down or restarting and then powering off from OpenCore.
 
Top