Contribute
Register

Set Clover to prefer iGPU

Joined
Mar 30, 2011
Messages
33
Motherboard
Z170-Ultragaming
CPU
i5-6600k
Graphics
Nvidia 1070
Mac
  1. MacBook
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
Hi,

I've just updated from Mountain Lion to Sierra. Everything is running fine as far as it seems beside the Graphics.

My system has a Z77-DS3H Mainboard with a i5-2500k and a Nvidea 1070. I'm using the 1070 only in Windows and so far I've been running OSX with the Intel HD 3000 internal GPU. To switch between the systems I used profiles in my BIOS in which the iGPU is first preference for OSX. It worked so far without problems.

During the install process clover only was visible in my graphics output from the 1070 (DVI). It's the same now in OSX and as Video Card I only have a 8MB compatibly mode (because there are no drivers for the 1070 of course). In Multibeast I did of course choose the settings for the HD3000 and iGPU. Any way how I can fix that and get my OSX to use the iGPU (connected via HDMI)?

Thanks in advance!

edit: I just tried to switch between HDMI and DVI, but that's not the problem. Video output is still over the 1070
 
Last edited:
Joined
Mar 30, 2011
Messages
33
Motherboard
Z170-Ultragaming
CPU
i5-6600k
Graphics
Nvidia 1070
Mac
  1. MacBook
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
Ok, after some tinkering I found out that I have to unplug the 1070 from the monitor. Then I can get clover to appear on the iGPU and also OSX to boot with it. I'm still confused why I can't switch it in the BIOS anymore.
 
Joined
Jan 13, 2013
Messages
37
Motherboard
G77 UD5H
CPU
i7 3770K @ 4.4 GHz
Graphics
GTX 1080
I have a similar sort of motherboard but I don't have to unplug anything. I checked my settings, looks like the only one I actually changed from default is Init Display First > IGFX. Clover boots using this and OS X says there's 1.5 GB of graphics memory.

edit: I'm not using Sierra...
 
Top