Contribute
Register

Solved > RX 580 Graphics Problem

Joined
Jun 17, 2019
Messages
35
Motherboard
Gigabyte Z390 Gaming X
CPU
Intel Core i7-9700
Graphics
UHD 630
@jiny505,

Please try the following:
  • Delete AMD9500Controller.kext from /Library/Extensions and run Kext Utility to rebuild the kernel cache.
  • Install latest Lilu, WhateverGreen, and AppleALC into /Library/Extensions (if not already done).
  • Then mount EFI partition of the macOS SSD, backup the existing CLOVER folder and copy the attached version in its place (rename the folder to CLOVER).
  • Ensure that your display monitor is connected to the RX 580 and that nothing is connected to any video ports on the rear IO panel.
    • In BIOS, set Initial Display Output to PCIe 1 Slot.
  • Reboot and check "About this Mac" to see if the RX 580 is recognized.
You should also create a custom USB port map by following this guide:
I saw AMD Radeon Rx 580 is plug-in Windows10.
I installed new Catalina, and Library/Extensions are here
Screen Shot 2020-02-27 at 5.03.17 AM.png


I installed Lilu and WhateverGreen and AppleALC with KextBeast to L/E.
And I copied your Clover to EFI/Clover and reboot.

But same problem. Graphics not working...

Screen Shot 2020-02-27 at 9.19.49 AM.png
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
9,532
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I saw AMD Radeon Rx 580 is plug-in Windows10.
I installed new Catalina, and Library/Extensions are here
View attachment 451899

I installed Lilu and WhateverGreen and AppleALC with KextBeast to L/E.
And I copied your Clover to EFI/Clover and reboot.

But same problem. Graphics not working...

Screen Shot 2020-02-27 at 9.19.49 AM.png
Please download IORegistryExplorer from here and run the application. Then just select File --> Save As... to save the IOReg data to a file, and upload that file.

By the way, is your monitor connected to the RX 580? If so, are you using HDMI or DisplayPort?
 
Joined
Jun 17, 2019
Messages
35
Motherboard
Gigabyte Z390 Gaming X
CPU
Intel Core i7-9700
Graphics
UHD 630
Please download IORegistryExplorer from here and run the application. Then just select File --> Save As... to save the IOReg data to a file, and upload that file.

By the way, is your monitor connected to the RX 580? If so, are you using HDMI or DisplayPort?

I upload reg file.
Yes, connected RX 580 and I am using DVI-Port.
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
9,532
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I upload reg file.
Yes, connected RX 580 and I am using DVI-Port.
This shows:
  • Your IGPU is not enabled. Have you enabled Internal Graphics in BIOS?
  • The default non-accelerated video driver is attached to the AMD GPU. macOS is not properly detecting the card.
  • What is the make/model of the RX 580?
  • Have you connected the PCIe power cable(s) on the top of the RX 580?
    • Remember that the RX 580 needs extra power connections.
Your AMD GPU has:
  • Vendor ID 0x1002 --> this is AMD --> good.
  • Device ID 0x6FDF --> this seems WRONG. It should be 0x67DF.
Questions:
  • Does your GPU have a modified VBIOS?
  • Is it a brand new card or did you buy a used card?
 
Last edited:
Joined
Oct 10, 2015
Messages
438
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I just noticed that your graphics card is not RX 580— yours is RX 580 2048SP, yet a normal RX 580 is 2304SP.

They are different GPUs, and RX 580 2048SP is a flashed Chinese-exclusive version of RX 570. It is much trickier than a normal RX 580 and I have not seen any successful case for Hackintosh.
 
Joined
Jun 17, 2019
Messages
35
Motherboard
Gigabyte Z390 Gaming X
CPU
Intel Core i7-9700
Graphics
UHD 630
This shows:
  • Your IGPU is not enabled. Have you enabled Internal Graphics in BIOS?
  • The default non-accelerated video driver is attached to the AMD GPU. macOS is not properly detecting the card.
  • What is the make/model of the RX 580?
  • Have you connected the PCIe power cable(s) on the top of the RX 580?
    • Remember that the RX 580 needs extra power connections.
Your AMD GPU has:
  • Vendor ID 0x1002 --> this is AMD --> good.
  • Device ID 0x6FDF --> this seems WRONG. It should be 0x67DF.
Questions:
  • Does your GPU have a modified VBIOS?
  • Is it a brand new card or did you buy a used card?
  • Your IGPU is not enabled. Have you enabled Internal Graphics in BIOS?
  • - Auto
  • What is the make/model of the RX 580?
  • STRIX-RX580-2048SP-8G-Gaming
  • IMG_0192.jpeg
  • Does your GPU have a modified VBIOS?
  • sorry, I don't know.
  • Is it a brand new card or did you buy a used card?
  • I bought new card.
 

Attachments

Joined
Jun 17, 2019
Messages
35
Motherboard
Gigabyte Z390 Gaming X
CPU
Intel Core i7-9700
Graphics
UHD 630
I just noticed that your graphics card is not RX 580— yours is RX 580 2048SP, yet a normal RX 580 is 2304SP.

They are different GPUs, and RX 580 2048SP is a flashed Chinese-exclusive version of RX 570. It is much trickier than a normal RX 580 and I have not seen any successful case for Hackintosh.
Oh, did it?
No way???
Thanks anyway.
 
Joined
Oct 10, 2015
Messages
438
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Oh, did it?
No way???
Thanks anyway.
If you really want to try this card for Hackintosh, you will have to flash it to RX 570.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
9,532
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
  • Your IGPU is not enabled. Have you enabled Internal Graphics in BIOS?
  • - Auto
That is not correct. It should be set to enabled.
 
Top