Contribute
Register

Realtek ALC1220 (S1220A) Owner Thread

Status
Not open for further replies.

nobodynose

Moderator
Joined
Sep 30, 2012
Messages
4,115
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iBook
  2. iMac
  3. Quadra
Mobile Phone
  1. Android
  2. iOS
Joined
Dec 13, 2016
Messages
76
Motherboard
Gigabyte Z270X Ultra Gaming
CPU
i5-7600K
Graphics
970 GTX
Excuse my ignorance.. so does that mean that I cannot get audio working on my hacintosh? My audio chipset is alc1220.
Yeah, not right now (but USB audio work). It seems like supporting Z270 audio is gonna be hard, harder than other audio codecs.

If I were you I would buy a USB sound card, you can get one for just a few bucks (and a good one for around $20).
 
Joined
Dec 13, 2016
Messages
76
Motherboard
Gigabyte Z270X Ultra Gaming
CPU
i5-7600K
Graphics
970 GTX
Should HDMI audio work or would I need a USB sound card for that to work also? Is there a particular usb sound card I should go for or will any work?

Thanks
I don't know about HDMI audio. Basically any USB sound card should work (just check if it supports Macs), I went with the Creative Sound Blaster Play 2

Edit: EEEEY, I just got sound working natively without USB soundcard :D Just install VoodooHDA 2.8.9 :D :D
 
Last edited:
Joined
Dec 13, 2016
Messages
76
Motherboard
Gigabyte Z270X Ultra Gaming
CPU
i5-7600K
Graphics
970 GTX
hey thanks kris33, just installed voodooHDA 2.8.9 and I now indeed have Audio. However, I do not get any sound over HDMI. Have you managed that?
Yeah, worked fine for me. Just make sure to select the correct HDMI output though, I got four HDMI output options for some reason.
 
Joined
Sep 26, 2015
Messages
126
Motherboard
Gigabyte H270N WiFi
CPU
i5-7500
Graphics
Quadro K1200
Mac
  1. MacBook Pro
The only option it looks like I have is "Digital-Out (HDMI)" when I select this all volume controls disappear and I get no sound through HDMI. Line outs are working properly though.

Do you have USB 3 working by any chance?

I think most USB sound card are 2.0 devices tho. If you want to get USB fully working properly, follow this by Rehabman & Follow this guide by ammulder #1 section 7.2

Not sure what board you are using, I assume it's a 200 series board.
simple round down is like:
1. Increase port limits in KextsToPatch
2. The skylake fix may also be needed(Name=AppleAPIC Find=C1E8100FB6F0 Replace=BE1700000090)
3. DSDT Patch to change EHC to EH0, so your kext will work
4. Install USBInjectAll.kext & XHCI-200-series-injector.kext, I got mine in /L/E
5. Use IOregistryExplorer to learn which port is which when using 2.0 3.0 devices
6. to create your own ACPI patch and place it in EFI/Clover/ACPI/patch
7. disable those ports out of the 15 limits by boot arg, disable the Increase port limit in kextstopatch.
 
Status
Not open for further replies.
Top