Contribute
Register

Razer Blade 15 - High Sierra 10.13.6 - Success(-)

Status
Not open for further replies.
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Have you tired booting back into the installer with Verbose to see what is hanging it up?

Honestly, the EFI folder had files in there from the very beginning of this thread that I got from someone else. They all always worked and I never had an issue, so I never changed them.

Just a heads up for those experiencing freezes and random reboots during or after install. The stock 500gb nvme is a Samsung P981 which is notoriously unstable under OSX. Chalk it up to wishful thinking but I failed to take @vettz500 warning that some of the factory drives don't work and foolishly assumed I must've had a different model. Several hours later, finally gave in and swapped it out for an EVO 960 after which installation was a breeze. Mojave is up and running. Now to work out the kinks. Thanks again!
 
Joined
Jul 23, 2013
Messages
123
Motherboard
Razer Blade 15 (2018)
CPU
I7-8750H
Graphics
GTX 1070HQ
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
Just a heads up for those experiencing freezes and random reboots during or after install. The stock 500gb nvme is a Samsung P981 which is notoriously unstable under OSX. Chalk it up to wishful thinking but I failed to take @vettz500 warning that some of the factory drives don't work and foolishly assumed I must've had a different model. Several hours later, finally gave in and swapped it out for an EVO 960 after which installation was a breeze. Mojave is up and running. Now to work out the kinks. Thanks again!
Glad you got it working! Man... that sucks to hear about the SSD. Guess I'll have to buy a new SSD and try to sell the one it comes with.
 
Joined
Aug 27, 2018
Messages
58
Motherboard
Razer Blade 15 - 2018
CPU
i7-8750H
Graphics
GTX 1070; UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
"The stock 500gb nvme is a Samsung P981 which is notoriously unstable under OSX."

@freejack can you send me some links talking about this? If the stock SSD does not work for hackintosh I think I might just not do it.
 
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Last edited:
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
"The stock 500gb nvme is a Samsung P981 which is notoriously unstable under OSX."

@freejack can you send me some links talking about this? If the stock SSD does not work for hackintosh I think I might just not do it.

Any particular reason you wouldn't want to upgrade it?

Getting one of the Samsung Evos or Pros offer better performance and more storage space as well as more compatibility.

Personally, Razer didn't offer enough storage space stock, even at max configuration, so I always planned on upgrading mine even before trying to hackintosh it.
 
Joined
Jul 23, 2013
Messages
123
Motherboard
Razer Blade 15 (2018)
CPU
I7-8750H
Graphics
GTX 1070HQ
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
Any particular reason you wouldn't want to upgrade it?

Getting one of the Samsung Evos or Pros offer better performance and more storage space as well as more compatibility.

Personally, Razer didn't offer enough storage space stock, even at max configuration, so I always planned on upgrading mine even before trying to hackintosh it.
Anything I should look out for in buying a new drive? I’m seeing some things online that the Samsung 970 series also use the P981 controller. Should I stick with the 960 series?
 
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Anything I should look out for in buying a new drive? I’m seeing some things online that the Samsung 970 series also use the P981 controller. Should I stick with the 960 series?

I believe the issues were exclusive to the PM981. Looks like people have been having success with both the 850 and 970 in Mojave on this forum.
 
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
@vettz500 do you have a working config.plist for Mojave? I'm just about there but having issues with getting backlight controls and sleep to work. I believe you said these two things were natively supported Mojave? The display will go blank once tries to enter sleep but within several seconds the fans will speed up and then reboot. Thanks!

Attached my config.plist
 

Attachments

  • config.plist
    14.4 KB · Views: 121
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Anything I should look out for in buying a new drive? I’m seeing some things online that the Samsung 970 series also use the P981 controller. Should I stick with the 960 series?

I'm using the 970 EVO 2TB without issue.


@vettz500 do you have a working config.plist for Mojave? I'm just about there but having issues with getting backlight controls and sleep to work. I believe you said these two things were natively supported Mojave? The display will go blank once tries to enter sleep but within several seconds the fans will speed up and then reboot. Thanks!

Attached my config.plist

I can't open your config.plist, it looks to be corrupt. But the config.plist I uploaded for the 17G2208 build of High Sierra is compatible with Mojave, I used them same config.plist for both installations without issue.

Sleep will not work until you have brightness control figured out as well as your USB Ports configured properly.

For brightness control to work you need SSDT-PNLF in EFI-Clover-ACPI-Patched as well the AppleBackLightInjector.kext + AppleBackLightFixup.kext + WhateverGreen.kext + Lilu.kext installed to L-E, also your config.plist needs to have the Inject EDID enabled and the product ID set to 0x9c7c. All of those things are available in the EFI+Kexts file attached to this post. It would probably be easier to try and use my Config.plist to start with and just install the Kexts and SSDT that are needed since my config.plist has all the patches and fixes applied already.
The config.plist in this file attached is my most recent/updated one that I just configured last night for proper/natively working audio with the AppleALC.kext

The files you need for USB port configuration (USBInjectAll.kext + SSDT-UIAC-ALL) are also in the file attached.

Lastly, make sure that EmuVariableUefi-64.efi is in EFI-Clover-drivers64UEFI folder. If it isn't you will have issues with sleep, shutdown and restart.

Sidenote: Sleep working properly is also dependent on what you set your SIMBIOS as. I've been using a MacBook Pro 15,2. Other variations might break sleep.
 

Attachments

  • config.plist
    14.9 KB · Views: 133
  • EFI + Kexts 10-26-18.zip
    20.7 MB · Views: 69

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm using the 970 EVO 2TB without issue.




I can't open your config.plist, it looks to be corrupt. But the config.plist I uploaded for the 17G2208 build of High Sierra is compatible with Mojave, I used them same config.plist for both installations without issue.

Sleep will not work until you have brightness control figured out as well as your USB Ports configured properly.

For brightness control to work you need SSDT-PNLF in EFI-Clover-ACPI-Patched as well the AppleBackLightInjector.kext + AppleBackLightFixup.kext + WhateverGreen.kext + Lilu.kext installed to L-E, also your config.plist needs to have the Inject EDID enabled and the product ID set to 0x9c7c. All of those things are available in the EFI+Kexts file attached to this post. It would probably be easier to try and use my Config.plist to start with and just install the Kexts and SSDT that are needed since my config.plist has all the patches and fixes applied already.
The config.plist in this file attached is my most recent/updated one that I just configured last night for proper/natively working audio with the AppleALC.kext

The files you need for USB port configuration (USBInjectAll.kext + SSDT-UIAC-ALL) are also in the file attached.

Lastly, make sure that EmuVariableUefi-64.efi is in EFI-Clover-drivers64UEFI folder. If it isn't you will have issues with sleep, shutdown and restart.

Sidenote: Sleep working properly is also dependent on what you set your SIMBIOS as. I've been using a MacBook Pro 15,2. Other variations might break sleep.

AppleBacklightFixup.kext and AppleBacklightInjector.kext are mutually exclusive.
AppleBacklightInjector.kext is deprecated, replaced by AppleBacklightFixup.kext.
 
Status
Not open for further replies.
Top