Contribute
Register

<< Solved >> Random Kernel Panics

Joined
Dec 30, 2017
Messages
20
Motherboard
z370n WiFi
CPU
i7 9700K
Graphics
RX 580 OEM
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello everyone,

I have been using my build for more than a year now and only recently it began getting random kernel panics.

Bootloader: Opencore 7.3

Hardware specs:
MOBO: z370n wifi
CPU: Coffee Lake i7 9700K
RAM: 32GB
SSD 1: Samsung EVO 970
SSD 2: WD Blue
GPU: RX 580

I have attached a log file. Any help much appreciated.
 

Attachments

  • Panic.txt
    7.3 KB · Views: 13

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,349
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Could be an issue you added by updating your OpenCore setup incorrectly.

If you revert back to OC 0.7.1 do you have the same issues?
 
Joined
Dec 30, 2017
Messages
20
Motherboard
z370n WiFi
CPU
i7 9700K
Graphics
RX 580 OEM
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have downgraded to OC 0.7.1

It has not crashed yet but the logfile still shows some strange errors that were not there before to my knowlegde:

2021-08-28 20:23:33.841588+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> AppleNVMe Assert failed: ( 0 != data )
2021-08-28 20:23:33.841589+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> ReleaseIDNode
2021-08-28 20:23:33.841590+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> file: /System/Volumes/Data/SWE/macOS/BuildRoots/d7e177bcf5/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-557.120.1/Common/IONVMeController.cpp
2021-08-28 20:23:33.841591+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> line: 5669
2021-08-28 20:23:33.841592+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert>
2021-08-28 20:23:33.842778+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> AppleNVMe Assert failed: ( 0 != data )
2021-08-28 20:23:33.842778+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> ReleaseIDNode
2021-08-28 20:23:33.842779+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> file: /System/Volumes/Data/SWE/macOS/BuildRoots/d7e177bcf5/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-557.120.1/Common/IONVMeController.cpp
2021-08-28 20:23:33.842780+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> line: 5669
2021-08-28 20:23:33.842781+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert>
2021-08-28 20:23:33.843967+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> AppleNVMe Assert failed: 0 == (status)
2021-08-28 20:23:33.843968+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> Exit
2021-08-28 20:23:33.843969+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> file: /System/Volumes/Data/SWE/macOS/BuildRoots/d7e177bcf5/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-557.120.1/Common/IONVMeController.cpp
2021-08-28 20:23:33.843970+0200 localhost kernel[0]: (IONVMeFamily) <IONVMeFamily`IONVMeDebugAssert> line: 5718







2021-08-28 20:23:57.380915+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.381068+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.381631+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.381778+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.382342+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.382498+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.383096+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.383240+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.383782+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.383920+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.388776+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.389029+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.390818+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
2021-08-28 20:23:57.391811+0200 localhost kernel[0]: (apfs) <apfs`log_err> apfs_keybag_init:2037: failed to initialize volume keybag, err = 2
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,349
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
The two errors are probably related to one issue - initialisation of your APFS formatted NVME drive.

Which if any NVMe solution are you using?
  1. Do you have NVMeFix.kext in your /OC/Kexts folder and config.plist or
  2. Have you transferred the old config.plist patches from Clover?
A copy of the latest release of NVMeFix.kext v1.0.9, is attached if you need or want to try using the kext with your setup.
 

Attachments

  • NVMeFix-1.0.9-RELEASE.zip
    107.1 KB · Views: 8
Joined
Dec 30, 2017
Messages
20
Motherboard
z370n WiFi
CPU
i7 9700K
Graphics
RX 580 OEM
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
The two errors are probably related to one issue - initialisation of your APFS formatted NVME drive.

Which if any NVMe solution are you using?
  1. Do you have NVMeFix.kext in your /OC/Kexts folder and config.plist or
  2. Have you transferred the old config.plist patches from Clover?
A copy of the latest release of NVMeFix.kext v1.0.9, is attached if you need or want to try using the kext with your setup.

As far as I can remember, I have made a new config.plist when I switched from Clover to OpenCore.



I will give the NVMeFix.kext a try.
The two errors are probably related to one issue - initialisation of your APFS formatted NVME drive.

Which if any NVMe solution are you using?
  1. Do you have NVMeFix.kext in your /OC/Kexts folder and config.plist or
  2. Have you transferred the old config.plist patches from Clover?
A copy of the latest release of NVMeFix.kext v1.0.9, is attached if you need or want to try using the kext with your setup.
It worked for a day and then crashed again :/
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,349
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Have a read of the Acidanthera NVMeFix readme - https://github.com/acidanthera/NVMeFix, see if the additional boot argument they recommend helps any.

I have assumed the NVMe drive is connected to your mATX board using the motherboard connector and the RX580 is connected to the single PCIe x16 slot. That is correct, yes?
 
Joined
Dec 30, 2017
Messages
20
Motherboard
z370n WiFi
CPU
i7 9700K
Graphics
RX 580 OEM
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Have a read of the Acidanthera NVMeFix readme - https://github.com/acidanthera/NVMeFix, see if the additional boot argument they recommend helps any.

I have assumed the NVMe drive is connected to your mATX board using the motherboard connector and the RX580 is connected to the single PCIe x16 slot. That is correct, yes?

Yes, that is correct. The NVMe drive is connected to my mATX board using the motherboard connector and the RX580 is connected to the single PCIe x16 slot.

I will check the readme file.
 
Joined
Dec 30, 2017
Messages
20
Motherboard
z370n WiFi
CPU
i7 9700K
Graphics
RX 580 OEM
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Samsung EVO 970 seems to be the issue here. This info was useful.

Samsung SSDs should be removed from recommended parts in the buyers guide here.
 
Last edited:
Top