Contribute
Register

Quick Fix for Intel HD 4600 Graphics Acceleration on 9 Series Motherboards

Joined
Aug 21, 2013
Messages
20
Motherboard
GA-Z97x-Gaming 3
CPU
i5 4460
Graphics
HD 4600
Mac
Classic Mac
Mobile Phone
iOS
Thanks for the fix! Just two questions:

1.Im getting static just before the log in screen(not a big deal just annoying)
2. How clear is the display suppose to be? (icons are abit rough around the edges)

Hardware:
ga-z97x-gaming 3
i5 4460
 
Joined
Aug 30, 2014
Messages
5
Motherboard
GIGABYTE Z97X-UD3H
CPU
i7 4790K
Graphics
HD4600 (CPU Internal)
Mac
Classic Mac
Mobile Phone
Hi all

i'm new guy of Hackintosh :crazy:

currently i can boot up my PC with Clover. and unexpectedly run into HD4600 with 7MB issue

================

My PC Hardware Info

CPU i7 4790K
Graphics HD4600 (CPU Internal)
System GIGABYTE Z97X-UD3H

================

i read all post of current topic and before i do my change i want make sure all my understood is correct:p

1· download Azul-10.9.4-9series-fixed.zip in topic #1
2· use Kext Wizard to install that kext to /System/Library/Extensions folder
3· change Clover config.plist with PlistEdit Pro ----> config.plist/Graphics/ig-platform-id/0x0300220D
4· reboot

if i am lucky , then everything should ok then.

right?

Q: what's does it mean(in #1):


The specific problem is MEI. MEI is now called dsdt/HECI. dsdt/ssdt injection does not work. An Info.plist edit is required:
Code:
add: IOKitPersonalities/AppleIntelMEIDriver/IOPCIPrimaryMatch/0x8cba8086


how should i do that?

thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
...
Q: what's does it mean(in #1):


The specific problem is MEI. MEI is now called dsdt/HECI. dsdt/ssdt injection does not work. An Info.plist edit is required:
Code:
add: IOKitPersonalities/AppleIntelMEIDriver/IOPCIPrimaryMatch/0x8cba8086


how should i do that?

thanks
Read post #104.
 
Joined
Aug 30, 2014
Messages
5
Motherboard
GIGABYTE Z97X-UD3H
CPU
i7 4790K
Graphics
HD4600 (CPU Internal)
Mac
Classic Mac
Mobile Phone
Read post #104.

yes i saw that one , but still don't know what dose this mean ... :silent:

is that mean , i don need do anything with that ? because

use Kext Wizard instal #1 kext to S/L/E folder is same as edit kext Info.plist manually?

so i just need to ignore it and do the rest of three step i wrote.

is that right?

thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
yes i saw that one , but still don't know what dose this mean ... :silent:

is that mean , i don need do anything with that ? because

use Kext Wizard instal #1 kext to S/L/E folder is same as edit kext Info.plist manually?

so i just need to ignore it and do the rest of three step i wrote.

is that right?
You read post #104, right... because it answered all your questions above.

Answers to your questions (only the sentences that end in ?): Yes, Yes, Yes.

I don't know if the ig-platform-id is appropriate for your hardware. That is up to you to find out. Note that config.plist/Graphics/ig-platform-id has no effect without config.plist/Graphics/Inject/Intel=true.
 
Joined
Aug 30, 2014
Messages
5
Motherboard
GIGABYTE Z97X-UD3H
CPU
i7 4790K
Graphics
HD4600 (CPU Internal)
Mac
Classic Mac
Mobile Phone
hi , i have try 0x0300220D. no luck with it.

so , any other code i can try?

where can i find those code?

any post i should read about?

PS:

i use boot args: -v slide=0 dart=0 darkwake=no npci=0x2000 -gux-defer_usb2 in clover


QQ20140831-1副本.png


QQ20140831-1.png================

My PC Hardware Info


CPU i7 4790K
Graphics HD4600 (CPU Internal)
System GIGABYTE Z97X-UD3H

================


thanks
 
Joined
Aug 30, 2014
Messages
5
Motherboard
GIGABYTE Z97X-UD3H
CPU
i7 4790K
Graphics
HD4600 (CPU Internal)
Mac
Classic Mac
Mobile Phone
:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D

:headbang::headbang::headbang::headbang::headbang::headbang::headbang::headbang::headbang::headbang::headbang::headbang::headbang:

it's working now !!!

thanks guys

love you :)
 

dez

Joined
Feb 2, 2014
Messages
121
Motherboard
Asus X299 Deluxe II
CPU
i9-9940X
Graphics
RX 5700XT
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
So quick note for folks running a GTX 650 Ti Boost or higher, trying to connect a LG Ultrawide Display via HDMI.

If you connect the Panel directly, on a fresh install, you'll be limited to 1080p. However, in my experience, after installing the patched kext in this thread, it enables the same as well. So it not only fixes the IGP, but perhaps also opens up the HDMI interface to higher supported resolutions.

How I arrived at this:
- Connected to OS X 10.9.4 via HDMI: 1080p.
- Connected via Dual DVI-D: 2560x1080, but fuzzy text.
- Connected to Windows 7 via HDMI: 2560x1080. (This confirmed that neither the GPU, HDMI cable, nor the Display was an issue).
- Installed the patched Kext, and voila! 2560x1080 on 10.9.4 using the same HDMI cable.

Spec:
- Asus Maximus VII Ranger.
- Intel i5 4690.
- Asus GTX 650 Ti Boost OC.
- LG 25UM65.

Hope this helps someone.
 
Top