Contribute
Register

Probook4530s only boots from USB installer

Joined
Jul 3, 2013
Messages
64
CPU
i5-7200U
Graphics
Intel 620
Mobile Phone
iOS
i had this working for awhile then my hard drive failed. I replaced the drive and set everything back up the same as before using my installer usb. However, now I cannot boot from internal drive without using the USB drive nor does wifi or sound work as it did before. The only thing that has changed is replacing the hard drive
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i had this working for awhile then my hard drive failed. I replaced the drive and set everything back up the same as before using my installer usb. However, now I cannot boot from internal drive without using the USB drive nor does wifi or sound work as it did before. The only thing that has changed is replacing the hard drive
What version of OS X? You're posting in the Yosemite forum, but your profile says 10.9.0.

What bootloader are you using?

What happens when you attempt to boot from the HDD?
 
Joined
Jul 3, 2013
Messages
64
CPU
i5-7200U
Graphics
Intel 620
Mobile Phone
iOS
I need to update the profile, it was set up when Mavericks was the newest. But I managed to get it fixed. The UEFI Guide was saying to use the "Config and DSDT Patcher" and I didn't do that, I did DSDT patch only or whatever the other option was. Plus when I set up the hard drive, rather than just formatting it, I told it one partition and applied it. So I made a couple changes to the "Guide to Install Yosemite on HP Laptops with Clover UEFI" Guide to get it working properly for me. So this thread can be locked or deleted. I'm going in my profile to change it to show 10.10 instead of 10.9
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I need to update the profile, it was set up when Mavericks was the newest. But I managed to get it fixed. The UEFI Guide was saying to use the "Config and DSDT Patcher" and I didn't do that, I did DSDT patch only or whatever the other option was. Plus when I set up the hard drive, rather than just formatting it, I told it one partition and applied it. So I made a couple changes to the "Guide to Install Yosemite on HP Laptops with Clover UEFI" Guide to get it working properly for me. So this thread can be locked or deleted. I'm going in my profile to change it to show 10.10 instead of 10.9
The guide definitely DOES NOT say to use "DSDT patch only"... That must have been your mistake.
 
Top