Contribute
Register

Problems with Intel HD 4600 resolution on Mavericks 10.9.3

Status
Not open for further replies.
Joined
May 29, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
Hi,

First of all thanks a lot to everybody making installers, guides and replying on the forums, that is a huge help!

I have just build my first hackintosh a few days ago, and had a lot of trouble getting installation to run. After a lot of trial and error, I found a tip to move out all AppleIntelHD* and AppleIntelF* kexts, and that actually made unibeast run and install on the machine.

I can boot with -x, or without if I remove the same kexts, but then I only have a screen resolution of 1024x768.

I have tried all sorts of bios and boot / multilbeast configurations, but no luck. The boot always stops with some blutooth notices as the last thing.

Any suggestions on how I can proceed with this?

Setup:
gigabyte ga-z87n-wifi
i7-4790 Haswell Refresh
Crucial Ballistix SP DDR3-1600 DC
Samsung 840 EVO SSD - 250GB
 
Joined
Apr 8, 2014
Messages
13
Motherboard
GA-Z87-HD3
CPU
i5-4670
Graphics
Intel HD4600, 1600x900
Mac
Classic Mac
Mobile Phone
  1. Android
Hi,

The same problem happened to me. Indeed I installed 10.9.3 with boot flags "IGPEnabler=N -v", but after installing and running MB 6.3, was not able to boot, so also moved AppleIntelHD* and AppleIntelF* and boot without any flags.

BTW, you can change your resolution org.chameleon.Boot.plist by adding this (according to wanted resolution):

<key>Graphics Mode</key>
<string>"1600x900x32"</string>

I am already thinking of trying 10.9.2, but not sure whether it helps...
 
Joined
May 29, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
So I actually got the graphics working, this is what I did:

  1. Set Product Name to MacMini6,2
  2. Followed this advice to configure the graphics card
  3. Set Intel Azul FB to 10
  4. And Graphics mode to 1920x1200x32

I guess step 1 doesn't matter, but right now I am just happy that it works. I might do some divide & conquer to nail it down later.

Also I haven't tested all features of the motherboard, but at least sound and bluetooth seems to be basically working.
 
Joined
Apr 23, 2014
Messages
38
Motherboard
GA-Z87X-UD7-TH
CPU
i7 4770k
Graphics
Intel HD Graphics 4600:
Mac
  1. iMac
Classic Mac
Mobile Phone
Just in case someone comes across this thread like I did, with intel onboard video resolution issues here is what worked for me. I needed 1600 x 1200 for my monitor.

The monitor has VGA and DV inputs but my other computer was on the DV so I wanted the new one on the VGA. Samsung SyncMaster 213T


mini dp to vga adapter = no good. The resolution I needed was not available

I removed the other computer from monitor DVI and used a HDMI to DVI cable for the new computer. When I restarted the machine it was automatically set to the correct 1600 x 1200. Now I just need a longer VGA cable for the old computer.

My new machine info:
Motherboard is the ga z87x ud7 th. It has HDMI and mini DP outputs
Not sure if it matters but I also have windows 7 installed on a seperate drive.
System Software Overview:


System Version: OS X 10.9.3 (13D65)
Kernel Version: Darwin 13.2.0
Boot Volume: Mav
Boot Mode: Normal
Computer Name: Bob’s Mac Pro
User Name: Bob (accountBob)
Secure Virtual Memory: Enabled
Time since boot: 16 minute


Hardware Overview:

Model Name: iMac
Model Identifier: iMac14,2
Processor Name: Intel Core i5
Processor Speed: 3.69 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MultiBeast.tonymacx86.com
SMC Version (system): 1.30f3
Illumination Version: 1.4a6
 
Status
Not open for further replies.
Top