Contribute
Register

Playing any sound reboots my machine

Joined
May 23, 2017
Messages
11
Motherboard
Gigabyte H270N WiFi
CPU
Intel Core i5 3.8 GHz 7600K
Graphics
Gigabyte GTX 1060 6GB
Mac
MacBook Pro
Mobile Phone
iOS
Hi all, maybe you can help me here as I did all day troubleshooting without any progress :(

I have working hackintosh for over a half a year and everything was super fine. Few days/weeks ago I have started to experience random restarts without any kernel panic or other error. Just black screen and then BIOS logo...

After many restarts I have noticed that restart happens after any sound being played. So here is the sequence:

1. I login normally and wait for desktop to appear
2. I can do everything until I generate any system sound, like copy, move to trash, empty trash, unlock preference panel, etc.
3. Right after the sound stops playing there is a reboot

From the beginning I was using AppleALC 1.2.2 with inject_id set to 11 and it was working perfectly. Now I tried AppleALC 1.3.0 but with this kext I don't have any audio device. And when I don't have audio devices I also don't have restarts ;)

I have updated Lilo and Clover to latest versions.

This problem appeared for no reason, at least I didn't notice any software install/update that caused it.
 
Joined
May 23, 2017
Messages
11
Motherboard
Gigabyte H270N WiFi
CPU
Intel Core i5 3.8 GHz 7600K
Graphics
Gigabyte GTX 1060 6GB
Mac
MacBook Pro
Mobile Phone
iOS
Some more testing and trying all AppleALC releases led me to stable solution which is version 1.2.7. It seems to work now and I didn't have any restart since installing it.
 
Top