Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD Vega 56

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,277
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I only have stutters when opening folders with a lot of apps in it launchpad, as I showed in my video. Everything else running smooth.
What kind of drive are you using? If that's the only time you see stuttering, it's possible that there's a delay in reading your directory. Try disabling "Put hard disks to sleep when possible" in Energy Saver System Preference.
 
Joined
Aug 28, 2016
Messages
81
Motherboard
Z390 Gaming Sli
CPU
I7-8700
Graphics
RX 580
Mobile Phone
Android, iOS
Yes, the RX 580 will work fine. Just avoid the XFX brand.

Changing video cards will have no affect on your ethernet. You need to find out which ethernet controller your motherboard uses and install the drivers.
Hi, thanks, I´m aware that changing the video card is one part of the problem. Wich RX580 do you like the most, I've been looking and they all are more around the same price range. Personally I like the Gigabyte Aorus RX580 and the MSI RX Armor. The XFX is a brand that I normally don't care much about.

On the other hand, my motherboard is a Z390 Gaming Sli from Gigabyte, and acording to them in their specs he ethernet card is the Intel® GbE LAN chip (10/100/1000 Mbit).

.

It's not very clear what piece of hardware they are using so I looked up inside intel for a linux driver, and I found this website:


But it is still not clear wich one it is. Moreover, it is a linux driver, I really have no idea how to get the proper driver (kext) for the mojave version. Do you know how?

Thanks again!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,277
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Hi, thanks, I´m aware that changing the video card is one part of the problem. Wich RX580 do you like the most, I've been looking and they all are more around the same price range. Personally I like the Gigabyte Aorus RX580 and the MSI RX Armor. The XFX is a brand that I normally don't care much about.

On the other hand, my motherboard is a Z390 Gaming Sli from Gigabyte, and acording to them in their specs he ethernet card is the Intel® GbE LAN chip (10/100/1000 Mbit).

.

It's not very clear what piece of hardware they are using so I looked up inside intel for a linux driver, and I found this website:


But it is still not clear wich one it is. Moreover, it is a linux driver, I really have no idea how to get the proper driver (kext) for the mojave version. Do you know how?

Thanks again!
I've only used a Sapphire RX 580 on a build for a friend. It has been trouble-free for close to two years.

Use IntelMausiEthernet.kext for your NIC. It's in MultiBeast.
 
Joined
Aug 28, 2016
Messages
81
Motherboard
Z390 Gaming Sli
CPU
I7-8700
Graphics
RX 580
Mobile Phone
Android, iOS
I've only used a Sapphire RX 580 on a build for a friend. It has been trouble-free for close to two years.

Use IntelMausiEthernet.kext for your NIC. It's in MultiBeast.
I installed that kext with multibeast and with kext beast but on Sierra with no luck. So i think I must go to mojave with this hardware.

Let me get an RX580 and I hope the next message I write here will begin with "Success".

Thanks a lot for being so patient and so helpful! Thumbs up!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,277
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I installed that kext with multibeast and with kext beast but on Sierra with no luck. So i think I must go to mojave with this hardware.

Let me get an RX580 and I hope the next message I write here will begin with "Success".

Thanks a lot for being so patient and so helpful! Thumbs up!
Hmm... That should be the correct kext for your NIC. I have no idea why it's not working for you. Maybe try installing it to /EFI/CLOVER/kexts/Other/ and let Clover inject it.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
22,357
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I installed that kext with multibeast and with kext beast but on Sierra with no luck
Worth checking that the Ethernet interface has not somehow become disabled in the BIOS settings.
 
Joined
Dec 1, 2018
Messages
38
Motherboard
ASUS ROG STRIX Z370F
CPU
i7-8700K
Graphics
UHD630
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
What kind of drive are you using? If that's the only time you see stuttering, it's possible that there's a delay in reading your directory. Try disabling "Put hard disks to sleep when possible" in Energy Saver System Preference.
Samsung 960 EVO 256GB NVme. I tried, it doesn't help. I believe it's iGPU related issue, because if I connect 1080p monitor it's not stuttering at all. I found many thread across the internet where owner's of mac mini 8.1 discussed lags and stuttering on 4k monitors. Can you please record how is animation smooth while opening folders in launchpad on that machine?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,277
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Samsung 960 EVO 256GB NVme. I tried, it doesn't help. I believe it's iGPU related issue, because if I connect 1080p monitor it's not stuttering at all. I found many thread across the internet where owner's of mac mini 8.1 discussed lags and stuttering on 4k monitors. Can you please record how is animation smooth while opening folders in launchpad on that machine?
I don't have that many apps on it yet. Lol
 
Top